1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Выгрузка в Xml

Тема в разделе "Базы данных и администрирование", создана пользователем cacti, 19 мар 2010.

Статус темы:
Закрыта.
  1. cacti

    cacti Гость

    Репутация:
    0
    Помогите пожалуйста..опыт в программирование небольшой и я уже просто устала, не знаю что делать. имеется форма где указаны датнач и даткон. Нужно сделать чтобы выгружались все товары справочника номенклатура, которые входят в этот период.

    Процедура ВыгрузитьРеквизитыТовара(ОбъектXML, Товар, Ид = Неопределено)

    Если НЕ ЗначениеЗаполнено(Ид) Тогда

    ИдТовара = СформироватьИдентификатовТовара(Товар.НоменклатураСсылка, Товар.ХарактеристикаСсылка);
    ЗаписатьТекстовойУзел(ОбъектXML, "Ид", ИдТовара);
    Иначе
    ЗаписатьТекстовойУзел(ОбъектXML, "Ид", Ид);
    КонецЕсли;
    ЗаписатьТекстовойУзел(ОбъектXML, "ШтрихКод", Товар.ШтрихКод);
    ЗаписатьТекстовойУзел(ОбъектXML, "Артикул", Товар.Артикул);
    ЗаписатьТекстовойУзел(ОбъектXML, "ЦенаЗаЕдиницу", Товар.Цена);
    ЗаписатьТекстовойУзел(ОбъектXML, "Дата", Товар.Дата);
    ЗаписатьТекстовойУзел(ОбъектXML, "ЕдиницаИзмерения", Товар.ЕдиницаИзмерения);
    ЗаписатьТекстовойУзел(ОбъектXML, "ТипЦены", Товар.ЦеноваяГруппа);
    ЗаписатьТекстовойУзел(ОбъектXML, "Количество", Товар.Количество);
    ЗаписатьТекстовойУзел(ОбъектXML, "Валюта", Товар.Валюта);
    ЗаписатьТекстовойУзел(ОбъектXML, "СтранаПроисхождения", Товар.СтранаПроисхождения);
    ЗаписатьТекстовойУзел(ОбъектXML, "Группа", Товар.Родитель);


    КонецПроцедуры

    Процедура ВыгрузитьКаталог(ОбъектXML, ИмяКаталога, ИдКаталога, ВладелецКаталога, Товары)

    ОбъектXML.ЗаписатьНачалоЭлемента("Каталог");

    ЗаписатьТекстовойУзел(ОбъектXML, "Ид", Строка(ИдКаталога));
    Если НЕ ЗначениеЗаполнено(ИмяКаталога) Тогда
    ИмяКаталога = "Каталог товаров от "+ Строка(ТекущаяДата());
    КонецЕсли;
    ЗаписатьТекстовойУзел(ОбъектXML, "Наименование", ИмяКаталога);
    ВыгрузитьКонтрагента(ОбъектXML, "Владелец", ВладелецКаталога);

    КоличествоВыгруженныхСтрок = 0;
    ОбъектXML.ЗаписатьНачалоЭлемента("Товары");
    Выборка = Товары.Выбрать();
    Пока Выборка.Следующий() Цикл
    Если НЕ Выборка.ЭтоГруппа Тогда
    ОбъектXML.ЗаписатьНачалоЭлемента("Товар");
    ВыгрузитьРеквизитыТовара(ОбъектXML, Выборка);
    ОбъектXML.ЗаписатьКонецЭлемента();
    КоличествоВыгруженныхСтрок = КоличествоВыгруженныхСтрок + 1;
    КонецЕсли;
    КонецЦикла;
    ОбъектXML.ЗаписатьКонецЭлемента();

    ОбъектXML.ЗаписатьКонецЭлемента();

    Сообщить(" Количество выгруженных строк каталога товаров: " + КоличествоВыгруженныхСтрок);

    КонецПроцедуры
     
  2. vitfil

    vitfil IT-интегратор

    Репутация:
    0
    Регистрация:
    2 апр 2004
    Сообщения:
    2.062
    Симпатии:
    0
    Перевести сможете на человеческий язык? Всю жизнь был уверен, что понятие "период" коррелирует с понятием "действие", но никак не с сущностью.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей