Вывести число в таблицу

Тема в разделе "1C и всё что с ней связано", создана пользователем Sollomon, 4 фев 2008.

  1. Sollomon

    Sollomon Гость

    Буду краток, вылаживаю код:
    В Если(Иначе), где стоят знаки вопроса.
    Код (Text):
    Процедура Печать()
    СпрТов = СоздатьОбъект("Справочник.Номенклатура");
    СпрТов.ПорядокКодов();
    СпрТов.ВыбратьЭлементы();
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Пока СпрТов.ПолучитьЭлемент() = 1 Цикл
    ТЭ = СпрТов.ТекущийЭлемент();
    Если ТЭ.ЭтоГруппа() = 1 Тогда
    Код = ТЭ.Код;
    Наз = ТЭ.Наименование;
    Таб.ВывестиСекцию("Группа");
    Иначе
    Код = ТЭ.Код;
    Наз = ТЭ.Наименование;
    ЕдИ = Строка(ТЭ.ЕдИзм);
    ?? ЦенаПост = Строка(ТЭ.ЦенаП);
    ?? ЦенаРеал = Строка(ТЭ.ЦенаР);
    Таб.ВывестиСекцию("Элемент");
    КонецЕсли;
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
    КонецПроцедуры
     
  2. Isabela

    Isabela Гость

    Если ЦенаП и ЦенаР - реквизиты справочника, все будет работать
     
  3. Silver Wind

    Silver Wind Гость

    Возможно ЦенаП и ЦенаР периодические реквизиты, тогда надо использовать метод Получить().
     
  4. Sollomon

    Sollomon Гость

    Совершенно верно, ЦенаП и ЦенаР - периодичны. А, теперь может мне кто-то рассказать, что за переменная такая (как в сказке), заточены мозги уже под Делфи, но жизнь заставляет заняться 1С.
     
  5. Isabela

    Isabela Гость

    Например, так
    ЦенаПост = Строка(ТЭ.ЦенаП.GetValue(WorkingDate()));
    ЦенаРеал = Строка(ТЭ.ЦенаР.GetValue(WorkingDate());
    вместо WorkingDate() можно подставить любую дату
     
Загрузка...

Поделиться этой страницей