Вывести число в таблицу

  • Автор темы Sollomon
  • Дата начала
S

Sollomon

#1
Буду краток, вылаживаю код:
В Если(Иначе), где стоят знаки вопроса.
Код:
Процедура Печать()
СпрТов = СоздатьОбъект("Справочник.Номенклатура");
СпрТов.ПорядокКодов();
СпрТов.ВыбратьЭлементы();
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Таблица");
Таб.ВывестиСекцию("Шапка");
Пока СпрТов.ПолучитьЭлемент() = 1 Цикл
ТЭ = СпрТов.ТекущийЭлемент();
Если ТЭ.ЭтоГруппа() = 1 Тогда
Код = ТЭ.Код;
Наз = ТЭ.Наименование;
Таб.ВывестиСекцию("Группа");
Иначе
Код = ТЭ.Код;
Наз = ТЭ.Наименование;
ЕдИ = Строка(ТЭ.ЕдИзм);
?? ЦенаПост = Строка(ТЭ.ЦенаП);
?? ЦенаРеал = Строка(ТЭ.ЦенаР);
Таб.ВывестиСекцию("Элемент");
КонецЕсли;
КонецЦикла;
Таб.ТолькоПросмотр(1);
Таб.ПараметрыСтраницы(1,100,1);
Таб.Показать("");
КонецПроцедуры
 
I

Isabela

#2
Если ЦенаП и ЦенаР - реквизиты справочника, все будет работать
 
S

Silver Wind

#3
Возможно ЦенаП и ЦенаР периодические реквизиты, тогда надо использовать метод Получить().
 
S

Sollomon

#4
Совершенно верно, ЦенаП и ЦенаР - периодичны. А, теперь может мне кто-то рассказать, что за переменная такая (как в сказке), заточены мозги уже под Делфи, но жизнь заставляет заняться 1С.
 
I

Isabela

#5
Например, так
ЦенаПост = Строка(ТЭ.ЦенаП.GetValue(WorkingDate()));
ЦенаРеал = Строка(ТЭ.ЦенаР.GetValue(WorkingDate());
вместо WorkingDate() можно подставить любую дату