Вывод Картинки На Форму

Тема в разделе "1C и всё что с ней связано", создана пользователем Olgir, 23 мар 2012.

Статус темы:
Закрыта.
  1. Olgir

    Olgir Гость

    Ситуация такая - в базе хранится картинка в виде ХранилищеЗначения. Мне нужно вывести ее на форму.

    Как картинка попала в базу:

    Код (Text):
    &НаКлиенте
    Процедура ЗаписатьДанные()
    МояКартинка = Новый Картинка(ПутьКФайлу);
    ЗаписатьНаСервере(МояКартинка, Объект.Наименование);
    КонецПроцедуры

    &НаСервере
    Процедура ЗаписатьНаСервере(МояКартинка, Наименование)
    ХранилищеКартинки = Новый ХранилищеЗначения(МояКартинка);
    НоваяКартинка = Справочники.Картинки.СоздатьЭлемент();
    НоваяКартинка.Наименование = Наименование;
    НоваяКартинка.Картинка = ХранилищеКартинки;
    НоваяКартинка.Записать();
    КонецПроцедуры;
    Как я ее оттуда забираю:

    Код (Text):
    &НаКлиенте
    Процедура ШапкаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка);
    ШапкаКартинка = ВыбранноеЗначение.Картинка.Получить();
    КонецПроцедуры
    Где выбранное значение - элемент справочника с картинками, ВыбранноеЗначение.Картинка - реквизит типа ХранилищеЗначения, а ШапкаКартинка - элемнет формы типа Картинка.

    После вышеуказанной процедуры ничего не происходит, поле ШапкаКартинка остается пустым. Пробовал делать так:
    Код (Text):
    ИмяФайла = "C:\test.jpg";
    ХранилищеКартинки = ВыбранноеЗначение.Картинка.Получить();
    ХранилищеКартинки.Записать(ИмяФайла);
    Картинка из базы при этом корректно записывается в test.jpg.

    Если ставлю на элементе ШапкаКартинка галочку "Гиперссылка", при нажатии на него появляется нужная картинка в новом окне, но на форме в поле по прежнему пусто.

    Что я делаю не так? Тапками не бросать - я новичек :). Поясните, пожалуйста, как правильно работать с картинками в базе?

    Ах да, это управляемая форма.
     
  2. Olgir

    Olgir Гость

    Отбой, проблему уже решил!
     
  3. Dzo

    Dzo Active Member

    Регистрация:
    13 апр 2009
    Сообщения:
    38
    Симпатии:
    0
    Прошу помощи. Похожая проблема. Торговля и Склад 7.7
    Пытаюсь в стандартую обработку ПечатьПрайса добавить изображение.

    врКод=ТекЭлем.Код;
    врФайлКартинки=КаталогИБ()+"Изображения\"+ВрКод+".jpg";
    Картина=СоздатьОбъект("Картинка");
    Если ФС.СуществуетФайл(врФайлКартинки)=1 Тогда
    Картина.Загрузить(врФайлКартинки);
    КонецЕсли;
    ИсхТабл.ПрисоединитьСекцию("Номенклатура|Картинка");

    В секцию "Номенклатура | Картинка" добавляю картинку, через Таблица-ВставитьРисунок-Текст. И присваиваю ей идентификатор Картина.

    В таблице выходит следующее

    [​IMG]

    Соображений нет, как быть дальше.
    Заранее благодарен!
     
  4. Dzo

    Dzo Active Member

    Регистрация:
    13 апр 2009
    Сообщения:
    38
    Симпатии:
    0
    Так и не решил проблему. Ап. Спасибо.
     
  5. evgenyatam

    evgenyatam Well-Known Member

    Регистрация:
    7 сен 2007
    Сообщения:
    175
    Симпатии:
    0
    выкини создатьОбъект.
     
  6. Dzo

    Dzo Active Member

    Регистрация:
    13 апр 2009
    Сообщения:
    38
    Симпатии:
    0
    Перерыл весь инет, сделал по другому.

    В таблицу вставил секцию Картинка, в нужную ячейку вставил "Таблица-Вставить Рисунок - Текст", в свойствах выбрал "выражение" прописал формулу Рисовать(ИсхТабл.ТекущийОбъект, Путькфайлу)

    Создал функцию

    В процедуре сформировать прописал путь к файлу

    Специально прописал именно один файл, пусть хоть что-нибудь выведет.

    И присаоединил секцию

    Не работает. Где я свернул не туда?
     
  7. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Вот и оно. Надо: "Таблица-Вставить Рисунок - Картинка". В ответ на выбор файла - эскейп.
    А дальше все так.
     
  8. Dzo

    Dzo Active Member

    Регистрация:
    13 апр 2009
    Сообщения:
    38
    Симпатии:
    0
    Спасибо огромное, заработало!
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей