Вывод Картинки На Форму

  • Автор темы Olgir
  • Дата начала
Статус
Закрыто для дальнейших ответов.
O

Olgir

#1
Ситуация такая - в базе хранится картинка в виде ХранилищеЗначения. Мне нужно вывести ее на форму.

Как картинка попала в базу:

Код:
&НаКлиенте
Процедура ЗаписатьДанные()
МояКартинка = Новый Картинка(ПутьКФайлу);
ЗаписатьНаСервере(МояКартинка, Объект.Наименование);
КонецПроцедуры

&НаСервере
Процедура ЗаписатьНаСервере(МояКартинка, Наименование)
ХранилищеКартинки = Новый ХранилищеЗначения(МояКартинка);
НоваяКартинка = Справочники.Картинки.СоздатьЭлемент();
НоваяКартинка.Наименование = Наименование;
НоваяКартинка.Картинка = ХранилищеКартинки;
НоваяКартинка.Записать();
КонецПроцедуры;
Как я ее оттуда забираю:

Код:
&НаКлиенте
Процедура ШапкаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка);
ШапкаКартинка = ВыбранноеЗначение.Картинка.Получить();
КонецПроцедуры
Где выбранное значение - элемент справочника с картинками, ВыбранноеЗначение.Картинка - реквизит типа ХранилищеЗначения, а ШапкаКартинка - элемнет формы типа Картинка.

После вышеуказанной процедуры ничего не происходит, поле ШапкаКартинка остается пустым. Пробовал делать так:
Код:
ИмяФайла = "C:\test.jpg";
ХранилищеКартинки = ВыбранноеЗначение.Картинка.Получить();
ХранилищеКартинки.Записать(ИмяФайла);
Картинка из базы при этом корректно записывается в test.jpg.

Если ставлю на элементе ШапкаКартинка галочку "Гиперссылка", при нажатии на него появляется нужная картинка в новом окне, но на форме в поле по прежнему пусто.

Что я делаю не так? Тапками не бросать - я новичек :). Поясните, пожалуйста, как правильно работать с картинками в базе?

Ах да, это управляемая форма.
 

Dzo

Active member
13.04.2009
38
0
#3
Прошу помощи. Похожая проблема. Торговля и Склад 7.7
Пытаюсь в стандартую обработку ПечатьПрайса добавить изображение.

врКод=ТекЭлем.Код;
врФайлКартинки=КаталогИБ()+"Изображения\"+ВрКод+".jpg";
Картина=СоздатьОбъект("Картинка");
Если ФС.СуществуетФайл(врФайлКартинки)=1 Тогда
Картина.Загрузить(врФайлКартинки);
КонецЕсли;
ИсхТабл.ПрисоединитьСекцию("Номенклатура|Картинка");

В секцию "Номенклатура | Картинка" добавляю картинку, через Таблица-ВставитьРисунок-Текст. И присваиваю ей идентификатор Картина.

В таблице выходит следующее



Соображений нет, как быть дальше.
Заранее благодарен!
 

Dzo

Active member
13.04.2009
38
0
#6
Перерыл весь инет, сделал по другому.

В таблицу вставил секцию Картинка, в нужную ячейку вставил "Таблица-Вставить Рисунок - Текст", в свойствах выбрал "выражение" прописал формулу Рисовать(ИсхТабл.ТекущийОбъект, Путькфайлу)

Создал функцию

Функция Рисовать(Куда, Откуда)
Куда.РежимРисования(3);
Куда.Загрузить(Откуда);
КонецФункции
В процедуре сформировать прописал путь к файлу

Путькфайлу=КаталогИБ()+"Изображения\00005317.jpg";
Специально прописал именно один файл, пусть хоть что-нибудь выведет.

И присаоединил секцию

ИсхТабл.ПрисоединитьСекцию("Номенклатура|Картинка");
Не работает. Где я свернул не туда?
 
Статус
Закрыто для дальнейших ответов.