• Paranoid - курс по анонимности и безопасности в сети от команды codeby. Защита персональных данных, анонимность в сети интернет, настройка виртуальных машин, безопасная передача данных, анти форензика и еще много всего полезного. Подробнее ...

Вызов Форма Элемента

  • Автор темы Zverff
  • Дата начала
Z

Zverff

#1
Есть процедура для создание создание кнопок из Справочника Номенклатура. Как написать которые он кнопки создал, при нажатие их что вышло Форма Элемента
Код:
Процедура ПервоеНажатие(Элемент)
// Вставить содержимое обработчика.
текЛево = 9;
ВыборкаСостояния = Справочники.Номенклатура.Выбрать();
Пока ВыборкаСостояния.Следующий() Цикл
Если ВыборкаСостояния.Родитель.Наименование = "Второе блюдо" Тогда //найдем кнопку по данному элементу
КнопкаНаФорме = ЭлементыФормы.Найти("Код" + ВыборкаСостояния.Код);
Если Не КнопкаНаФорме = Неопределено Тогда
ЭлементыФормы.Удалить(КнопкаНаФорме);
КонецЕсли;
КонецЕсли;
Если ВыборкаСостояния.Родитель.Наименование = "Первое блюдо" Тогда 
текКнопка = ЭлементыФормы.Добавить(Тип("Кнопка"), "Код" + (ВыборкаСостояния.Код), Истина);
текКнопка.Высота = 40;
текКнопка.Ширина = 70;
текКнопка.Заголовок = (ВыборкаСостояния.Наименование);
текКнопка.Верх = 65;
текКнопка.Лево = текЛево;

текЛево = текЛево + текКнопка.Ширина + 7;
Иначе
продолжить;
КонецЕсли;
КонецЦикла;
Элемент.Доступность = Ложь;
Если Элементыформы.Второе.Доступность = Ложь тогда
Элементыформы.Второе.Доступность = Истина;
КонецЕсли;

КонецПроцедуры
 

unknown181538

НеГуру
28.12.2008
1 417
0
#3
Может быть вам нужно использовать "ДобавитьОбработчик()"? Но написали вы непонятно.
 
W

WildAnther

#8
Попробуйте добавить при добавлении кнопки что нибудь типа ЕстьКнопка = Истина, а дальше уже проверять добавили или нет? Если правильно понял вопрос конечно... По форме вот что советует СП
Пример:

Код:
Клиенты = Справочники.Контрагенты;
НовыйКлиент= Клиенты.СоздатьЭлемент();
НовыйКлиент.ПолучитьФорму().Открыть();
Может просто я не правильно понял Вас.)
 
Z

Zverff

#10
Может конфигурацию скинуть? Напишите, скайп или майл. Скину