Вызов Форма Элемента

Тема в разделе "1C и всё что с ней связано", создана пользователем Zverff, 25 ноя 2011.

  1. Zverff

    Zverff Гость

    Есть процедура для создание создание кнопок из Справочника Номенклатура. Как написать которые он кнопки создал, при нажатие их что вышло Форма Элемента
    Код ( (Unknown Language)):
    Процедура ПервоеНажатие(Элемент)
    // Вставить содержимое обработчика.
    текЛево = 9;
    ВыборкаСостояния = Справочники.Номенклатура.Выбрать();
    Пока ВыборкаСостояния.Следующий() Цикл
    Если ВыборкаСостояния.Родитель.Наименование = "Второе блюдо" Тогда //найдем кнопку по данному элементу
    КнопкаНаФорме = ЭлементыФормы.Найти("Код" + ВыборкаСостояния.Код);
    Если Не КнопкаНаФорме = Неопределено Тогда
    ЭлементыФормы.Удалить(КнопкаНаФорме);
    КонецЕсли;
    КонецЕсли;
    Если ВыборкаСостояния.Родитель.Наименование = "Первое блюдо" Тогда
    текКнопка = ЭлементыФормы.Добавить(Тип("Кнопка"), "Код" + (ВыборкаСостояния.Код), Истина);
    текКнопка.Высота = 40;
    текКнопка.Ширина = 70;
    текКнопка.Заголовок = (ВыборкаСостояния.Наименование);
    текКнопка.Верх = 65;
    текКнопка.Лево = текЛево;

    текЛево = текЛево + текКнопка.Ширина + 7;
    Иначе
    продолжить;
    КонецЕсли;
    КонецЦикла;
    Элемент.Доступность = Ложь;
    Если Элементыформы.Второе.Доступность = Ложь тогда
    Элементыформы.Второе.Доступность = Истина;
    КонецЕсли;

    КонецПроцедуры
     
  2. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    Можноболееразвернуто?
     
  3. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Может быть вам нужно использовать "ДобавитьОбработчик()"? Но написали вы непонятно.
     
  4. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    А может "НазначитьДействие()"???
     
  5. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Мой СП такого не знает)
     
  6. Дайнеко

    Дайнеко Well-Known Member
    1C Team

    Регистрация:
    19 ноя 2009
    Сообщения:
    951
    Симпатии:
    0
    Можно более cвернуто?
    Уберите команды не имеющие отношения к вопросу.
     
  7. Zverff

    Zverff Гость

    Никто не сможет помочь что ли?
     
  8. WildAnther

    WildAnther Гость

    Попробуйте добавить при добавлении кнопки что нибудь типа ЕстьКнопка = Истина, а дальше уже проверять добавили или нет? Если правильно понял вопрос конечно... По форме вот что советует СП
    Пример:

    Код ( (Unknown Language)):
    Клиенты = Справочники.Контрагенты;
    НовыйКлиент= Клиенты.СоздатьЭлемент();
    НовыйКлиент.ПолучитьФорму().Открыть();
    Может просто я не правильно понял Вас.)
     
  9. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Вы читаете вообще, что вам отвечают?
     
  10. Zverff

    Zverff Гость

    Может конфигурацию скинуть? Напишите, скайп или майл. Скину
     
  11. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Сюда и выкладывайте
     
Загрузка...
Похожие Темы - Вызов Форма Элемента
  1. k85
    Ответов:
    0
    Просмотров:
    359
  2. alexas1
    Ответов:
    0
    Просмотров:
    505
  3. Sanchezz86
    Ответов:
    1
    Просмотров:
    585
  4. vln1981
    Ответов:
    0
    Просмотров:
    704
  5. JohnLemon
    Ответов:
    1
    Просмотров:
    830

Поделиться этой страницей