Wia.devicemanager

gorlanovmax

Well-Known Member
19.06.2008
286
0
35
Петербург
#1
Проблема такова:
На ХР все работает нормально, дает список доступных устройств, получает снимки и т.д.
На Висте вызов метода DeviceInfos.Count дает в результате 0, хотя камера и сканер подключены

В чем может быть причина?
 

gorlanovmax

Well-Known Member
19.06.2008
286
0
35
Петербург
#3
]]>http://msdn.microsoft.com/en-us/library/ms...28VS.85%29.aspx]]> и далее

проблема в том, что с Си я не очень знаком. Пишу в 1С 7.7.

Я пишу так:

Код:
Перем ИмяФайла, oDevice[5];

ИмяФайла=КаталогИБ()+"Sotrudnik\123.jpg";

Процедура СделатьФото()
Device=CreateObject("WIA.DeviceManager");
Колво = Device.DeviceInfos.Count;
Для Кол=1 По Колво Цикл
Если Device.DeviceInfos(Кол).Type=3 Тогда
Попытка
oDevice[Кол]=Device/DeviceInfos(Кол).Connect();
Исключение
oDevice[Кол]=0;
КонецПопытки;
Иначе
oDevice[Кол]=0;
КонецЕсли;
КонецЦикла;

Для Кол=1 По Колво Цикл
Если oDevice[Кол] <> 0 Тогда
Item=oDevice[Кол].ExecuteCommand("{AF933CAC-ACAD-11D2-A093-00C04F72DC3C}");
Image=Item.Transfer("{557CF401-1A04-11D3-9A73-0000F81EF32E}");
Image.SaveFile(ИмяФайла);
КонецЕсли;
КонецЦикла
КонецПроцедуры
И Переменная Колво получается равной нулю

Объясните дураку, как это написать для Висты
 

vital

Больной Компом Детектед
29.01.2006
2 432
40
codeby.net
#4
<div class="sp-wrap"><div class="sp-head-wrap"><div class="sp-head folded clickable">(Извините за)оффтоп</div></div><div class="sp-body"><div class="sp-content">Посмотрел на исходник выше и ужаснулся, какой все-таки в 1С ужасный язык.. Все вперемешку...
 

gorlanovmax

Well-Known Member
19.06.2008
286
0
35
Петербург
#5
(Извините за)оффтоп
Посмотрел на исходник выше и ужаснулся, какой все-таки в 1С ужасный язык.. Все вперемешку...
Да это я просто так писал коряво. если бы все было на русском или все на англицком, было бы нормально

А по делу никаких советов нет???
 

vital

Больной Компом Детектед
29.01.2006
2 432
40
codeby.net
#6
У меня - нет. Я вообще 1С ни разу в жизни не видел..
 

gorlanovmax

Well-Known Member
19.06.2008
286
0
35
Петербург
#8
Нашел такую штуку:
В Висте в списке DCOM компонентов есть
WIA Device Manager и
WIA Device Manager 2

но у меня не получается создать объект из второго менеджера((((