Проблема WiFi-Pumpkin need PyQt4 :(

z3r0c10wn

Well-known member
04.09.2017
105
200
#21
Сборка:
sudo apt-get install python-qt4

sudo apt-get install libpq-dev python-dev libxml2-dev libxslt1-dev libldap2-dev libsasl2-dev libffi-dev libtiff5-dev libjpeg62-turbo-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

cd WiFi-Pumpkin

sudo pip install -r requirements.txt

sudo pip install service_identity

sudo pip install scapy_http

sudo apt-get install mitmproxy

Запускаемся под рутом(если есть проблемы с X11):
$ su
# export QT_X11_NO_MITSHM=1
# wifi-pumpkin
Если не помогло - релогин(X-сессия) в рут - чек работает или нет.

Если в ошибках - по прежнему ошибки qt4 - соберитесь руками.


**Я не могу понять установилось ли у меня qt4 или нет**

Создай простой файл test.py
Код:
import sys
from PyQt4.QtGui import *
app = QApplication(sys.argv)
button = QPushButton("Hello World", None)
button.show()
app.exec_()
python test.py
upload_2017-12-25_7-59-42.png
 

vimka

Member
13.02.2016
7
0
#22
Сборка:
sudo apt-get install python-qt4

sudo apt-get install libpq-dev python-dev libxml2-dev libxslt1-dev libldap2-dev libsasl2-dev libffi-dev libtiff5-dev libjpeg62-turbo-dev zlib1g-dev libfreetype6-dev liblcms2-dev libwebp-dev tcl8.6-dev tk8.6-dev python-tk

cd WiFi-Pumpkin

sudo pip install -r requirements.txt

sudo pip install service_identity

sudo pip install scapy_http

sudo apt-get install mitmproxy

Запускаемся под рутом(если есть проблемы с X11):
$ su
# export QT_X11_NO_MITSHM=1
# wifi-pumpkin
Если не помогло - релогин(X-сессия) в рут - чек работает или нет.

Если в ошибках - по прежнему ошибки qt4 - соберитесь руками.


**Я не могу понять установилось ли у меня qt4 или нет**

Создай простой файл test.py
Код:
import sys
from PyQt4.QtGui import *
app = QApplication(sys.argv)
button = QPushButton("Hello World", None)
button.show()
app.exec_()
python test.py
Посмотреть вложение 14016
[doublepost=1514222485,1514222163][/doublepost]попытался запустить python.py вот такая херня вылезла
 

Вложения

z3r0c10wn

Well-known member
04.09.2017
105
200
#25
[doublepost=1514222485,1514222163][/doublepost]попытался запустить python.py вот такая херня вылезла
У вас ошибка в обработке QT-X11 ему либо прав не хватает, либо у вас не подстроен root на x11
Чтобы проверить данное утверждение рекомендую запустить Иксы под рутом (то есть не посредственно залогиньтесь в рута) и запустите скрипт.

Так же может помочь проверить следующая схема:
# export QT_X11_NO_MITSHM=1
python script.py


Жду логи ошибки в студию
P.S. Кстати как видно из вывода Hello World - QT у вас установлен и работает.