Xml 1С8

Тема в разделе "1C и всё что с ней связано", создана пользователем ech, 12 авг 2009.

  1. ech

    ech Гость

    Добрый день! Подскажите пож-та, как из файла .xml загрузить данные в поля ввода и табличную часть документа? Вот код, который наваял.

    Процедура КнопкаВыполнитьНажатие(Кнопка)
    ИмяФайла= "С:\s4et.xml";
    Чтение = Новый ЧтениеXML;
    Чтение.ОткрытьФайл(ИмяФайла);
    Имя = Чтение.Имя;
    Массив = Новый Структура(Имя);
    Пока Чтение.Прочитать() Цикл
    ПолучитьXMLТип(Чтение);
    Если Чтение.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда
    Имя = Чтение.Имя;
    Пока Чтение.ПрочитатьАтрибут() Цикл
    Атрибут = Чтение.Значение;
    КонецЦикла;
    КонецЕсли;
    Если Чтение.ТипУзла = ТипУзлаXML.Текст Тогда
    Массив.Вставить(Имя,Чтение.Значение);
    КонецЕсли;
    Если Чтение.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда
    ДобавитьЭлемент(Массив);
    КонецЕсли;
    КонецЦикла
    КонецПроцедуры

    Записывает только номер счета, на остальные тэги ругаеться, что не обнаружены.
     
  2. ech

    ech Гость

    что никто не знает?
     
  3. thinkfast

    thinkfast Гость

    Звиняй, я именно xml выгрузку ни разу не писал. А посидеть почитать/разобраться просто нету времени.
     
  4. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Выложили б образец файла.
     
  5. ech

    ech Гость

    образца файла нет я его сам придумываю.
     
  6. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    А может, если сам структуру придумываешь, использовать формат TXT или DBF - там все гораздо прозрачнее и головной боли не будет.
     
  7. ech

    ech Гость

    дело в том, что счет фактура в последствии будет выгружаться из интернет-магазина, в формат хмл, так что по другому никак! вот я как раз придумываю структуру хмл счет фактуры, а вот как загрузить ее 1С 8.1. возникли проблемы, + как загрущить табличную часть????
     
  8. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    А в другой формат, значит, никак ?
     
  9. ech

    ech Гость

    разработчики сайта сказали, что будет формат хмл только+продумать мне структуру загрузки , т.е. какие данные нужны в этом файлике, в 1С 7.7 я загружал/выгружал данные через хмл файлы без проблем, а вот в 1С 8.1 трудновато.
    Если кто поможет, бужу благодарен.
     
  10. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    У меня он ругался вовсе не на отсутствие тега, а на отстуствие элемента в структуре.
    И дата в XML, вообще говоря, имеет другой вид.
    Также непонятно, что у вас корневой элемент, а что начало документа "Счет".
     
  11. ech

    ech Гость

    стратил, корневой элемент Сет.
    Ваш вариант намного работоспособней моего, спасибо за помощь!
     
  12. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Я бы добавил еще тэг, отмечающий начало документа, т.к., как я понимаю, в одном файле может быть несколько счетов.
     
  13. ech

    ech Гость

    в одном файле будет один счет.
     
  14. ech

    ech Гость

  15. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    А в массиве сколько элементов номенклатуры?
    Может вам цикл использовать?)
     
  16. ech

    ech Гость

    да вот цикл то мне и нужен, надо определиться только какой
     
  17. ech

    ech Гость

    тема закрыта
     
Загрузка...

Поделиться этой страницей