За Двоился Спр.единица Изм.

Тема в разделе "1C и всё что с ней связано", создана пользователем MelU, 17 ноя 2011.

Статус темы:
Закрыта.
  1. MelU

    MelU Гость

    В номенклатура при выборе ЕХО дает на выбор 2-ед. из них правильная одна(открываю в спр.ном. закладку ЕИ, правильная выделенная жирным). Когда создавался ШК он выбрал неправильную ЕИ, когда я печатаю этикетки ШК не выходит на печать. рис. 1 1.jpg Теперь хочу сделать замену у ШК ЕИ на правильную ... вот только как ?
    Вот наброски


    Процедура КнопкаВыполнитьНажатие(Кнопка)
    Спр = Справочники.Номенклатура.НайтиПоКоду("УТ000000910");
    КодОЕ = Спр.ЕдиницаХраненияОстатков.Код;


    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьМенеджерЗаписи();
    НаборЗаписей.ЕдиницаИзмерения = КодОЕ
    КонецПроцедуры

    Хочется пока только для выбранной ном. исправить у ее ШК ЕИ ... подскажите более корректный код ...
     
  2. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Код ( (Unknown Language)):
    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.Владелец.Уставноить(Номенклатура);
    НаборЗаписей.Прочитать();
    дЛЯ каждого Тек Из НаборЗаписей Цикл
    Тек.ЕдиницаИзмерения = НужнаяЕдиница;
    КонецЦикла;
    НаборЗаписей.ЗАписать();
     
  3. MelU

    MelU Гость


    Пишет.

    Штрихкод: 03X01-01308 уже имеет владельца "Серьги -03X01-01308".
     
  4. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Перед "Для каждого" проверьте количество в наборе. сколько там у вас строк?
     
  5. MelU

    MelU Гость


    Одна
     

    Вложения:

  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Может быть у вас заведен этот штрихкод на 2 разных товара?
     
  7. MelU

    MelU Гость

    Итого сделал вот так
    1 шаг. удаляю ШК из РегистраСведений.ШтрихКод

    ТипШтрихкода_ = ПланыВидовХарактеристик.ТипыШтрихкодов.НайтиПоКоду("000000005");

    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();
    НаборЗаписей.Отбор.ТипШтрихкода.Установить(ТипШтрихкода_);//т.к. у нас для товаров свой типШК? вот по нему и сделал отбор
    НаборЗаписей.Записать();

    2 шаг. заношу новый ШК в РегистраСведений.ШтрихКод

    Номенклатура = Справочники.Номенклатура.Выбрать(полеВводаРодителя);

    Пока Номенклатура.Следующий() Цикл

    Ном = Номенклатура.Наименование;
    Штрихкод_ = Номенклатура.Артикул;
    КодОЕ = Номенклатура.ЕдиницаХраненияОстатков;
    Качество_ = Справочники.Качество.Новый;

    НаборЗаписей = РегистрыСведений.Штрихкоды.СоздатьНаборЗаписей();

    НаборЗаписей.Отбор.ЕдиницаИзмерения.Установить(КодОЕ);

    НоваяЗапись = НаборЗаписей.Добавить();

    НоваяЗапись.Владелец = Номенклатура.Ссылка;
    НоваяЗапись.ЕдиницаИзмерения = КодОЕ;
    НоваяЗапись.Качество = Качество_;
    НоваяЗапись.ТипШтрихкода = ТипШтрихкода_;
    НоваяЗапись.Штрихкод = Штрихкод_;

    НаборЗаписей.Записать();

    КонецЦикла;


    Может есть лучший вариант, но я сделал вот так ... только медленно работает на 5000 наименований(((
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей