Запись документа.

  • Автор темы Greml1N
  • Дата начала
G

Greml1N

Гость
#1
Всем привет!!!!
Такое дело. Создаётся обработка которое делает нужные ей вещи.А точнее формирует Проводки созданные вручную документы "ОперацияБух". В конце обработки стоит Док.Записать(). Всё вроде бы хорошо. Документы создаются и записуются. Но вот что странно они не проводятся.Хотя значок как будто всё хорошо. При открытии созданного документа и нажатии ОК всё проводится,и все проводки проходят. Вопрос: Почему док не проводится?

P.S: Так же стоит Док.Проведен=Истина,не помогает.
1с.Бух.1.6.24
Платформа 1с 8.1.14
 
G

Greml1N

Гость
#3
Не ну если создавать руками это понятно. А у меня всё идёт через код. Создаётся Документ,записывается. Но блин он не проводится,ОСВ его не видит. Но если я созданный документ програмно,открою в пользовательском режиме Нажму ОК,он нормально проведётся.
 
G

Greml1N

Гость
#5
Когда вручную создаётся документ Операции,то она проводки нормально всё делаются и в ОСВ всё отображается.Но когда программно через код создаёшь то док записуется,но в ОСв не отображается до тех пор пока не откроешь и не нажмёшь Ок. Код тут в принципе не поможет но всё же вот:


Процедура КнопкаВыполнитьНажатие(Кнопка)


Нач=ЭлементыФормы.Дата.Значение;
Кон=ЭлементыФормы.ПолеВвода1.Значение;
кон=КонецДня(Кон);
Счет=ЭлементыФормы.ПолеВвода2.Значение;
Запрос = Новый запрос;
Запрос.Текст= "ВЫБРАТЬ
| ХозрасчетныйОбороты.Счет КАК счет,
| ХозрасчетныйОбороты.Субконто1 КАК суб1,
| ХозрасчетныйОбороты.Субконто2 КАК суб2,
| ХозрасчетныйОбороты.Субконто3 КАК суб3,
| ХозрасчетныйОбороты.Организация КАК организация,
| ХозрасчетныйОбороты.СуммаОборот КАК СуммаОборот
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Обороты(&НачалоПериода, &КонецПериода, , , , , , ) КАК ХозрасчетныйОбороты
|ГДЕ
| ХозрасчетныйОбороты.Счет = &Счет
|
|СГРУППИРОВАТЬ ПО
| ХозрасчетныйОбороты.Субконто1,
| ХозрасчетныйОбороты.Субконто2,
| ХозрасчетныйОбороты.Субконто3,
| ХозрасчетныйОбороты.Счет,
| ХозрасчетныйОбороты.Организация,
| ХозрасчетныйОбороты.СуммаОборот
|ИТОГИ ПО
| ОБЩИЕ";


Запрос.УстановитьПараметр("НачалоПериода",Нач);
Запрос.УстановитьПараметр("КонецПериода",Кон);
Запрос.УстановитьПараметр("Счет",Счет);
Результат=Запрос.Выполнить();
Выборка=Результат.Выбрать();
Пока Выборка.Следующий() цикл


Док=Документы.ОперацияБух.СоздатьДокумент();
ФормаДок = Док.ПолучитьФорму("ФормаДокумента");
Док.Дата=Кон;
Док.Организация=Выборка.организация;
//ФормаДок.Открыть();
ВЫ=Док.Движения.Хозрасчетный.Добавить();
ВЫ.СчетКт=Счет;
вы.Период=Кон;
Вы.СчетДт=ПланыСчетов.Хозрасчетный.ПрочиеРасходы;
Вы.Сумма=Выборка.СуммаОборот;
Вы.СубконтоКт.Подразделения=Выборка.Суб1;
Вы.СубконтоКт.СтатьиЗатрат=Выборка.Суб3;
Вы.СубконтоКт.НоменклатурныеГруппы=Выборка.Суб2;
//Вы.СубконтоДт.ПрочиеДоходыиРасходы=Расх;


Док.СуммаОперации=Вы.Сумма;








Если Выборка.СуммаОборот = null
тогда
Продолжить

Иначе

Док.Записать();
Док.Проведен=Истина;

КонецЕсли;
КонецЦикла;


КонецПроцедуры
 

tanat

Well-Known Member
02.03.2007
265
0
#6
ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение)
 

unknown181538

НеГуру
28.12.2008
1 417
0
30
Москва
#9
.Но когда программно через код создаёшь то док записуется,но в ОСв не отображается до тех пор пока не откроешь и не нажмёшь Ок. Код тут в принципе не поможет но всё же вот:
Отображается в ОСВ :rolleyes: Вы Shift+f4 не пробовали)
Чтение неверного кода не помогает его исправлению?)
 
K

kaa

Гость
#11
Цитата:
(tanat @ 26:11:2010, 10:39 )

 
ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение)



Пробовал не помогает. Для данного дока не предусмотрено проведение.

ДокументОбъект.Записать(РежимЗаписиДокумента.Запись)
 
G

Greml1N

Гость
#12
Цитата:
(tanat @ 26:11:2010, 10:39 )

 
ДокументОбъект.Записать(РежимЗаписиДокумента.Проведение)



Пробовал не помогает. Для данного дока не предусмотрено проведение.

ДокументОбъект.Записать(РежимЗаписиДокумента.Запись)
Попробовал то же 0 эмоций.