Запрет редактирования документов

  • Автор темы randa
  • Дата начала
R

randa

#1
Доброго времени суток!
Есть две базы Основная и Перефийрийная, настроен полный обмен данными.

Необходимо чтобы Перефирийная база видела документы Основной но не могла их редактировать.

вот реализовал вот так

Процедура ПередЗаписьюДокументаАвторТекущийПользовательПереферийнаяПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт

Если Источник.Автор <> глТекущийПользователь Тогда
Отказ=истина;
КонецЕсли;

Если Отказ Тогда
Сообщить("Запрещено редактирование документов этого пользователя",);
КонецЕсли;

подскажите как описать условие, если документ новый продолжить?!

Если ЭтоНовый() Тогда

???????????????????????

и проверка по Переферийной базе

подскажите как это сделать по переф.и при создании нового документа
 

Darlock

Well-known member
04.01.2008
560
1
#2
Код:
Процедура ПриОткрытии()

ЭтаФорма.ТолькоПросмотр = Не ЭтоНовый();

КонецПроцедуры