1. Набираем команду codeby webinar. Набираем команду для организации и проведения вебинаров. Подробнее ...

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление
  3. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление

Запрет редактирования документов

Тема в разделе "Базы данных и администрирование", создана пользователем randa, 6 авг 2010.

  1. randa

    randa Гость

    Репутация:
    0
    Доброго времени суток!
    Есть две базы Основная и Перефийрийная, настроен полный обмен данными.

    Необходимо чтобы Перефирийная база видела документы Основной но не могла их редактировать.

    вот реализовал вот так

    Процедура ПередЗаписьюДокументаАвторТекущийПользовательПереферийнаяПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт

    Если Источник.Автор <> глТекущийПользователь Тогда
    Отказ=истина;
    КонецЕсли;

    Если Отказ Тогда
    Сообщить("Запрещено редактирование документов этого пользователя",);
    КонецЕсли;

    подскажите как описать условие, если документ новый продолжить?!

    Если ЭтоНовый() Тогда

    ???????????????????????

    и проверка по Переферийной базе

    подскажите как это сделать по переф.и при создании нового документа
     
  2. Darlock

    Darlock Well-Known Member

    Репутация:
    0
    Регистрация:
    4 янв 2008
    Сообщения:
    560
    Симпатии:
    1
    Код:
    Процедура ПриОткрытии()
    
    ЭтаФорма.ТолькоПросмотр = Не ЭтоНовый();
    
    КонецПроцедуры
     
  3. vbs

    vbs Well-Known Member

    Репутация:
    0
    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Неплохо бы исправить это убожество
     
Загрузка...

Поделиться этой страницей