Запрет редактирования документов

Тема в разделе "1C и всё что с ней связано", создана пользователем randa, 6 авг 2010.

  1. randa

    randa Гость

    Доброго времени суток!
    Есть две базы Основная и Перефийрийная, настроен полный обмен данными.

    Необходимо чтобы Перефирийная база видела документы Основной но не могла их редактировать.

    вот реализовал вот так

    Процедура ПередЗаписьюДокументаАвторТекущийПользовательПереферийнаяПередЗаписью(Источник, Отказ, РежимЗаписи, РежимПроведения) Экспорт

    Если Источник.Автор <> глТекущийПользователь Тогда
    Отказ=истина;
    КонецЕсли;

    Если Отказ Тогда
    Сообщить("Запрещено редактирование документов этого пользователя",);
    КонецЕсли;

    подскажите как описать условие, если документ новый продолжить?!

    Если ЭтоНовый() Тогда

    ???????????????????????

    и проверка по Переферийной базе

    подскажите как это сделать по переф.и при создании нового документа
     
  2. Darlock

    Darlock Well-Known Member
    1C Team

    Регистрация:
    4 янв 2008
    Сообщения:
    558
    Симпатии:
    0
    Код ( (Unknown Language)):
    Процедура ПриОткрытии()

    ЭтаФорма.ТолькоПросмотр = Не ЭтоНовый();

    КонецПроцедуры
     
  3. vbs

    vbs Well-Known Member

    Регистрация:
    18 фев 2007
    Сообщения:
    1.708
    Симпатии:
    3
    Неплохо бы исправить это убожество
     
Загрузка...

Поделиться этой страницей