Запрет в документе

  • Автор темы Eraser
  • Дата начала
Статус
Закрыто для дальнейших ответов.
E

Eraser

#1
Вопрос состоит в том как можно запретить пользователю закрытие нового документа без сохранения 1с 8.1
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#2
Стесняюсь спросить, а для чего это надо?
 
H

Hryv

#4
Может тогда лучше не давать печатать пока не сохранили?
 

puh14

Well-known member
11.07.2008
1 412
0
#5
даже в семерке бух в полномочиях пользователей(справочник) была опция запрета расчечатки непроведенных документов. Думаю что и в восьмерку это перекочесвало.
 

vitfil

IT-интегратор
02.04.2004
2 062
0
#6
Eraser, ничего более полного для написанного выше товарищами добавить не могу.
 
E

Eraser

#8
Большое спасибо попробуем такие варианты
Процедура ПечатьНакладной(Элемент)


Если ЭтоНовый() тогда
Предупреждение("Документ НЕ сохранен! Печать без сохранения невозможна.");
Иначе
ТабДок = Новый ТабличныйДокумент;
Макет = Документы.РасходнаяНакладная.ПолучитьМакет("НакладнаяПолная");

Концесли;
КонецПроцедуры

Воплотил таким макаром посмотрим на что єто повлияет
 

evgenyatam

Well-known member
07.09.2007
175
0
#9
в типовых конфигурациях восьмерки не только жестко запрещено печатать документ без записи, но и код который собирает данные для печати не может работать с не записанными документами. а если документ записан, но изменен в форме то теоретически он не должен видеть изменений (таких экспериментов не проводил).
 

Дайнеко

Well-known member
19.11.2009
951
0
#10
Я практикую такую вариацию (применительно к 7):

Процедура Печать()
Если НЕ(Выбран()=1) Тогда
Записать();
КонецЕсли;
Далее печать.

Наверно так хочет шеф: если документ печатался, он молча сохраняется. А лишние вопросы и клики "Сохранить" пользователей раздражают.
 
E

Eraser

#11
Я практикую такую вариацию (применительно к 7):

Процедура Печать()
Если НЕ(Выбран()=1) Тогда
Записать();
КонецЕсли;
Далее печать.

Наверно так хочет шеф: если документ печатался, он молча сохраняется. А лишние вопросы и клики "Сохранить" пользователей раздражают.
Спасибо!!! пригодилось
 
Статус
Закрыто для дальнейших ответов.