запрос 7.7

Тема в разделе "1C и всё что с ней связано", создана пользователем Renat11111, 5 май 2009.

  1. Renat11111

    Renat11111 Well-Known Member

    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0
    Сей запрос В группировке по счету дает адекватные данные токо по д*цензура*овому обороту по счету. Все остальное не приавильно. Что нужно подправить? что сделал не так? токо пожалуйста не предлагайте бух итогами делать....

    |Период с ДатаНач по ДатаКон;

    |Обрабатывать НеПомеченныеНаУдаление;
    |Счет = Операция.Д*цензура*.Счет, Операция.Кредит.Счет;
    |ЭкономКлассифРасходов = Операция.Д*цензура*.ЭкономКлассифРасходов, Операция.Кредит.ЭкономКлассифРасходов;
    |Сумма = Операция.Сумма;
    |Функция СндСумма = СНД(Сумма);
    |Функция ДОсумма = ДО(Сумма);
    |Функция КОсумма = КО(Сумма);
    |Функция СКДСумма = СКД(Сумма);
    |Группировка Счет;
    |Группировка ЭкономКлассифРасходов;
    |Условие (Счет=Счет_120);
    |Условие (ЭкономКлассифРасходов в СписокКлассификаторов);
     
  2. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    а чем ты так не любишь бухитоги? в семерке это же святая святых))))
     
  3. Renat11111

    Renat11111 Well-Known Member

    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0
    Да бух итогами сделал..... хочу запросом и не могу, что то не то.
     
  4. KiR

    KiR НЕ шибка опытный програмер)
    1C Team

    Регистрация:
    11 сен 2007
    Сообщения:
    1.581
    Симпатии:
    0
    а запрос тут просто настолько кривое нечтно, что действительно фиг поймет как оно работает! я тож как-то с подобной задачей долбался по учебнику, потом плюнул и пользую бухитоги)
     
  5. puh14

    puh14 Well-Known Member
    1C Team

    Регистрация:
    11 июл 2008
    Сообщения:
    1.412
    Симпатии:
    0
    поубирай условия, или выбирай их в диалоге - подобный запрос стопудово пашет. Кстати - а СНК,СКК небе не надо значть?
     
  6. Renat11111

    Renat11111 Well-Known Member

    Регистрация:
    20 апр 2008
    Сообщения:
    123
    Симпатии:
    0
    в условиях список значений не вижу смысла если честно его в диалоге размещать. СНК, СКК не нужно. счет то активный у меня. Бух итогами
    вот так делаю мне казалось что запросом легче будет и лучше оказывается наоборот: кто чего еще подскажет буду рад. всем ответившим спасибо.

    ИтогоПоКредиту = Ит.КО();
    ИтогоСНД = Ит.СНД();
    ИтогоПоД*цензура*у = Ит.ДО();
    ИтогоСКД = Ит.СКД();

    Таб.ВывестиСекцию("ИтогоПоКредиту|ДанныеДокумента");

    РазмерСписка = СписокКлассификаторов.РазмерСписка();
    для I = 1 по РазмерСписка Цикл

    ТекКлассификатор = СписокКлассификаторов.ПолучитьЗначение(I);
    Если Ит.ПолучитьСубконто(1,,ТекКлассификатор)=1 Тогда
    ИтогПоКлассификатору = Ит.КО();
    Иначе
    ИтогПоКлассификатору = 0;
    КонецЕсли;

    Таб.ПрисоединитьСекцию("ИтогоПоКредиту|СпрКлассификаторов");
    КонецЦикла;



    Таб.ВывестиСекцию("Пустая");
    Таб.ВывестиСекцию("СальдоНач|ДанныеДокумента");

    РазмерСписка = СписокКлассификаторов.РазмерСписка();
    для I = 1 по РазмерСписка Цикл

    ТекКлассификатор = СписокКлассификаторов.ПолучитьЗначение(I);
    Если Ит.ПолучитьСубконто(1,,ТекКлассификатор)=1 Тогда
    СНДКлассификатор = Ит.СНД();
    Иначе
    СНДКлассификатор = 0;
    КонецЕсли;

    Таб.ПрисоединитьСекцию("СальдоНач|СпрКлассификаторов");
    КонецЦикла;



    Таб.ВывестиСекцию("Пустая");
    Таб.ВывестиСекцию("ИтогоПоД*цензура*у|ДанныеДокумента");
    РазмерСписка = СписокКлассификаторов.РазмерСписка();
    для I = 1 по РазмерСписка Цикл

    ТекКлассификатор = СписокКлассификаторов.ПолучитьЗначение(I);
    Если Ит.ПолучитьСубконто(1,,ТекКлассификатор)=1 Тогда
    ДОКлассификатор = Ит.ДО();
    Иначе
    ДОКлассификатор = 0;
    КонецЕсли;

    Таб.ПрисоединитьСекцию("ИтогоПоД*цензура*у|СпрКлассификаторов");
    КонецЦикла;

    Таб.ВывестиСекцию("Пустая");
    Таб.ВывестиСекцию("СальдоКон|ДанныеДокумента");
    РазмерСписка = СписокКлассификаторов.РазмерСписка();
    для I = 1 по РазмерСписка Цикл

    ТекКлассификатор = СписокКлассификаторов.ПолучитьЗначение(I);
    Если Ит.ПолучитьСубконто(1,,ТекКлассификатор)=1 Тогда
    СКДКлассификатор = Ит.СКД();
    Иначе
    СКДКлассификатор = 0;
    КонецЕсли;

    Таб.ПрисоединитьСекцию("СальдоКон|СпрКлассификаторов");
    КонецЦикла;
     
Загрузка...

Поделиться этой страницей