Запрос

  • Автор темы Orc
  • Дата начала
Статус
Закрыто для дальнейших ответов.
O

Orc

Гость
#1
Здравствуйте всем!

Подскажите неумному!!!
Есть такой простенький запросик:

|Спр=Справочник.Сотрудники.ТекущийЭлемент;
|Группировка Спр;
|Условие (Спр.ЭтоГруппа()=1);

И строчка
|Условие (Спр.ЭтоГруппа()=1);
не работает, причем Если вместо 1 поставить 0 то все работает очень даже правильно!!!
Где я недопетрил?!?!?!
Заранее благодарю!
 
7

77dpi

Гость
#3
и при такой группировке (без условий)

|Группировка Спр Без Упорядочивания Все ;

пустые группы(без детей) не попадают в выборку

а при обходе выборки ЭтоГруппа() работает:

Пока Запрос.Группировка(1) = 1 Цикл
Если Запрос.ТекущийЭлемент.ЭтоГруппа()=1 Тогда
Сообщить(""+Запрос.ТекущийЭлемент);
КонецЕсли;
КонецЦикла;

много в 77 загадочного.
 
O

Orc

Гость
#4
Попробуй
|Группировка Спр Все;
Спасибо, конечно, но группировки я попробовал всевозможные - дело не в этом! (((

а при обходе выборки ЭтоГруппа() работает:

Пока Запрос.Группировка(1) = 1 Цикл
Если Запрос.ТекущийЭлемент.ЭтоГруппа()=1 Тогда
Сообщить(""+Запрос.ТекущийЭлемент);
КонецЕсли;
КонецЦикла;

много в 77 загадочного.
Спасибо, конечно, за заботу, но вопрос не в этом - это очень долго, хотелось бы поставить условие!
 
O

Orc

Гость
#5
Большое спасибо всем сочувствующим! Я нашел ответ на свой вопрос.
Дело в том, что такая вещь как запрос выдрана из SQL "наживую без наркоза" и некоторые вещи - как раз такие, о которых я спрашивал - не понимает. Так что придется ставить проверку при группировке...

Еще раз всем спасибо!!!
 
Статус
Закрыто для дальнейших ответов.