Запросы

Тема в разделе "1C и всё что с ней связано", создана пользователем Helena, 7 апр 2007.

Статус темы:
Закрыта.
  1. Helena

    Helena Гость

    Справочник Сотрудники имеет периодичекий реквизит История. Не получается по каждому сотруднику выводить текущее значение Истории.
    Подскажите, плиз, почему

    Процедура Сформировать()
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    Таб.ВывестиСекцию("Шапка");
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса = "
    |Сотр=Справочник.Сотрудники.ТекущийЭлемент;
    |Ист= Справочник.Сотрудники.История;
    |Группировка Сотр упорядочить по Сотр.Наименование;
    |";
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
    Возврат;
    КонецЕсли;

    Таб.ВывестиСекцию("Строка");
    Пока Запрос.Группировка("Сотр") = 1 Цикл
    Если Запрос.Сотр.ЭтоГруппа() = 0 Тогда
    Таб.ВывестиСекцию("Строка2");
    КонецЕсли;
    КонецЦикла;

    КонецПроцедуры
     
  2. LSH

    LSH Гость

    Периодические реквизиты в черном запросе - глюк 1С (или фича?)...
    Дело в том, что значение периодического реквизита можно получить только если в запросе прописан период, и только на дату "по". Т.к. в вашем запросе даты не важны - можете смело указывать период построения запроса.
    Как вариант - можете в группировке по "Сотр" вытягивать значение в переменную, а из нее - в отчет.
     
  3. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Вопросец один наклюнулся... Почему именно запрос? Если ваш запрос - это все, что необходимо сделать, проще будет выборкой, которая, кстати, именно в этом конкретном случае будет работать быстрее.
     
  4. Helena

    Helena Гость

    В общем итоге мне нужно выбрать работающих на конкретную дату сотрудников, посмотреть их Историю (периодический реквизит, хранит значения документов прием, увольнение, изменение) и в зависимости от неё выбрать документ Изменение, Увольнение или Прием на этого сотрудника
     
Загрузка...
Похожие Темы - Запросы
  1. anna
    Ответов:
    18
    Просмотров:
    1.322
  2. ToxaRat
    Ответов:
    11
    Просмотров:
    1.706
  3. bumbarashek
    Ответов:
    4
    Просмотров:
    2.142
  4. c11984
    Ответов:
    0
    Просмотров:
    1.647
  5. Xima
    Ответов:
    1
    Просмотров:
    1.604
Статус темы:
Закрыта.

Поделиться этой страницей