Установить сервер на Linux не просто легко, а очень легко. Но в репозиториях всегда устаревшие версии программ. Например, PHP там ветки 5.5.

Ubuntu (и, естественно, Linux Mint) по умолчанию поставляются с PHP 5.5, но если вы хотите использовать PHP 5.6, то вас от этого отделяют всего три строки в командной строке. Говорят, что нижеследующая инструкция для «чистой установки». Т.е. для тех, кто ещё не успел поставить PHP, и что она не для обновления уже установленного PHP. Я не знаю, но у меня всё сработало прекрасно, хотя PHP я установил вместе с свервером в той инструкции, на которую выше дал ссылку. При установке на «чистую» систему, всё должно пройти идеально — проверено на многих машинах. При обновлении существующего PHP появятся дополнительные вопросы о конфигурационном файле (я поменял на новый из пакета, но вы можете поступить по своему желанию — синтаксис файла настройки одинаков для PHP 5.5 и для PHP 5.6.

01

Апач также работает, я проверил.

1. Добавляем источник пакета PHP 5.6 на вашу систему:



02

и подтверждаем с ENTER. Если вы видите здесь ошибку, вам нужно установить в первую очередь python-software-properties (а затем вернуться опять к предыдущему шагу):

2. Обновление

3. Установка PHP

03

для проверки версии делаем:

04

Ура! Между прочим, этот предельно-простой-для-установки пакет PHP 5.6 был создан Ondřej Surý, следовательно, можете подумать о стимулировании этого человека, подкинув ему деньжат на пиво или на кофе на его странице помощи.


Спонсор публикаций Cyber-512

Готовим специалиста в области ИБ  - Воспитаем специалиста в области ИБ с нуля до начального уровня. После обучения сможете оказывать услуги по проведению тестирования на проникновение ( легальный хакинг )

Похожие темы

Как установить Pyrit в Kali Linux Эта инструкция (Как установить Pyrit в Kali Linux) из серии о том, Как установить GLRX, AMD APP SDK, CAL++ и Pyrit в Kali Linux. Идея в том, чтобы у...
Как активировать предлагаемый архив репозитория на... Как активировать предлагаемый архив для Ubuntu 16.04 LTS? Использовать apt-get для установки выбранного обновления ядра, которое еще не было официал...
Самые частые ошибки и вопросы при настройке и уста... Ошибка: Fatal error: Call to undefined function mb_detect_encoding() in C:serverdatahtdocsphpmyadminlibrariesphp-gettextgettext.inc on line 177 Реше...
Как установить NetBeans и Java на Linux... Казалось бы, что здесь обсуждать? Открыть менеджер программ и установить. Но в менеджере программ, на момент написания, версия 7.0.1, а официально д...
Как установить и настроить кэш Varnish на Ubuntu L... Как установить сервер кэша Varnish для повышения производительности моего существующего веб-сервера Apache, а особенно кэширования динамического содер...