Apache Lounge компилирует для нас, точнее для операционной системы Windows, актуальные бинарники веб-сервера Apache. Делают они это уже более десяти лет. Они собрали армию поклонников — сотни тысяч довольных пользователей: маленькие и большие компании, а также персональные пользователи. Они всегда собирают свежие бинарники, на самых последних компиляторах, при этом проводят должное тестирование. На их бинарники ссылаются ASF, Microsoft, PHP и другие. И всё больше и больше коммерческого программного обеспечения упаковываются с их бинарниками и модулями.

Чтобы вы понимали значение работы Apache Lounge, напомню, что современные версии PHP просто не работают с Apache с официального сайта httpd.apache.org.

Скомпилированные файлы собираются из исходных кодов от ASF на httpd.apache.org, они содержат самые свежие патчи и необходимые зависимости вроде zlib, openssl и других, которые делают загрузку здесь предпочтительнее, чем загрузку в других местах.

Последний билд был собран в последней Windows® Visual Studio C++ 2015 RC aka VC14. VC14 имеет преимущества, исправления и оптимизации по производительности, управлению памяти, генерации кода и стабильности по сравнению с VC11.

Например, тюнинг качества кода и улучшений, сделанный по различным областям кода для «скорости». А также в большей степени использует современные процессоры и поддерживаемые в Windows (win 7 и выше) встроенные функции.

Бинарники не работают на XP и 2003, для этого используйте файлы VC10. Поддерживаемые операционные системы Windows: 7 SP1, Vista SP2, Server 2008 SP2 / R2 SP1, 8 / 8.1, Server 2012 / R2, 10, Server 2016.

После того, как вы загрузили и до попытки установить, вы должны убедиться, что скаченный файл не повреждён и не подделан. Используйте PGP сигнатуру и/или хеш SHA для проверки целостности.

Убедитесь, что у вас установлен Visual C++ Redistributable for Visual Studio 2015: VC14 vcredist_x64/86.exe.

ModSecurity 2.9 для Windows

Вместе с сервером, обновили бинарники и ModSecurity (mod_security). Причём не только собрали их в новом компиляторе, но и использовали исходники последней версии — 2.9.

Подробности о ModSecurity можно посмотреть в соответствующем комментарии: https://codeby.net/bezopasnost/kak-ustanovit-modsecurity-mod_security-na-apache-na-windows#comment-1969

Нововведения ModSecurity 2.9 здесь: https://github.com/SpiderLabs/ModSecurity/blob/master/CHANGES

Теперь curl стала зависимостью, это от того, что активирована новая директива 'SecRemoteRules', она позволяет определить служебный файл HTTPS, который может содержать правила в формате SecRule для загрузки в ModSecurity.

Об этом говориться здесь: https://www.apachelounge.com/viewtopic.php?p=27452

Все эти новшества доступны с 31 мая 2015 года.


Если вам нужен самый качественный хостинг за разумные деньги, то вы найдёте его здесь. Главное в хостинге — это не сэкономить несколько рублей. Главное — это бесперебойная работа сайтов. codeby.net хостится на этой площадке и всячески её рекомендует: за стабильность, качество, современные технологии и удобство использования.

Похожие темы

Как настроить кросс-платформенный сервер резервног... В этом сообщение я представлю вам BackupPC, программный кросс-платформенный бэкап сервер, который через сеть может вытянуть резервное копирование клие...
Восстанавливаем GRUB в Kali Linux после обновления... Автор статьи: AndreyKravets, первоначально статья опубликована по адресу http://andrey.lviv.ua/blog/repair-grub-kali-linux-with-windows-10...
С чего начать свой путь ? Песочные войны. Часть 7... Не могу утверждать правильность своего высказывания, так как сужу только по своим наблюдениям, НО войнушек раньше было больше, чем сейчас. Нет, ...
Logjam атака: доказательство концепции с наглядным... Мы описали технические детали наших атак в нашей научной статье, Несовершенная секретность: Неудачи Diffie-Hellman на практике. В разделах ниже мы пре...
Делаем локальный сайт (на localhost) доступным для... До открытия доступа на локалхост, рекомендуется установить ModSecurity (mod_security) на Apache. Эта статья для тех, у кого есть сайт на локальном ...