FP8 проблемы с дизайнером

lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
сабж
при открытии любой БД пишет рефрешинг и на этом виснет
FP8 проблемы с дизайнером

ругается на открытие БД, в кот. есть Database Script
---------------------------
IBM Notes
---------------------------
Error loading USE or USELSX module: *javacon
---------------------------
ОК
---------------------------

кто с таким сталкивался?
 
S

swyatogor

Lotus team
24.02.2014
620
29
Не сталкивался.. потому как java наверное не пользую..
 
R

rinsk

Lotus team
12.11.2009
1 049
86
Не сталкивался. Есть и дбскрипт и джавабибл. Почистить что-ть?
 
lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
Не сталкивался. Есть и дбскрипт и джавабибл. Почистить что-ть?
есть код, кот. использует общую либу (обработка ошибок), в ней обработчик ошибок java
вопрос - почему дизайнер виснет, с ошибкой-то кода я могу "справиться" ;)
 
S

swyatogor

Lotus team
24.02.2014
620
29
поставил fp8 на рабочую машинку.. появилась вот такая бяда..
FP8 проблемы с дизайнером

кто подскажет что сделать?))
 
lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
@swyatogor судя про трейсу - нет путей к либам, при сборке
у меня сильное подозрение - изменения жвм на версию 1.8 имеют неприятные последствия для java проектов
даже для уже скомпиированных
для себя я решил погодить использовать - ибо не знаю деталей и решений
 
garrick

garrick

Lotus team
26.10.2009
1 024
81
поставил fp8 на рабочую машинку.. появилась вот такая бяда..
Посмотреть вложение 9534
кто подскажет что сделать?))
Посмотрите в свойствах проекта какую jvm он использует, есть ли она у вас в наличии.
[doublepost=1490596157,1490595948][/doublepost]
@swyatogor судя про трейсу - нет путей к либам, при сборке
у меня сильное подозрение - изменения жвм на версию 1.8 имеют неприятные последствия для java проектов
даже для уже скомпиированных
для себя я решил погодить использовать - ибо не знаю деталей и решений
Под 1.8 запускается только клиент, дизайнер по прежнему использует 1.6 из папки jvm1.6, проблемы могут быть только с новыми путями к этой jvm и внешним библиотеками из jvm/lib/ext, если вы забыли их положить ещё и в jvm1.6/lib/ext.
 
S

swyatogor

Lotus team
24.02.2014
620
29
не стал ломать голову что и как там настраивается.. снес нафиг лотус и поставил старую версию которая была..и всё заворкало
 
lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
и внешним библиотеками из jvm/lib/ext, если вы забыли их положить ещё и в jvm1.6/lib/ext.
выше описывал траблу - до перкладывания даже не дохдит
и при старте БД не работает LS2J инициализация
 
garrick

garrick

Lotus team
26.10.2009
1 024
81
выше описывал траблу - до перкладывания даже не дохдит
и при старте БД не работает LS2J инициализация
Ну, тут я даже и не знаю... по-моему это уже как-то ломали раньше в очередном фикс-паке, потом починили... ну, теперь снова. Всё идёт по индусскому плану. :)

Такая же проблема была после FP1 и решается она так же, как и тогда - надо запустить дизайнер без клиента.
 
Последнее редактирование:
S

swyatogor

Lotus team
24.02.2014
620
29
Кстати.. а ни кто не обращал внимания на битность java??.. она там давно 64-х битная?
 
garrick

garrick

Lotus team
26.10.2009
1 024
81
Кстати.. а ни кто не обращал внимания на битность java??.. она там давно 64-х битная?
Биность Java равна битности клиента/сервера - всегда так было.
[doublepost=1490779184,1490779123][/doublepost]
сабж
при открытии любой БД пишет рефрешинг и на этом виснет
Посмотреть вложение 9423
ругается на открытие БД, в кот. есть Database Script
---------------------------
IBM Notes
---------------------------
Error loading USE or USELSX module: *javacon
---------------------------
ОК
---------------------------

кто с таким сталкивался?
[doublepost=1490779123,1490779025][/doublepost]Нашел вот что. Если вы что-то отлаживали в дебагере, а потом его отключили, то для повторного включения дебагера надо перезапустить дизайнер. Иначе галочка в меню "Debug Lotus Script" включается и выключается, но ничего не происходит.
 
A

alexas1

Lotus team
10.04.2014
1 109
216
... что-то отлаживали в дебагере, а потом его отключили, то для...
- ХЗ, у меня этого ничего нет. Дебажу и ничего не перезапускаю. Всё происходит ))
ток, если дебажится форма, к примеру, галку надо ставит ДО её открытия (т.е. переоткрыть ЕЁ есличо). ну и всего остального эт тож касается
 
lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
Нашел вот что. Если вы что-то отлаживали в дебагере, а потом его отключили, то для повторного включения дебагера надо перезапустить дизайнер
я ничего не дебажу
есть БД, в кот. класс "работы" с ошибками java, вызываемой из LS (LS2J)
в скрипте БД, либа (с классом) подключается
при открытии БД - ловим ошибку
 
garrick

garrick

Lotus team
26.10.2009
1 024
81
я ничего не дебажу
есть БД, в кот. класс "работы" с ошибками java, вызываемой из LS (LS2J)
в скрипте БД, либа (с классом) подключается
при открытии БД - ловим ошибку
Про это я уже "говорил" выше - надо запустить дизайнер без клиента и тогда нет никаких ошибок. Был такой же глюк в FP1, потом починили, а сейчас вернули назад.
[doublepost=1490783750,1490783564][/doublepost]
- ХЗ, у меня этого ничего нет. Дебажу и ничего не перезапускаю. Всё происходит ))
ток, если дебажится форма, к примеру, галку надо ставит ДО её открытия (т.е. переоткрыть ЕЁ есличо). ну и всего остального эт тож касается
А у меня такая штука - если остановить дебагер "не дойдя до конца кода" в процессе отладки, где-то посередине кода, то второй раз он не стартует без перезапуска дизайнера. :(
 
lmike

lmike

нет, пердело совершенство
Lotus team
27.08.2008
7 258
439
Про это я уже "говорил" выше - надо запустить дизайнер без клиента и тогда нет никаких ошибок. Был такой же глюк в FP1, потом починили, а сейчас вернули назад.
я вовсе не запускаю дизайнер...
 
Мы в соцсетях:  ТелеграмВконтактеДзенФейсбукТвиттерЮтуб