• Открыта запись на вторую часть курса по анонимности и безопасности в сети интернет "Paranoid II" от команды codeby. Анонимные роутеры, Подъём, настройка и администрирование Tor-ноды, Работа с железом ПК, Удаление аппаратных закладок, Минимизация рисков, Авторские разработки и многое другое. Подробнее ...

kali-linux-mate-2017-W43-amd64

Мертвый Палладин

Мертвый Палладин

Happy New Year
09.05.2017
65
7
устанавливал kali-linux-mate-2017-W43-amd64 и kali-linux-mate-2017.2-amd64, везде выходит такой экран, что не так?
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 515
3 353
Картинку не видно, но мысли есть.

1) Опишите ход установки
2) Виртуалка или на живую
3) После чего появилась проблема?
4) Что такое recovery mode известно?
 
Мертвый Палладин

Мертвый Палладин

Happy New Year
09.05.2017
65
7
ставил как обычно на живую, картинка скоро будет, яндекс диск тупит
[doublepost=1509269733,1509269446][/doublepost]
Картинку не видно, но мысли есть.

1) Опишите ход установки
2) Виртуалка или на живую
3) После чего появилась проблема?
4) Что такое recovery mode известно?
вот ссылка на фото
в других версиях все нормально запускалось
[doublepost=1509270938][/doublepost]recovery mode ничего не дало
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 515
3 353
startx написать, жмем Энтер и сюда скрин
 
Мертвый Палладин

Мертвый Палладин

Happy New Year
09.05.2017
65
7
startx написать, жмем Энтер и сюда скрин
появился нормальный рабочий экран Мата, провел перезагрузку, вышло тоже самое что на ссылке, потом ввел startx, появился рабочий стол
 
Мертвый Палладин

Мертвый Палладин

Happy New Year
09.05.2017
65
7
Все нормально и работать можно?
да, разберусь.
не подскажешь что тут не так?
root@WhoAmI:~# cd xerosploit && sudo python install.py
┌══════════════════════════════════════════════════════════════┐
█ █
█ Xerosploit Installer █
█ █
└══════════════════════════════════════════════════════════════┘

[++] Please choose your operating system.

1) Ubuntu / Kali linux / Others
2) Parrot OS

>>> 1

[++] Installing Xerosploit ...
Чтение списков пакетов… Готово
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Пакет libgmp3-dev недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
libgmp-dev

E: Не удалось найти пакет libpcap-dev
E: Для пакета «libgmp3-dev» не найден кандидат на установку
WARNING: bin/xettercap is not executable
WARNING: See for help
Successfully built RubyGem
Name: xettercap
Version: 1.5.7xerob
File: xettercap-1.5.7xerob.gem
Building native extensions. This could take a while...
ERROR: Error installing xettercap-1.5.7xerob.gem:
ERROR: Failed to build gem native extension.

current directory: /var/lib/gems/2.3.0/gems/pcaprub-0.12.4/ext/pcaprub_c
/usr/bin/ruby2.3 -r ./siteconf20171029-10674-z0ddc3.rb extconf.rb

[*] Running checks for pcaprub_c code...
platform is x86_64-linux-gnu
checking for ruby/thread.h... yes
checking for rb_thread_blocking_region()... no
checking for rb_thread_call_without_gvl()... yes
checking for pcap_open_live() in -lpcap... no
checking for pcap_setnonblock() in -lpcap... no
creating Makefile

To see why this extension failed to compile, please check the mkmf.log which can be found here:

/var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/pcaprub-0.12.4/mkmf.log

current directory: /var/lib/gems/2.3.0/gems/pcaprub-0.12.4/ext/pcaprub_c
make "DESTDIR=" clean

current directory: /var/lib/gems/2.3.0/gems/pcaprub-0.12.4/ext/pcaprub_c
make "DESTDIR="
compiling pcaprub.c
pcaprub.c:11:10: fatal error: pcap.h: Нет такого файла или каталога
#include <pcap.h>
^~~~~~~~
compilation terminated.
Makefile:239: ошибка выполнения рецепта для цели «pcaprub.o»
make: *** [pcaprub.o] Ошибка 1

make failed, exit code 2

Gem files will remain installed in /var/lib/gems/2.3.0/gems/pcaprub-0.12.4 for inspection.
Results logged to /var/lib/gems/2.3.0/extensions/x86_64-linux/2.3.0/pcaprub-0.12.4/gem_make.out
Xerosploit has been sucessfuly instaled. Execute 'xerosploit' in your terminal.
root@WhoAmI:~/xerosploit#
 
Dr.Lafa

Dr.Lafa

Mod. Hardware
Gold Team
30.12.2016
510
1 036
Пакет libgmp3-dev недоступен, но упомянут в списке зависимостей другого пакета.
Это может означать, что пакет отсутствует, устарел, или доступен из источников, не упомянутых в sources.list
Однако следующие пакеты могут его заменить:
libgmp-dev
Терминал говорит вам, что в репозиториях, которые вы сейчас используете, нет такого пакета, но такой пакет существует.
И да, он существует в non-free репозитории кали:
Код:
sudo mousepad /etc/apt/sources.list
если в файле есть репозиторий deb kali-rolling main contrib non-free и deb-src kali-rolling main contrib non-free, то нужно раскоментировать его (убрать # в начале строки)
если нету, то добавляем.


Далее обновляемся
Код:
sudo apt-get update
и ставим пакет
Код:
sudo apt-get install libgmp3-dev
 
Мертвый Палладин

Мертвый Палладин

Happy New Year
09.05.2017
65
7
Терминал говорит вам, что в репозиториях, которые вы сейчас используете, нет такого пакета, но такой пакет существует.
И да, он существует в non-free репозитории кали:
Код:
sudo mousepad /etc/apt/sources.list
если в файле есть репозиторий deb kali-rolling main contrib non-free и deb-src kali-rolling main contrib non-free, то нужно раскоментировать его (убрать # в начале строки)
если нету, то добавляем.


Далее обновляемся
Код:
sudo apt-get update
и ставим пакет
Код:
sudo apt-get install libgmp3-dev
репозитории были неисправны, стояли репозитории обновлений с диска.
 
Мы в соцсетях:  ТелеграмВконтактеДзенФейсбукТвиттерЮтуб