• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Не получается установить зависимости для некоторых программ а Kali Linux

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
Здравствуйте! При использовании Кали понадобились некоторые программки, такие как fluxion, wifiphisher, airgeddon. Все бы ничего, в Кали из коробки есть куча предустановленных инструментов, пакетов, зависимостей, но в данной ситуации эти проги (все 3 что я назвал выше) не увидели такие зависимости как bettercap, dhcpd, hostapd и еще парочку, но они необязательны, так что не буду о них. "Ну ничего" - подумал я, "Не впервой, докачаю отдельно". Погуглил, нашел все это дело на GitHub(в офиц. репозиториях мне так и не удалось их скачать, ибо выдавало ошибку: "пакет с таким именем не найден"(p.s. репозитории я обновлял если что)) и скачал. Но к моему огорчению, ни одна программа так и не увидела, ничегошеньки из того, что я скачал. Но справедливости ради, надо заметить, что, например, для airgeddon я точно так же докачивал пакет BEef, и его прога тоже не увидела сначала, но там была возможность (в самой проге во время работы), указать путь к этому пакету (только к этому, для других такой роскоши не предусмотрено). Я указал путь и все заработало и при последующих запусках все определялось при старте проги, без моего участия.

Внимание вопрос:
Как установить недостающие зависимости/пакеты/инструменты в Кали Линукс, для таких прог как fluxion, wifiphisher, airgeddon и т.п.? Может надо скачанные пакеты в папку какую-то, может надо их распаковать как-то, прописать где-то в конфигах программ путь к ним? Вообщем что-нибудь сделать, потому что я уже не выкупаю кааак!
 

f22

Codeby Academy
Gold Team
05.05.2019
1 846
225
BIT
1 137
Как установить недостающие зависимости/пакеты/инструменты в Кали Линукс, для таких прог как fluxion, wifiphisher, airgeddon и т.п.? Может надо скачанные пакеты в папку какую-то, может надо их распаковать как-то, прописать где-то в конфигах программ путь к ним? Вообщем что-нибудь сделать, потому что я уже не выкупаю кааак!
Лучше всего читать информацию об установке таких программ на их главной странице на github'e
wifiphisher
1581956140254.png
Выполняешь последовательно команды в командной строке
git clone https://github.com/wifiphisher/wifiphisher.git
cd wifiphisher
sudo python setup.py install

fluxion
1581956398773.png

wget https://raw.githubusercontent.com/FluxionNetwork/fluxion/master/install/install.sh && bash install.sh

airgeddon
Там сразу 2 метода установки предлагается.
1581956318632.png
 

rumiantsau

New member
17.02.2020
4
0
BIT
0
Здравствуйте! При использовании Кали понадобились некоторые программки, такие как fluxion, wifiphisher, airgeddon. Все бы ничего, в Кали из коробки есть куча предустановленных инструментов, пакетов, зависимостей, но в данной ситуации эти проги (все 3 что я назвал выше) не увидели такие зависимости как bettercap, dhcpd, hostapd и еще парочку, но они необязательны, так что не буду о них. "Ну ничего" - подумал я, "Не впервой, докачаю отдельно". Погуглил, нашел все это дело на GitHub(в офиц. репозиториях мне так и не удалось их скачать, ибо выдавало ошибку: "пакет с таким именем не найден"(p.s. репозитории я обновлял если что)) и скачал. Но к моему огорчению, ни одна программа так и не увидела, ничегошеньки из того, что я скачал. Но справедливости ради, надо заметить, что, например, для airgeddon я точно так же докачивал пакет BEef, и его прога тоже не увидела сначала, но там была возможность (в самой проге во время работы), указать путь к этому пакету (только к этому, для других такой роскоши не предусмотрено). Я указал путь и все заработало и при последующих запусках все определялось при старте проги, без моего участия.

Внимание вопрос:
Как установить недостающие зависимости/пакеты/инструменты в Кали Линукс, для таких прог как fluxion, wifiphisher, airgeddon и т.п.? Может надо скачанные пакеты в папку какую-то, может надо их распаковать как-то, прописать где-то в конфигах программ путь к ним? Вообщем что-нибудь сделать, потому что я уже не выкупаю кааак!
Можно fluxion запустить с ключом -i и он сам все найдет, скачает и установит
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
Лучше всего читать информацию об установке таких программ на их главной странице на github'e
wifiphisher
Посмотреть вложение 38432
Выполняешь последовательно команды в командной строке
git clone https://github.com/wifiphisher/wifiphisher.git
cd wifiphisher
sudo python setup.py install

fluxion
Посмотреть вложение 38434

wget https://raw.githubusercontent.com/FluxionNetwork/fluxion/master/install/install.sh && bash install.sh

airgeddon
Там сразу 2 метода установки предлагается.
Посмотреть вложение 38433
Ну программы-то я уже установил, кроме wifiphiser и сейчас скажу почему. Собственно по этой же самой причине, я не смог установить пакеты...
Причина: при установке используется скрипт ***.py, то есть Python, а конкретно Python 3, а в Kali установлен Python 2.6 или 2.8, вообщем не суть, ниже 3-й версии точно. И поэтому при установке этих пакетов и программ, где используется python-скрипт, выдается ошибка: "Необходим Python версии 3". Хорошо, попробовал установить Python 3-ей версии, но у меня ни черта не получилось. Выдало ошибки по типу:
make[1]: *** [all] Ошибка 2
Я брал исходники с GitHub. Может есть исходники и в официальных репозиториях или еще где-либо?
 

f22

Codeby Academy
Gold Team
05.05.2019
1 846
225
BIT
1 137
а в Kali установлен Python 2.6 или 2.8, вообщем не суть, ниже 3-й версии точно.
Твоя точность не выдерживает никакой критики.
Уже с прошлого года в kali устанавливались обе версии и python2, и python3.
А вот какая у тебя была установлена по умолчанию - большой вопрос.

но у меня ни черта не получилось. Выдало ошибки по типу:
make[1]: *** [all] Ошибка 2
Установи для начала библиотеки
sudo apt-get install -y libnl-3-dev libnl-genl-3-dev
А потом запускай скрипт установки
sudo python3 setup.py install

Только что проверил, всё работает, как часы.
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
Установи для начала библиотеки
sudo apt-get install -y libnl-3-dev libnl-genl-3-dev
А потом запускай скрипт установки
sudo python3 setup.py install

Только что проверил, всё работает, как часы.

Выдает ошибку:
E: Невозможно найти пакет libnl-3-dev E: Невозможно найти пакет libnl-genl-3-dev

Версия Kali Linux:
Distributor ID: Kali Description: Kali GNU/Linux Rolling Release: 2019.4 Codename: kali-rolling

Можно fluxion запустить с ключом -i и он сам все найдет, скачает и установит
Попробровал, выдало ошибку:
Код:
E: Невозможно найти пакет bc
Dependency installation failed!
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
Покажы репы
cat /etc/apt/sources.list
Код:
# 

# deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

#deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
 

Xulinam

Grey Team
02.03.2017
1 015
240
BIT
79
Код:
#

# deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

#deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.
че то репов нет у тебя)
 

R3M1X

Green Team
16.02.2020
117
20
BIT
0
Код:
#

# deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

#deb cdrom:[Debian GNU/Linux 2019.4 _Kali-rolling_ - Official Snapshot amd64 LIVE/INSTALL Binary 20191125-10:47]/ kali-last-snapshot contrib main non-free

# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
# see the sources.list(5) manual.

потом apt-get update && apt-get upgrade
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
Твоя точность не выдерживает никакой критики.
Уже с прошлого года в kali устанавливались обе версии и python2, и python3.
А вот какая у тебя была установлена по умолчанию - большой вопрос.


Установи для начала библиотеки
sudo apt-get install -y libnl-3-dev libnl-genl-3-dev
А потом запускай скрипт установки
sudo python3 setup.py install

Только что проверил, всё работает, как часы.
Сделал все, что сказали в 2-х предыдущих сообщениях выше(#12 и #13).
Вернулся к этому пункту, 1-я команда прошла, но 2-я выдала ошибку:
Код:
python3: can't open file '/root/setup.py': [Errno 2] No such file or directory
 

R3M1X

Green Team
16.02.2020
117
20
BIT
0
Сделал все, что сказали в 2-х предыдущих сообщениях выше(#12 и #13).
Вернулся к этому пункту, 1-я команда прошла, но 2-я выдала ошибку:
зависимость:
libnl-genl-3-dev
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
зависимость:
libnl-genl-3-dev
Так я же уже установил этот пакет...
Код:
root@kali:~# sudo apt-get install libnl-genl-3-dev
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Уже установлен пакет libnl-genl-3-dev самой новой версии (3.4.0-1+b1).
Следующие пакеты устанавливались автоматически и больше не требуются:
  libayatana-ido3-0.4-0 libbfio1 libhogweed4 libnettle6
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 62 пакетов не обновлено.
 

f22

Codeby Academy
Gold Team
05.05.2019
1 846
225
BIT
1 137
Вернулся к этому пункту, 1-я команда прошла, но 2-я выдала ошибку:
ты находишься в корневой директории - /root , а репозиторий склонировал в папку /root/wifiphisher
Сначала перейди туда, а потому уже запускай.
cd ~/wifiphisher/
sudo python3 setup.py install
либо запускай по пути
sudo python3 ~/wifiphisher/setup.py install


Ну и репозитории дополни, если ещё не добавил
echo "deb http://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list
 

TttTTr

Well-known member
17.02.2020
45
0
BIT
0
ты находишься в корневой директории - /root , а репозиторий склонировал в папку /root/wifiphisher
Сначала перейди туда, а потому уже запускай.
cd ~/wifiphisher/
sudo python3 setup.py install
либо запускай по пути
sudo python3 ~/wifiphisher/setup.py install


Ну и репозитории дополни, если ещё не добавил
echo "deb http://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list
Репозитории добавил.
Зашел в директорию, но опять выдало ошибку...
Код:
root@kali:~# cd wifiphisher
root@kali:~/wifiphisher# sudo python3 setup.py install
Traceback (most recent call last):
  File "/root/wifiphisher/setup.py", line 23, in <module>
    from setuptools import Command, find_packages, setup
ModuleNotFoundError: No module named 'setuptools'

Погуглил, попробовал доустановить пакеты, которые просят через:
Код:
apt-get install -y python3-setuptools
Но выдало, что они уже установлены.
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!