Наш партнер GENESIS HACKSPACE

Хакспейс: Клуб — физическое место, где собираются увлеченные техникой, IT, электроникой, роботами и физикой люди. Первая сеть бесплатных хакспейсов в г.Тверь и области.

Установить сервер на Linux не просто легко, а очень легко. Но в репозиториях всегда устаревшие версии программ. Например, PHP там ветки 5.5.

Ubuntu (и, естественно, Linux Mint) по умолчанию поставляются с PHP 5.5, но если вы хотите использовать PHP 5.6, то вас от этого отделяют всего три строки в командной строке. Говорят, что нижеследующая инструкция для «чистой установки». Т.е. для тех, кто ещё не успел поставить PHP, и что она не для обновления уже установленного PHP. Я не знаю, но у меня всё сработало прекрасно, хотя PHP я установил вместе с свервером в той инструкции, на которую выше дал ссылку. При установке на «чистую» систему, всё должно пройти идеально — проверено на многих машинах. При обновлении существующего PHP появятся дополнительные вопросы о конфигурационном файле (я поменял на новый из пакета, но вы можете поступить по своему желанию — синтаксис файла настройки одинаков для PHP 5.5 и для PHP 5.6.

01

Апач также работает, я проверил.

1. Добавляем источник пакета PHP 5.6 на вашу систему:

02

и подтверждаем с ENTER. Если вы видите здесь ошибку, вам нужно установить в первую очередь python-software-properties (а затем вернуться опять к предыдущему шагу):

2. Обновление

3. Установка PHP

03

для проверки версии делаем:

04

Ура! Между прочим, этот предельно-простой-для-установки пакет PHP 5.6 был создан Ondřej Surý, следовательно, можете подумать о стимулировании этого человека, подкинув ему деньжат на пиво или на кофе на его странице помощи.

Похожие темы

Замечания по обновлению до PHP 7... Оглавление: Изменения не совместимые со старыми версиями Новые особенности Изменения в модулях SAPI Устаревшая функциональн...
Проект Razboynik (Разбойник) https://codeby.net/forum/threads/razboynik.58364/ В этой публикации я хочу поделиться с вами информацией о проекте российских разработчиков. Про...
Проверка уязвимостей, обнаруженных Nexpose... Перейти к содержанию полного руководства пользователя Metasploit на русском языке. Валидация уязвимостей с Nexpose Мастер проверки уязвимостей предо...
Установка Дополнений гостевой ОС VirtualBox для Ka... Если вы запускаете Kali Linux в качестве «гостевой» системы в VirtualBox, эта статья поможет вам успешно установить инструменты «Дополнения гостевой О...
Новости софта от 1 сентября 2014 года (PHP, phpMyA... Самая главная новость — это мажорное обновление PHP 5.6.0. Теперь ветка 5.6 считается стабильной и рекомендованной для «продакшана»...