Документ и справочник

Тема в разделе "1C и всё что с ней связано", создана пользователем angel18, 19 окт 2007.

Статус темы:
Закрыта.
  1. angel18

    angel18 Гость

    Привет всем помогите вообщем есть справочник Маршрут - имеет реквизиты наименование(100) код(5) и путь следования(неогр строка), так вот создал документ, кот отображает это но в документе когда выбираешь путь следования в окне ввода строки из справочника Маршрут выбирается и сохраняется либо наименование либо код, Как сделать так, чтобы был выбран из справочника запись из реквизита путь следования!!!!

    Это нужно для того, чтобы выбрать элемент которые больше 100 символов, а наименование только 100 максимум, вообщем именно в этом и проблема! Помогите срочно надо!
     
  2. kaa

    kaa Гость

    Либо сделать путь следования справочником и в документе выбирать его, либо в документе создать реквизит путь следования ,в свойствах указать имеет кнопку выбора и в процедуре ПриНачалеВыбораЗначения(Элем) описать выбор что типа:

    Процедура ПриНачалеВыбораЗначения(Элем)
    Если Элем="ПутьСледования" Тогда
    Форма.ОткрытьПодбор("Справочник.Маршрут",,,0,);
    КонецЕсли;
    КонецПроцедуры

    //и описать обработку подбора
    Процедура ОбработкаПодбора(ЗначениеПодбора,КонтФормы)
    Если ЗначениеПодбора.Вид()="Маршрут" Тогда
    ПутьСледования = ЗначениеПодбора.ПутьСледования;
    КонецЕсли;
    КонецПроцедуры
     
  3. angel18

    angel18 Гость

    Спасибо но не получается пишет

    Форма.ОткрытьПодбор("Справочник.Маршрут",,,0,);
    {Документ.Автоперевозки.Форма.Модуль(7)}: Поле агрегатного объекта не обнаружено (ОткрытьПодбор)

    Может что-то не туда вставляю!!!

    И еще а что за первый путь в справочнике подробнее можешь объяснить!!!
     
  4. kaa

    kaa Гость

    извини затупил
    Форма.ОткрытьПодбор("Справочник.Маршрут",,,0,); - неправильно
    надо так ОткрытьПодбор("Справочник.Маршрут",,,0,);

    <!--QuoteBegin-angel18+20:10:2007, 17:56 -->
    <span class="vbquote">(angel18 @ 20:10:2007, 17:56 )</span><!--QuoteEBegin-->И еще а что за первый путь в справочнике подробнее можешь объяснить!!!
    [snapback]82463" rel="nofollow" target="_blank[/snapback]​
    [/quote]

    Заводишь справочник ПутиСледования который имеет только наименование
    в справочнике маршрут у реквизита ПутьСледования ставишь тип Справочник.ПутиСледования и в документе тоже
     
  5. Zab

    Zab Well-Known Member
    1C Team

    Регистрация:
    7 авг 2006
    Сообщения:
    583
    Симпатии:
    0
    Я бы сделал проще.
    В справочнике Маршрут в предопределенной процедуре ПриЗаписи, записывал бы в наименование справочника первые 100 символов из пути следования. Сомневаюсь, что у тебя на форме документа есть поле выбора, в котором отобразится больше. В самом справочнике бы не отображал просто поле наименования. В итоге, получишь видимость того, что на форме документа отображается маршрут. Если хочешь, можно рядом разместить реквизит типа надпись, в который вписать формулу: ?(МаршрутСледования.выбран()=1,Маршрут.маршрутСледования,""), тогда при выборе в реквизите маршрутСледования чего-нить, будет в тексте отображен полный текст маршрута.
     
  6. angel18

    angel18 Гость


    Спасибо Каа но получается что в форме выбираешь из справочника данное наименование а оно все равно 100 символов!!! максимум Правда 2-ой способ тоже такой!
     
  7. angel18

    angel18 Гость

    Ребята нужна помощь сам не справлюсь мелочь а не могу но не программер я 1С а пользователь! Сделаю в знак благодарности - положу вам на мобильный через элекснет 200 руб тоько помогите!!!

    Дело вот такое есть база в ней я уже все сделал это 6 справочников, 1 документ автоперевозки, журнал заявок, на основе печати документа формируется ведомость! все это я сделал!!!

    Вопрос в том чтобы вы сделали, чтобы в реквизитах документа когда выбираешь адрес загрузки, адрес разгрузки, маршрут перевозки, перевозчика были >100 символов!!!

    Просто когда жмешь печать документа тама нах обрезанные данные по 100 симв максимум!
    Надо сделать так что бы при выборе в документе в строке ввода точнее она ссылалась на др реквизит неогранниченной длины!, я по вашим советам делаю но что-то не так!!!! помогите!!!!

    352353730 моя ася стучитесь бд маленькая всего 2-3 мб сделаете? только сегодня прошу!

    В принципе это 3-х минутное дело! сылка на мою БД http://www.rapidshare.ru/438074
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей