Как сделать выборку по номенклатуре

Тема в разделе "1C и всё что с ней связано", создана пользователем Farrago, 21 июн 2009.

  1. Farrago

    Farrago Гость

    Здравствуйте Господа!
    Помогите

    1С 7,7 Бюджетная

    Процедура ПриОткрытии()


    ТабЗнач.НоваяКолонка("Продукты",,,,"Продукты",20);
    ТабЗнач.НоваяКолонка("ЕдИзм",,,,"Ед.изм.",10);
    ТабЗнач.НоваяКолонка("СчетКредит",,,,"Счет кредита",15);
    ТабЗнач.НоваяКолонка("Сад");

    Возврат;

    КонецПроцедуры


    //*******************************************
    Процедура Выполнить()

    Спр=СоздатьОбъект("Справочник.Номенклатура");

    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент()=1 Цикл

    ТабЗнач.НоваяСтрока();

    Если Спр.ЭтоГруппа()=1 Тогда
    ТабЗнач.УдалитьСтроку();
    КонецЕсли;



    ТабЗнач.Продукты=Спр.ПолнНаимен;

    ТабЗнач.ЕдИзм=Спр.ЕдИзм;

    ТабЗнач.СчетКредит=Спр.СчетУчета;


    Продолжить;

    КонецЦикла;


    КонецПроцедуры

    //********************************************************************************
    ******************

    Эта процедурв выволит все наменования, имеющиеся в справочнике " Номенклатура" в таблицу значений.
    Как сделать что бы вывести один вид, напримно " Продукты питания"

    С балгодарностью
     
  2. has

    has Гость

    Спр.НайтиПоНаименованию("Продукты питания")...в чем проблема то?..... и странный код какой-то ;)
     
  3. Farrago

    Farrago Гость

    Я новичок, все методом тыка, в чем странность? Подскахите
     
  4. has

    has Гость

    инструкции "продолжить" и "возврат" здесь неуместны....в 1С есть синтакс-помощник, почитайте там или в литературе
     
  5. kaa

    kaa Гость

    Процедура ПриОткрытии()


    ТабЗнач.НоваяКолонка("Продукты",,,,"Продукты",20);
    ТабЗнач.НоваяКолонка("ЕдИзм",,,,"Ед.изм.",10);
    ТабЗнач.НоваяКолонка("СчетКредит",,,,"Счет кредита",15);
    ТабЗнач.НоваяКолонка("Сад");
    КонецПроцедуры

    Процедура Выполнить()

    //Если Продукты питания это группа
    Спр=СоздатьОбъект("Справочник.Номенклатура");
    Спр.НайтиПоКоду(ХХХ);//ХХХ это код группы, если выведен на форму то не надо

    Род = Спр.ТекущийЭлемент();

    Спр.ИспользоватьРодителя(Род);//если есть на форме то идентификатор вместо Род
    Спр.ВыбратьЭлементы();

    Пока Спр.ПолучитьЭлемент()=1 Цикл
    Если Спр.ЭтоГруппа()=1 Тогда
    Продолжить;
    КонецЕсли;

    ТабЗнач.НоваяСтрока();
    ТабЗнач.Продукты=Спр.ПолнНаимен;

    ТабЗнач.ЕдИзм=Спр.ЕдИзм;

    ТабЗнач.СчетКредит=Спр.СчетУчета;

    КонецЦикла;


    КонецПроцедуры
     
  6. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    Код очень смешной)
     
  7. Farrago

    Farrago Гость

    Если смешной, то как надо?
     
  8. vitfil

    vitfil IT-интегратор

    Регистрация:
    2 апр 2004
    Сообщения:
    2.070
    Симпатии:
    0
    Надо начинать с изучения основ программирования и чтения учебников.
     
  9. unknown181538

    unknown181538 НеГуру
    1C Team

    Регистрация:
    28 дек 2008
    Сообщения:
    1.418
    Симпатии:
    0
    kaa уже написал.
     
  10. perfomance

    perfomance Гость

    Ну практически все так тока действительно перемудрил в процедуре открытия с КлСл Возврат; И в процедуре Выполнить() Намудрил в Цикле по поводу удаления строк из ТЗ если при переборке вдруг попадется группа. А так для новичка гуддд. А так Каа тебе эталонно код написал.
     
Загрузка...

Поделиться этой страницей