Не работает Nanoweb написанный на Php

Тема в разделе "PHP программирование", создана пользователем itwork, 16 янв 2010.

  1. itwork

    itwork Гость

    Привет всем, решил на днях поставить вебсервер (nanoweb) написанный на Php но так нармално он не заработал.

    Поставил nanoweb на Windows 7 и к нему phpMyAdmin, так вот после открытия второй страницы (phpMyAdmin) вебсервер просто завис и так висел при любой phpшной странице, а Html страницы открывал без проблем!

    Поставил nanoweb на Debian 5 и к нему одну phpшную страницу с кодом <? phpinfo(); ?> так он тоже висел минут 15, но потом придложил сохранить эту страницу! ))

    Плз кто ставил этот сервак, скажите что нужно настроить или написать дополнительно к ниму, чтобы на нем нармально работали php страницы?

    PHP 5.2.12 + Nanoweb 2.2.9
     
  2. vital

    vital Больной Компом Детектед
    Команда форума Web Team

    Регистрация:
    29 янв 2006
    Сообщения:
    2.474
    Симпатии:
    27
    Совет:
    Не страдать фигней и поставить Апач.
    Это происходит из-за не правильно или вообще не прописанного mime типа.. ХЗ, где они прописываются в этом твоем нановеб..
     
  3. itwork

    itwork Гость

    НЕт, просто нужен веб сервер написанный на php, к сожелению я так понимаю nanoweb единственный....

    Получилось разобраться самому, дело было в том, что в настойках nanoweb под линуком прописывался путь к PHP-CLI, заменил на php-cgi и PHP странички начались показываться, но например сайтик phpMyAdmin, тормозил немерено (страница открывалась 30min),

    Ниможет ли это зависить от каких нибудь настроек в php.ini????
     
  4. vital

    vital Больной Компом Детектед
    Команда форума Web Team

    Регистрация:
    29 янв 2006
    Сообщения:
    2.474
    Симпатии:
    27
    нет, не может.
     
Загрузка...

Поделиться этой страницей