Не возвращаются значения в отчет

Тема в разделе "1C и всё что с ней связано", создана пользователем towel, 15 июл 2008.

Статус темы:
Закрыта.
  1. towel

    towel Гость

    Доброго времени суток вам.
    у меня такая проблема: соддаю отчет через конструктор, на код ни что не ругается, только вот значения с РегистраНакопления.Продажи он не возвращет в таблицу.... вот код, я его немножко поменял, что б он по периодам выводил...ну а вв общем без изменений:
    [codebox]Процедура ВыручкаМастеров(ТабДок, ДатаНачала, ДатаОкончания) Экспорт
    //{{КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ(ВыручкаМастеров)
    // Данный фрагмент построен конструктором.
    // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

    Макет = ОтчетОбъект.ПолучитьМакет("ВыручкаМастеров");
    Запрос = Новый Запрос;
    Запрос.Текст =
    "ВЫБРАТЬ
    | ПродажиОбороты.Мастер КАК Мастер,
    | ПРЕДСТАВЛЕНИЕ(ПродажиОбороты.Мастер),
    | ПродажиОбороты.Период КАК Период,
    | ПродажиОбороты.Клиент,
    | ПРЕДСТАВЛЕНИЕ(ПродажиОбороты.Клиент),
    | ПродажиОбороты.ВыручкаОборот КАК Выручка
    |ИЗ
    | РегистрНакопления.Продажи.Обороты(&ДатаНачала, &ДатаОкончания, День, ) КАК ПродажиОбороты
    |
    |УПОРЯДОЧИТЬ ПО
    | Период
    |ИТОГИ
    | СУММА(Выручка)
    |ПО
    | ОБЩИЕ,
    | Мастер,
    | Период ПЕРИОДАМИ(День, &ДатаНачала, &ДатаОкончания)";

    Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
    Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);

    Результат = Запрос.Выполнить();

    ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
    ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
    ОбластьШапкаТаблицы = Макет.ПолучитьОбласть("ШапкаТаблицы");
    ОбластьПодвалТаблицы = Макет.ПолучитьОбласть("ПодвалТаблицы");
    ОбластьОбщийИтог = Макет.ПолучитьОбласть("ОбщиеИтоги");
    ОбластьМастер = Макет.ПолучитьОбласть("Мастер");
    ОбластьПериод = Макет.ПолучитьОбласть("Период");
    ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

    ТабДок.Очистить();
    ТабДок.Вывести(ОбластьЗаголовок);
    ТабДок.Вывести(ОбластьШапкаТаблицы);
    ТабДок.НачатьАвтогруппировкуСтрок();

    ВыборкаОбщийИтог = Результат.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

    ВыборкаОбщийИтог.Следующий(); // Общий итог
    ОбластьОбщийИтог.Параметры.Заполнить(ВыборкаОбщийИтог);
    ТабДок.Вывести(ОбластьОбщийИтог, ВыборкаОбщийИтог.Уровень());

    ВыборкаМастер = ВыборкаОбщийИтог.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

    Пока ВыборкаМастер.Следующий() Цикл
    ОбластьМастер.Параметры.Заполнить(ВыборкаМастер);
    ТабДок.Вывести(ОбластьМастер, ВыборкаМастер.Уровень());

    ВыборкаПериод = ВыборкаМастер.Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам, "Период", "Все");

    Пока ВыборкаПериод.Следующий() Цикл
    ОбластьПериод.Параметры.Заполнить(ВыборкаПериод);
    ТабДок.Вывести(ОбластьПериод, ВыборкаПериод.Уровень());

    ВыборкаДетали = ВыборкаПериод.Выбрать();

    Пока ВыборкаДетали.Следующий() Цикл
    ОбластьДетальныхЗаписей.Параметры.Заполнить(ВыборкаДетали);
    ТабДок.Вывести(ОбластьДетальныхЗаписей, ВыборкаДетали.Уровень());
    КонецЦикла;
    КонецЦикла;
    КонецЦикла;

    ТабДок.ЗакончитьАвтогруппировкуСтрок();
    ТабДок.Вывести(ОбластьПодвалТаблицы);
    ТабДок.Вывести(ОбластьПодвал);

    //}}КОНСТРУКТОР_ВЫХОДНЫХ_ФОРМ
    КонецПроцедуры[/codebox]

    заранее спасибо.
     
Загрузка...
Статус темы:
Закрыта.

Поделиться этой страницей