оч срочно помогите пожалуйста закрытие формы

  • Автор темы ssvetusik
  • Дата начала
S

ssvetusik

Гость
#1
мне необходимо сделать следующее при открытие документа закрыть имеющуюся обработку и автоматически открыть другую
Форма.Закрыть выполняется только в работе данного документа или обработке
а мне необходимо из документа закрыть форму((((((((
 
D

Dr.Uid

Гость
#2
"Топорный", но рабочий вариант:
1. В глобальнике заводим две переменные:
Перем глКонтекст Экспорт;
Перем глФормаОткрыта Экспорт;

2. В обработке, которую закрываем из вне добавляем:
Процедура ПриОткрытии()
глФормаОткрыта = 1;
глКонтекст = глВзятьКонтекст(Контекст);
КонецПроцедуры // ПриОткрытии

3. Для того что бы её закрыть:
Процедура Сформировать()
Если глФормаОткрыта = 1 Тогда
глКонтекст.Форма.Закрыть();
глФормаОткрыта = 0;
КонецЕсли;
КонецПроцедуры

И всё...
 
S

ssvetusik

Гость
#3
а процедура сформировать в документе делается????
 
D

Dr.Uid

Гость
#4
:)

Код из процедуры закрывает форму и её содержимое вставляем туда, откуда закрываем форму... т.е. в документ, обработку и т.д. в подходящую процедуру...
P.S. выше был пример...