1. Получи 30.000 рублей. Для получения денег необходимо принять участие в конкурсе авторов codeby. С условиями и призами можно ознакомиться на этой странице ...

    Внимание! Регистрация авторов на конкурс закрыта.

    Скрыть объявление
  2. Требуются разработчики и тестеры для проекта codebyOS. Требования для участия в проекте: Знание принципов работы ОС на базе Linux; Знание Bash; Крайне желательное знание CPP, Python, Lua; Навыки системного администрирования. Подробнее ...

    Скрыть объявление

оч срочно помогите пожалуйста закрытие формы

Тема в разделе "Базы данных и администрирование", создана пользователем ssvetusik, 27 сен 2007.

  1. ssvetusik

    ssvetusik Гость

    Репутация:
    0
    мне необходимо сделать следующее при открытие документа закрыть имеющуюся обработку и автоматически открыть другую
    Форма.Закрыть выполняется только в работе данного документа или обработке
    а мне необходимо из документа закрыть форму((((((((
     
  2. Dr.Uid

    Dr.Uid Гость

    Репутация:
    0
    "Топорный", но рабочий вариант:
    1. В глобальнике заводим две переменные:
    Перем глКонтекст Экспорт;
    Перем глФормаОткрыта Экспорт;

    2. В обработке, которую закрываем из вне добавляем:
    Процедура ПриОткрытии()
    глФормаОткрыта = 1;
    глКонтекст = глВзятьКонтекст(Контекст);
    КонецПроцедуры // ПриОткрытии

    3. Для того что бы её закрыть:
    Процедура Сформировать()
    Если глФормаОткрыта = 1 Тогда
    глКонтекст.Форма.Закрыть();
    глФормаОткрыта = 0;
    КонецЕсли;
    КонецПроцедуры

    И всё...
     
  3. ssvetusik

    ssvetusik Гость

    Репутация:
    0
    а процедура сформировать в документе делается????
     
  4. Dr.Uid

    Dr.Uid Гость

    Репутация:
    0
    :)

    Код из процедуры закрывает форму и её содержимое вставляем туда, откуда закрываем форму... т.е. в документ, обработку и т.д. в подходящую процедуру...
    P.S. выше был пример...
     
Загрузка...

Поделиться этой страницей