Перенос справочника ФизЛица

  • Автор темы WildAnther
  • Дата начала
W

WildAnther

#1
Доброго времени суток коллеги.
Переношу я значит справочник ФизическиеЛица,
После переноса, при попытки открыть элемент справочника выдает ошибочку следующего содержания:
<!--shcode--><pre><code class='1с'>{Справочник.ФизическиеЛица.Форма.ФормаЭлемента(206)}: Значение не является значением объектного типа (Количество)
Если мНаборЗаписейГражданство.Количество() > 0 Тогда[/CODE]
Не могу понять в чем дело... Надеюсь на вашу помощь.
Заранее благодарю.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#2
а что значит - "Переношу справочник" ?
 
W

WildAnther

#3
Да пожалуй не совсем ясно.
Переношу из Бухгалтерии в свою базу.
Беру копирую и вставляю к себе, ну сопутствующие ему объекты тоже переношу.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#4
ну еще стоило начать с платформы....
копируешь объект справочника целиком или же просто какие-то отдельные реквизиты или формы?
 
W

WildAnther

#5
Ох опять промах...
1С 8.1 БУХ 1.6
Переношу целиком весь справочник.
 

KiR

НЕ шибка опытный програмер)
11.09.2007
1 581
0
#6
а что есть - мНаборЗаписейГражданство? может этого нет в объекте текущего справочника? тогда нужно это либо переписать либо тоже скопировать... отследить легко отладчиком
 
W

WildAnther

#7
<!--shcode--><pre><code class='# 1c'>Перем мНаборЗаписейГражданство Экспорт;

.....

Процедура ГражданствоНачалоВыбора(Элемент, СтандартнаяОбработка)

СтандартнаяОбработка = Ложь;
Отказ = Ложь;
ФормаВвода = ПолучитьФорму("ФормаЗаписиГражданство", ЭтаФорма);
ФормаВвода.НаборЗаписей = мНаборЗаписейГражданство;
ФормаВвода.Открыть();

КонецПроцедуры

....

мНаборЗаписейГражданство = РегистрыСведений.ГражданствоФизЛиц.СоздатьНаборЗаписей();
....

Запрос.Текст =
"ВЫБРАТЬ РАЗРЕШЕННЫЕ
| ГражданствоФизЛицСрезПоследних.Период,
| ГражданствоФизЛицСрезПоследних.ФизЛицо,
| ГражданствоФизЛицСрезПоследних.Страна,
| ГражданствоФизЛицСрезПоследних.НеИмеетПравоНаПенсию,
| ГражданствоФизЛицСрезПоследних.НеЯвляетсяНалоговымРезидентомРФ
|ИЗ
| РегистрСведений.ГражданствоФизЛиц.СрезПоследних(, ФизЛицо = &ФизЛицо) КАК ГражданствоФизЛицСрезПоследних";
Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
ЗаполнитьЗначенияСвойств(мНаборЗаписейГражданство.Добавить(), Выборка);
КонецЕсли;[/CODE]

Вот.
 

tanat

Well-known member
02.03.2007
265
0
#8
мНаборЗаписейГражданство = РегистрыСведений.ГражданствоФизЛиц.СоздатьНаборЗаписей();

Это - в процедуре ЗаполнитьНаборыПоФизлицу(), которая инициализируется, в свою очередь, в Обработчике события ПередОткрытием() у формы элемента данного справочника в Бухгалтерии. Видимо не все "сопутствующие" объекты перенесли. Как действовать - решайте сами. Всё разжували дальше некуда).
А на будущее - учитесь пользоватсья отладчиком ( как сказал KiR) или глобальным поиском. С ними намного легче жить.

Получается что вы скопировали справочник из типовой,а регистры, из которых попадают данные в этот справочник - не скопировали. Или их переносите тоже или убирайте этипроцедуры вообще, если они вам ненужны.
 
W

WildAnther

#9
Это всё я прекрасно понимаю.
Отладчик осваиваю(честно)
Справочники и всё остальное я тоже перенес=)
 

tanat

Well-known member
02.03.2007
265
0
#10
пардон) не правильно Вам сказал:
Переменная эта определена в модуле объекта "Справочник.ФизическиеЛица" как:
мНаборЗаписейГражданство = РегистрыСведений.ГражданствоФизЛиц.СоздатьНаборЗаписей();


Очевидно, просто не перенесли регистр сведений "ГражданствоФизЛиц".
А ошибку вызывает, потому что в процедуре "ПриОткрытии" формы элемента стоит ссылка на процедуру
ОбновитьПредставлениеЭлемента("Гражданство");

Воюйте, вобщем).
 
W

WildAnther

#11
товарищи.. Оказался глупее глупого... Перенося. Не обратил внимания что мне не нужно Гражданство и как то запамятовал, потому что раньше с паспортом так было и распутался весь... Вообщем да.. не перенес регистр гражданство. убрав кусок кода всё встало на свои места. но ошибки еще есть... но их я попробую решить сам.=) благодарю!
 
W

WildAnther

#12
Товарищи столкнулся с следующей проблемой...
После изменения ДокументаУдостоверящегоЛичности в форме ФизическогоЛица никаких результатов... По следствию трасировки, выявил что в оригинале срабатывает

<!--shcode--><pre><code class='1c'>Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)

Если ИмяСобытия = "ОбновитьФорму" и (Источник = Ссылка или (ТипЗнч(Источник) = Тип("СправочникСсылка.ФизическиеЛица") и Источник.Пустая())) Тогда

ИмяОбновляемогоЭлемента = Параметр.ИмяЭлемента;
ОбновитьПредставлениеЭлемента(ИмяОбновляемогоЭлемента);

ИначеЕсли ИмяСобытия = "ОбновитьУдостоверениеЛичности" Тогда

ОбновитьПредставлениеЭлемента("УдостоверениеЛичности");

КонецЕсли;

КонецПроцедуры[/CODE]

У меня не срабатывает...
Тоесть не проходит строка из общей формы...

<!--shcode--><pre><code class='1c'>Оповестить("ОбновитьУдостоверениеЛичности");[/CODE]

Но почему не происходит перевод данных в формы ФизЛиц не понимаю...
 
W

WildAnther

#13
С оповещением разобрался, не так все сложно оказалось. =)