Простой запрос с условием

SeverBap

Well-Known Member
18.09.2007
451
0
#1
Подскажите как исправить этот запрос:
Код:
	Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ШтрихКод", ШК);
Запрос.Текст = "
|ВЫБРАТЬ
|	ШтрихКоды.Ссылка
|ИЗ
|	Справочник.ШтрихКоды КАК ШтрихКоды
|ГДЕ
|	ШтрихКоды.Наименование = &ШтрихКод
|";

РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();

Если Выборка.Следующий() Тогда
Возврат Выборка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;
где ШК - это наименование справочника...
 
T

thinkfast

Гость
#2
мб так:
|ГДЕ | ШтрихКоды.Наименование = &ШтрихКод.Наименование
или
|ГДЕ | ШтрихКоды.Ссылка= &ШтрихКод.Ссылка
 
H

has

Гость
#3
Bap пробелы в наименовании посмотри. Точнее сократи пробелы
 

unknown181538

НеГуру
28.12.2008
1 417
0
#4
Может, если поле одно, то и так сойдет, а вообще:
Если Выборка.Следующий() Тогда
Возврат Выборка.ссылка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;
 

unknown181538

НеГуру
28.12.2008
1 417
0
#5
ПС. А не устроит ? :
возврат Справочники.ШтрихКоды.НайтиПоНаименованию(ШК);
 

SeverBap

Well-Known Member
18.09.2007
451
0
#6
Хочется через запрос! Сейчас у меня и так по наименованиею ищит!
 

puh14

Well-Known Member
11.07.2008
1 412
0
#7
Запрос = Новый Запрос();
Запрос.УстановитьПараметр("ШтрихКод", ШК);
Запрос.Текст = "
|ВЫБРАТЬ
| ШтрихКоды.Ссылка
| ШтрихКоды.Наименование как СтрокаПоиска
|ИЗ
| Справочник.ШтрихКоды КАК ШтрихКоды
|ГДЕ
| Строкапоиска ПОДОБНО ""%"" + &ШтрихКод + ""%""
|";

Выборка = Запрос.Выполнить().Выбрать();
Если Выборка.Следующий() Тогда
Возврат Выборка.ПолучитьОбъект();
Иначе
Возврат Неопределено;
КонецЕсли;



что-то такое... А то с пробелами действительно нехорошо может получится. Наименование в отдельную переменную вытащил на всякий случай - мож и с ШтрихКоды.Наименование прокатит.