Странные тормоза с подформами

Тема в разделе "Lotus - Программирование", создана пользователем AlexyeNov, 24 июн 2010.

  1. AlexyeNov

    AlexyeNov Гость

    Всем привет!

    Когда нибудь встречал такую странность - при вложении на форму подформы открытии документа из Notes увеличивается секунды на три, а если в этой подформе ещё одна подформа вложена, то время загрузки увеличивается уже на 15 секунд :)
    В подформах ничего нету кроме текстового поля.

    Форма является response-to-response.
     
  2. hosm

    hosm * so what *

    Регистрация:
    18 май 2009
    Сообщения:
    2.450
    Симпатии:
    7
    вроде в 8ке это пофиксили. в качестве фикса для более ранних версий надо было пихать какой-то лотусскрипт-код в инициализации подформы (или формы тоже?)
     
  3. hosm

    hosm * so what *

    Регистрация:
    18 май 2009
    Сообщения:
    2.450
    Симпатии:
    7
    вот, нашла источник :)
    думаю, подробности можно посмотреть на сайте айбиэм в фикслисте к версии, если они этот баг документировали...
     
  4. AlexyeNov

    AlexyeNov Гость


    Спасибо, мне это правда не помогло ;)
    Помогло следующее: в каждую подформу засунул в глобалы Option Explicit...
    Прикольный баг :)
     
  5. Akupaka

    Akupaka А че я?.. О.о

    Регистрация:
    4 окт 2007
    Сообщения:
    3.373
    Симпатии:
    2
    В общем-то, это равноправное решение - код подформы сгенерировался.
    Так же как и обработка событий других объектов ( On Event ), если на событие не повесить хотя бы коммент, то код события не сгенерится и обработчик не сработает.

    С подформами какой-то аналогичный глюк, вероятно.
     
Загрузка...

Поделиться этой страницей