Codeby web-security - новый курс от Codeby Security School

Представляем вашему вниманию новый курс от команды The Codeby - "Тестирование Веб-Приложений на проникновение с нуля". Общая теория, подготовка рабочего окружения, пассивный фаззинг и фингерпринт, Активный фаззинг, Уязвимости, Пост-эксплуатация, Инструментальные средства, Social Engeneering и многое другое. Подробнее ...


Для запуска Metasploit Framework в Kali 2.0 смотрите здесь.

Чтобы соответствовать Политике Сетевых Служб (Network Services Policy) Kali Linux, при загрузке отсутствуют сетевые службы, включая службы базы данных, поэтому нужно сделать пару шагов чтобы запустить Metasploit с поддержкой базы данных.

Запускаем службу Kali PostgreSQL

Metasploit использует PostgreSQL как его базу данных, следовательно сначала её нужно запустить.

service postgresql start

Вы можете убедиться, работает ли PostgreSQL проверив вывод ss -ant и убедившись, что порт 5432 прослушивается.


Paranoid - курс от Codeby Security School

Представляем вашему вниманию курс от команды codeby - "Комплекс мер по защите персональных данных, анонимности в интернете и не только" Подробнее ...


State Recv-Q Send-Q Local Address:Port Peer Address:Port
LISTEN 0 128 :::22 :::*
LISTEN 0 128 *:22 *:*
LISTEN 0 128 127.0.0.1:5432 *:*
LISTEN 0 128 ::1:5432 :::*

Запуск службы Kali Metasploit

С запущенной PostgreSQL, следующее, что нам нужно, это запустить службу metasploit. В первый раз, когда запущена служба, она создаст базу данных msf3 user и базу данных называемую msf3. Служба также запустит Metasploit RPC и веб-сервер, который ей требуется.

service metasploit start

Запуск msfconsole в Kali

Сейчас, когда службы PostgreSQL и Metasploit запущены, вы можете запустить msfconsole и проверить работу базы данных командой db_status как показано ниже.

msfconsole
msf > db_status
[*] postgresql connected to msf3
msf >

Настройка Metasploit для запуска при загрузке системы

Если вы предпочитаете иметь запущенные PostgreSQL и Metasploit при старте системы, вы можете использовать update-rc.d для включения этих служб как показано ниже.

update-rc.d postgresql enable
update-rc.d metasploit enable

Codeby Market от Сodeby

Мы запустили свой магазин CodebyMarket Equipment for InfoSec. Уже добавили RaspberryAlfa Long-RangeOrange PiArduino и многое другое. Купить Pentesting Devices