При использовании airgeddon - ошибка

recrut

recrut

Member
26.09.2016
11
0
При использовании airgeddon - ошибка
Друзья, будьте добры, помогите исправить 4 ошибки
Иначе функционал неполноценныи
У меняKali Linux
Спасибо!!!

Optional tools: checking...

beef-xss .... Ok
packetforge-ng .... Ok
dhcpd .... Error (Possible package name : isc-dhcp-server / dhcp-server / dhcp)
wash .... Ok
etterlog .... Ok
dnsspoof .... Ok
reaver .... Ok
hostapd .... Error (Possible package name : hostapd)
iptables .... Ok
wpaclean .... Ok
bully .... Ok
sslstrip .... Ok
aireplay-ng .... Ok
unbuffer .... Ok
lighttpd .... Error (Possible package name : lighttpd)
crunch .... Ok
ettercap .... Ok
hashcat .... Ok
mdk3 .... Ok
bettercap .... Error (Possible package name : bettercap)
pixiewps .... Ok
 
valerian38

valerian38

Grey Team
20.07.2016
658
748
Ну так возьми и установи те пакеты которых не хватает в ручную:
dhcpd, hostapd, lighttpd, bettercap
 
  • Нравится
Реакции: nikos
nikos

nikos

Well-known member
25.12.2016
508
190
При использовании airgeddon - ошибка
Друзья, будьте добры, помогите исправить 4 ошибки
Иначе функционал неполноценныи
У меняKali Linux
Спасибо!!!

Optional tools: checking...

beef-xss .... Ok
packetforge-ng .... Ok
dhcpd .... Error (Possible package name : isc-dhcp-server / dhcp-server / dhcp)
wash .... Ok
etterlog .... Ok
dnsspoof .... Ok
reaver .... Ok
hostapd .... Error (Possible package name : hostapd)
iptables .... Ok
wpaclean .... Ok
bully .... Ok
sslstrip .... Ok
aireplay-ng .... Ok
unbuffer .... Ok
lighttpd .... Error (Possible package name : lighttpd)
crunch .... Ok
ettercap .... Ok
hashcat .... Ok
mdk3 .... Ok
bettercap .... Error (Possible package name : bettercap)
pixiewps .... Ok
Попробуй для начало
Код:
apt-get update && apt-get install dhcpd hostapd lighttpd bettercap
 
recrut

recrut

Member
26.09.2016
11
0
Попробуй для начало
Код:
apt-get update && apt-get install dhcpd hostapd lighttpd bettercap
Сделал, вот чо получилось:

root@kali:~# apt-get update && apt-get install dhcpd hostapd lighttpd bettercap
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package lighttpd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package dhcpd
E: Unable to locate package hostapd
E: Package 'lighttpd' has no installation candidate
E: Unable to locate package bettercap
 
valerian38

valerian38

Grey Team
20.07.2016
658
748
Ищи вот эти пакеты dhcpd, hostapd, lighttpd, bettercap в сети и устанавливай каждый по отдельности
 
w3n0m41k

w3n0m41k

Well-known member
30.10.2016
62
41
apt-get install isc-dhcp-server
[doublepost=1510925329,1510925295][/doublepost]apt-get install bettercap
[doublepost=1510925375][/doublepost]а вот тут черным почти по русски написали как возможно называется пакет(смотреть то что в скобках) dhcpd .... Error (Possible package name : isc-dhcp-server / dhcp-server / dhcp)
[doublepost=1510925486][/doublepost]но для начала apt-get update, apt-get upgrade а потом ставь
[doublepost=1510925644][/doublepost]и apt-get install lighttpd прости что так сумбурно и не по порядку просто пораллельно пробовал на виртуалке установить и профит все встало
 
  • Нравится
Реакции: nikos и recrut
recrut

recrut

Member
26.09.2016
11
0
Спасибо!
Но, вот что получилось:

root@kali:~# apt-get update
Reading package lists... Done
root@kali:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@kali:~# apt-get install lighttpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package lighttpd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lighttpd' has no installation candidate
root@kali:~# apt-get install bettercap
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package bettercap
root@kali:~# apt-get install isc-dhcp-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package isc-dhcp-server
root@kali:~#
 
w3n0m41k

w3n0m41k

Well-known member
30.10.2016
62
41
проверь sources.list
[doublepost=1510926626,1510926365][/doublepost]если kali то выглядеть должен так
 

Вложения

  • 111,3 КБ Просмотры: 179
nikos

nikos

Well-known member
25.12.2016
508
190
Спасибо!
Но, вот что получилось:

root@kali:~# apt-get update
Reading package lists... Done
root@kali:~# apt-get upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@kali:~# apt-get install lighttpd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package lighttpd is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'lighttpd' has no installation candidate
root@kali:~# apt-get install bettercap
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package bettercap
root@kali:~# apt-get install isc-dhcp-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package isc-dhcp-server
root@kali:~#
Да тут с репами проблемы вот команда для проверки
Код:
if cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main contrib non-free" || cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main non-free contrib"; then echo -e "\n\n\033[0;32mРепозиторий в порядке"; else echo -e "\n\n\033[0;31mПроблема с репозиторием"; fi
Если есть проблемы то это команда всё исправит
Код:
echo -e "deb https://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list
[doublepost=1510927115,1510926960][/doublepost]Потом когда репы починишь запусти вот эту команду
Код:
apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
 
w3n0m41k

w3n0m41k

Well-known member
30.10.2016
62
41
Да тут с репами проблемы вот команда для проверки
Код:
if cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main contrib non-free" || cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main non-free contrib"; then echo -e "\n\n\033[0;32mРепозиторий в порядке"; else echo -e "\n\n\033[0;31mПроблема с репозиторием"; fi
Если есть проблемы то это команда всё исправит
Код:
echo -e "deb https://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list
[doublepost=1510927115,1510926960][/doublepost]Потом когда репы починишь запусти вот эту команду
Код:
apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y
вот прям в точку))))))))))) просто команды не искал проще было скрин выкинуть))))))))))
 
  • Нравится
Реакции: recrut
z3RoTooL

z3RoTooL

Well-known member
28.02.2016
716
695
жеесть, я думал уже каждая бабка у подъезда врубается в кали, а тут же всё написано, и на гитхабе всё написано, но неееее... зачем чё-то читать, лучше на форуме запостить.
 
nikos

nikos

Well-known member
25.12.2016
508
190
жеесть, я думал уже каждая бабка у подъезда врубается в кали, а тут же всё написано, и на гитхабе всё написано, но неееее... зачем чё-то читать, лучше на форуме запостить.
Не все любят искать инфу есть те которые любят когда им всё разжуют :)
[doublepost=1510950609,1510950548][/doublepost]
жеесть, я думал уже каждая бабка у подъезда врубается в кали, а тут же всё написано, и на гитхабе всё написано, но неееее... зачем чё-то читать, лучше на форуме запостить.
Сам таким был пока не понял что в гугле бана не дают :)
 
recrut

recrut

Member
26.09.2016
11
0
Да тут с репами проблемы вот команда для проверки
Код:
if cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main contrib non-free" || cat /etc/apt/sources.list | grep -E "deb https://http.kali.org/kali kali-rolling main non-free contrib"; then echo -e "\n\n\033[0;32mРепозиторий в порядке"; else echo -e "\n\n\033[0;31mПроблема с репозиторием"; fi
Если есть проблемы то это команда всё исправит
Код:
echo -e "deb https://http.kali.org/kali kali-rolling main non-free contrib" > /etc/apt/sources.list
[doublepost=1510927115,1510926960][/doublepost]Потом когда репы починишь запусти вот эту команду
Код:
apt-get update && apt-get upgrade -y && apt-get dist-upgrade -y

hostapd, lighttpd, bettercap - решено

dhcpd - тут никак, пишет:
Evil Twin attack just AP (Locked option, it needs: dhcpd);
Evil Twin AP attack with sniffing and bettercap-sslstrip2/BeEF (Locked option, it needs: dhcpd);
dhcpd .... Error (Possible package name : isc-dhcp-server / dhcp-server / dhcp)


Перепробовал все, что писали выше
 
valerian38

valerian38

Grey Team
20.07.2016
658
748
hostapd, lighttpd, bettercap - решено

dhcpd - тут никак, пишет:
Evil Twin attack just AP (Locked option, it needs: dhcpd);
Evil Twin AP attack with sniffing and bettercap-sslstrip2/BeEF (Locked option, it needs: dhcpd);
dhcpd .... Error (Possible package name : isc-dhcp-server / dhcp-server / dhcp)


Перепробовал все, что писали выше
идёшь сюда:

скачиваешь пакет, потом устанавливаешь.
 
  • Нравится
Реакции: nikos
K

Knuckles

Здравствуйте! Нужна помощь по тому же вопросу, только с другими инструментами, я сильно нуп, надеюсь, сильно не заругаете:giggle: Использую Mint 19.x
 

Вложения

  • 286,7 КБ Просмотры: 234
Последнее редактирование:
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 554
3 395
сильно не заругаете:giggle:
Нет, но посоветуем начать учить англ.яз или хотя бы начать использовать транслейтер . Вам надо пакеты доствить, какие - программа написала. Как ставить пакеты в свою систему Вам известно?
 
K

Knuckles

Нет, но посоветуем начать учить англ.яз или хотя бы начать использовать транслейтер . Вам надо пакеты доствить, какие - программа написала. Как ставить пакеты в свою систему Вам известно?
Нет конечно, затем и интересуюсь! Чуть инглиша знаю, только пересел на линух, чокуда нажимать хз, где что почитать для лалок нашел только на гитхабе и у вас на форуме, ну и команду форума минт тоже дикими вопросами докучаю, к своему сожалению
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 554
3 395
Нет конечно, затем и интересуюсь!




название нужных программ Airgeddon написал

UPD Совет на будущее: когда будете использовать профильные форумы где обсуждают операционные системы, программерская тусовка, старайтесь не выпячивать для чего все надо ( я хочу взламывать точки, что с прогой, хек не прет ) - учитесь доносить проблему правильно и более мягко, как пользователь :) Это просто пожелание и совет он Вам много нервов сбережет, поможет получить помощь.
 
  • Нравится
Реакции: Knuckles
K

Knuckles





название нужных программ Airgeddon написал

UPD Совет на будущее: когда будете использовать профильные форумы где обсуждают операционные системы, программерская тусовка, старайтесь не выпячивать для чего все надо ( я хочу взламывать точки, что с прогой, хек не прет ) - учитесь доносить проблему правильно и более мягко, как пользователь :) Это просто пожелание и совет он Вам много нервов сбережет, поможет получить помощь.
Нене, только аудит своих беспроводных сетей, конечно! Спасибо огромное! Очень неловко за собственное невежество, приношу извинения за глазной дискомфорт, пойду пробовать!
 
Мы в соцсетях: