• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Проблема с установкой metasploit в termux

Oberon Phelonious

New member
15.04.2020
4
0
BIT
0
Всем привет!
Столкнулся с проблемой при установке Metasploit в Termux.

Пробовал несколько различных способов установки, но так ничего и не вышло.
Года 3-4 назад ставил примерно тем же способом, что сообщает нам "id2746" на другой телефон.

Все гораздо проще:
apt update && apt upgrade -y
Далее нужно включить в репозитории нестабильные пакеты:
apt install unstable-repo
Устанавливаем Metasploit:
apt install metasploit
Запуск стандартный:
msfconsole

Изучив данный вопрос в интернете, понял, что я такой не один - решения не нашел.
Пришлось возвращаться и продолжать самому.

Извращался, как только мог, но ничего не решало моей проблемы.
Вплоть до полного обнуления Termux - никаких изменений.

Код:
$ apt install unstable-repo
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package unstable-repo

$ apt install metasploit
Reading package lists... Done
Building dependency tree      
Reading state information... Done
E: Unable to locate package metasploit

Быть может кто подскажет, что с этим можно сделать?
 

Вложения

  • Снимок экрана 2020-04-15 в 5.02.59.png
    Снимок экрана 2020-04-15 в 5.02.59.png
    27,7 КБ · Просмотры: 359

EblanKalilinux

New member
12.03.2021
4
0
BIT
0
У меня тоже была такая проблема, но потом я понял что Metasploit убрали с пакетов pkg и apt ну и в общем нашол на github утилиту которая автоматически устанавливала тебе Metasploit но проблема была в том что если я устанавливал Metasploit таким образом то у меня не хотелся создаваться apk,exe (ну точнее они создавались но не хотели устанавливаться) ну и потом я удалил Metasploit и решил снова установить Metasploit с github но уже от другого челика, и у меня получилось! Всё apk и exe работали как надо, но потом мне пришлось удалить на время Termux и когда я его скачал снова (Termux) то захотел снова установить Metasploit, ну и сделал я тоже самое (зашол на github 2 челика) и установил его себе, но тут мне начала вылазить ошыбка мол у меня чего-то нету и показывало чего не хватает, потом методом проб и ошыбок я понял что у меня был установлен ruby версии 3.0.0 а для корректной работы нужен был ruby версии 2.7.0 (+ -) ну и я опять начал разбираться в этом, и сделал итог
1 - качаем и устанавливаем Metasploit у этого чела (noob-hackers/m-wiz)
2 - после того как установили Metasploit - сразу же его удаляем
3 - снова скачиваем Metasploit но только теперь у этого чела (gushmazuko/metasploit_in_termux)
И вуаля, после того как вы установите Metasploit у вас будет всё работать.
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!