• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Установка драйверов Alfa AWUS036NH для Kali Linux 2020.3 на Raspberry

Houston

Member
02.09.2020
6
0
BIT
0
Добрый день!
Столкнулся с проблемой установки драйверов Alfa AWUS036NH для Kali Linux 2020.3 на Raspberry. Скачивал несколько драйверов с разных сайтов, в том числе и с официального, но, насколько я понял, драйвера слишком старые для нынешней версии ядра, так что одноплатник этот модуль даже не видит.
Подскажите, пожалуйста, может, кто-то знает, как решается данная проблема?
 

zibruss

Green Team
04.06.2019
42
16
BIT
14
В целом kali 2020.3 не требует установки драйверов AWUS036NH, он так отлично видит . Разве что ставить нужно сетевые зависимости для Raspberry /
 

KrAsAv4iK

Member
01.09.2020
9
-1
BIT
0
В целом kali 2020.3 не требует установки драйверов AWUS036NH, он так отлично видит . Разве что ставить нужно сетевые зависимости для Raspberry /
Это на версии ядра 4.9 KaliLinux хорошо видел этот адаптер.
У kali 2020.3 версия ядра - 5.7
Возможно, на Raspberry ядро kali не содержит драйверов для этого устройства/
У меня имеется и Raspberry и AWUS036NH, но нет желания и времени проверить, чтобы быть убедительнее .
 

Houston

Member
02.09.2020
6
0
BIT
0
Если я всё правильно понял, то у меня стоит ядро Kernel 4.19.118, но системой модуль так и не определился.
Это на версии ядра 4.9 KaliLinux хорошо видел этот адаптер.
У kali 2020.3 версия ядра - 5.7
Возможно, на Raspberry ядро kali не содержит драйверов для этого устройства/
У меня имеется и Raspberry и AWUS036NH, но нет желания и времени проверить, чтобы быть убедительнее .
 

zibruss

Green Team
04.06.2019
42
16
BIT
14

Это на версии ядра 4.9 KaliLinux хорошо видел этот адаптер.
У kali 2020.3 версия ядра - 5.7
Возможно, на Raspberry ядро kali не содержит драйверов для этого устройства/
У меня имеется и Raspberry и AWUS036NH, но нет желания и времени проверить, чтобы быть убедительнее .
Он и на 5.7 ощущает себя отлично.

Screenshot_3.png
 
Последнее редактирование:

zibruss

Green Team
04.06.2019
42
16
BIT
14
На самом одноплатнике, образ брал с офф сайта, специально под малинку
Какие сетевые драва ставил ? пробуй это если ее не ставил Realtek RTL8192CU .

далее помануалке

Код:
sudo nano /etc/network/interfaces

auto wlan0

allow-hotplug wlan0

iface wlan0 inet manual

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
 

Houston

Member
02.09.2020
6
0
BIT
0
Какие сетевые драва ставил ? пробуй это если ее не ставил Realtek RTL8192CU .

далее помануалке

Код:
sudo nano /etc/network/interfaces

auto wlan0

allow-hotplug wlan0

iface wlan0 inet manual

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
Понял, спасибо, попробую при возможности

Какие сетевые драва ставил ? пробуй это если ее не ставил Realtek RTL8192CU .

далее помануалке

Код:
sudo nano /etc/network/interfaces

auto wlan0

allow-hotplug wlan0

iface wlan0 inet manual

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
Всё сделал, по итогу, система теперь не видит и встроенный вайфай модуль. Пишет: Device not managed
 

zibruss

Green Team
04.06.2019
42
16
BIT
14
Я уже протестил. Зафурычало на ура. Скинул мануал. Делай все что там нарисовано. И будет счастье.
 

Houston

Member
02.09.2020
6
0
BIT
0
Я уже протестил. Зафурычало на ура. Скинул мануал. Делай все что там нарисовано. И будет счастье.
Сделал всё, как в инструкции, но не помогло. Встроенный модуль тоже не заработал.
 

Fnoobas

New member
29.10.2020
1
0
BIT
0
Добрый день!
Столкнулся с проблемой установки драйверов Alfa AWUS036NH для Kali Linux 2020.3 на Raspberry. Скачивал несколько драйверов с разных сайтов, в том числе и с официального, но, насколько я понял, драйвера слишком старые для нынешней версии ядра, так что одноплатник этот модуль даже не видит.
Подскажите, пожалуйста, может, кто-то знает, как решается данная проблема?
Проблема решена? Адаптер не определяется только в kali linux или и в других системах? Лампочка горит или мигает? Адаптер куплен на aliexpress? Пробовали менять провод?
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!