• Профессиональным авторам. Срочный заказ!

    Необходимо сделать развернутое описание каждой из наших услуг. Ограничений на объем текста нет. ЦА - руководство компаний (сухой технический текст). При отсутствии исполнителей среди участников форума, работа будет передана фрилансерам 10 февраля.

    Подробнее о заказе ...

Статья Установка Metasploit-Framework на Android-устройство [NO ROOT]

v1ri0us

v1ri0us

Member
22.03.2019
5
18
Привет, сегодня я расскажу про установку Metasploit-Framework на твое Android-устройство.
На сегодняшний день, Metasploit является одним из лучших инструментов пентеста. В нем собранно несколько тысяч эксплоитов и не только. С его помощью даже можно создать свой новый инструмент.
И так к делу

Нам понадобится:


1) Телефон​
2) Приложение Termux​
Play Market:
F-Droid:
3) 400-500 MB свободной памяти на устройстве​
4) Интернет (лучше Wi_Fi)​
Запустив приложение вы увидите это:

27857


Перед началом нужно обновить пакеты:
Код:
apt update & apt upgrade -y
Далее нужно включить в репозитории нестабильные пакеты:
Код:
apt install unstable-repo
И наконец устанавливаем сам Metasploit:
Код:
apt install metasploit
Пройдет 5-15 минут и Metasploit установится
Важно! Во время установки ни в коем случае не останавливайте процесс, иначе можете навредить телефону
После установки, Metasploit можно будет открыть при помощи команды msfconsole
 
Slava tm

Slava tm

Member
17.03.2019
12
11
Самая простейшая инструкция, так как термукс на смарте имеется пошёл тестить, отчёт будет ниже...
 
  • Нравится
Реакции: v1ri0us
V

Valkiria

v1ri0us, как ты делаешь скриншоты на телефоне ?
Статья написана с телефона или с компьютера ?
Если с компьютера, то как ты переносишь скриншоты с телефона ?
 
v1ri0us

v1ri0us

Member
22.03.2019
5
18
v1ri0us, как ты делаешь скриншоты на телефоне ?
Статья написана с телефона или с компьютера ?
Если с компьютера, то как ты переносишь скриншоты с телефона ?
Скриншот с телефона - сочетание клавиш включения и громкости -
Переношу через usb кабель
Статья написана с компьютера

Самая простейшая инструкция, так как термукс на смарте имеется пошёл тестить, отчёт будет ниже...
Удачи:3

Если хотите узнать больше про msf - пишите
 
  • Нравится
Реакции: Valkiria
Slava tm

Slava tm

Member
17.03.2019
12
11
Кароче итоги теста в скринах, все расписывать лень да и время уже 3 часа ночи
Screenshot_2019-03-23-01-50-03.png



Screenshot_2019-03-23-01-50-46.png


Screenshot_2019-03-23-01-51-09.png


Screenshot_2019-03-23-01-51-59.png


Screenshot_2019-03-23-01-53-51.png
Screenshot_2019-03-23-01-55-52.png


Screenshot_2019-03-23-01-56-42.png


Screenshot_2019-03-23-01-57-52.png


Screenshot_2019-03-23-02-04-43.png


Screenshot_2019-03-23-02-05-34.png


Screenshot_2019-03-23-02-06-56.png


Screenshot_2019-03-23-02-11-42.png


Screenshot_2019-03-23-02-17-48.png


Screenshot_2019-03-23-02-19-32.png


Screenshot_2019-03-23-02-22-36.png


Screenshot_2019-03-23-02-24-43.png


Screenshot_2019-03-23-02-26-45.png


Screenshot_2019-03-23-02-27-04.png


Screenshot_2019-03-23-02-27-43.png


Screenshot_2019-03-23-02-27-59.png
Не знаю почему но установка заняла очень много времени и кажется я где-то натупил что нифига не установилось...

Ссорян ребят это я натупил, не запустил консоль...
Screenshot_2019-03-23-03-16-11.png
Всё работает
 
D

Doomy

А почему на ранних описаниях, кои я встречал в других источниках, репозитории надо было настраивать из Гитхаба? Тут как то реально все просто. В чем тогда там был подвох?
 
v1ri0us

v1ri0us

Member
22.03.2019
5
18
А почему на ранних описаниях, кои я встречал в других источниках, репозитории надо было настраивать из Гитхаба? Тут как то реально все просто. В чем тогда там был подвох?
Не знаю=/
 
CookieShark

CookieShark

New member
19.02.2019
2
1
Крутяк, единственный способ, которым удалось таки заставить msfconsole запускаться в термухе. Только вот migrate не хочет выполняться, это уже видимо какие-то индивидуальные проблемы.
Android 5.1 (оболочка FlymeOS 6)
27904
 
gushmazuko

gushmazuko

Red Team
24.03.2017
162
388
Nomikama

Nomikama

New member
25.10.2018
2
2
Возможно только у меня так было, но все же..
На этапе:
Перед началом нужно обновить пакеты:

apt update & apt upgrade -y
У меня только проверило обновление но не установило, пришлось дописывать потом ещё раз "apt upgrade" отдельно, так что будьте внимательны.
 
  • Нравится
Реакции: v1ri0us
G

Gorbushkaa

New member
29.03.2019
1
1
А будут посты про сам msf. Ну тип его возможности, отдельные фишки?
 
  • Нравится
Реакции: Мамонт
CookieShark

CookieShark

New member
19.02.2019
2
1
Возможно только у меня так было, но все же..
На этапе:

У меня только проверило обновление но не установило, пришлось дописывать потом ещё раз "apt upgrade" отдельно, так что будьте внимательны.
просто там не хватает знака & еще одного, должно было выглядеть так:
apt update && apt upgrade -y
 
expl0iter

expl0iter

Member
05.12.2018
5
1
Успешно, но времени заняло много. Причем получилось так, что телефон час был без интернета, не очень аккуратно юзабелен, благо не превратился в кирпич. Спасибо за статью!
 
  • Нравится
Реакции: v1ri0us
G

GOOD

New member
08.05.2019
2
0
Всем привет! Помогите пожалуйста выскачила ошибка
Код:
124:in                                    `with_friendly_errors'                    /data/data/com.termux/files/usr/bin/bundle:22:in
`<main>'                                                                            An error occurred while
installing nokogiri (1.10.2), and Bundler cannot continue.                          Make sure that `gem install nokogiri -v   '1.10.2' --source 'RubyGems.org | your community gem host'`succeeds before bundling.                
In Gemfile:                               factory_bot_rails was resolved to 5.0.2,  which depends on
railties was resolved to 4.2.11.1,        which depends on                          actionpack was resolved to 4.2.11.1,      which depends on                          actionview was resolved to                4.2.11.1, which depends on                rails-dom-testing was resolved            to 1.0.9, which depends on                            nokogiri                      dpkg: error processing package metasploit (--configure):                             installed metasploit package post-installation script subprocess returned error exit status 5                                Errors were encountered while processing:  metasploit                               E: Sub-process /data/data/com.termux/files/usr/bin/dpkg returned an error code (1)
 
D

dream-team777

Member
14.03.2018
18
8
Интересно каким образом получается КИРПИЧ? :)))
 
Мы в соцсетях: