ОБСУЖДЕНИЕ

Не запускаются Perl скрипты на сервере

1 ответов 5,5 тыс.
AI-выжимка обсуждения скоро

Краткие тезисы обсуждения со ссылками на ключевые ответы появятся здесь.

Статус
Закрыто для дальнейших ответов.
Автор темы
Всем привет.
Есть сервер, OS на сервере CentOs 5.4
Нужно установить скрипт, который написан на Perl.
Файлы залил в бинарном режиме, но при запросе любого файла с расширением .cgi из браузера возникает ошибка 500 Internal Server Error и файл отображается как простой текст в браузере, вот так:

Код:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>500 Internal Server Error</title>
</head><body>
<h1>Internal Server Error</h1>
<p>The server encountered an internal error or
misconfiguration and was unable to complete
your request.</p>
<p>Please contact the server administrator,
root@localhost and inform them of the time the error occurred,
and anything you might have done that may have
caused the error.</p>
<p>More information about this error may be available
in the server error log.</p>
<hr>
<address>Apache/2.2.3 (CentOS) Server at мой_домен.org Port 80</address>
</body></html>

Как исправить?
 
* убедитесь что на залитых .cgi файлах стоит бит execute (поставьте chmod 755 например)
* может не хватать модулей. CPanel, например, позволяет установить недостающие модули с CPAN'а. в таком случае возможно придётся добавить в ваш CGI скрипт BEGIN блок который указан в разделе CPanel откуда устанавливаются модули.
* до сих пор не помогает? .. добавьте use CGI::Carp qw(fatalsToBrowser); в начала скрипта -- это быдет выкидывать ошибки в работе самого скрипта в браузер. Не забудьте убрать эту строку после того как разберётесь с проблемой.
* смотрите error логи на серваке (в контрольной панели обычно есть для этого раздел)

удачи
 
Статус
Закрыто для дальнейших ответов.