• Открыта запись на вторую часть курса по анонимности и безопасности в сети интернет "Paranoid II" от команды codeby. Анонимные роутеры, Подъём, настройка и администрирование Tor-ноды, Работа с железом ПК, Удаление аппаратных закладок, Минимизация рисков, Авторские разработки и многое другое. Подробнее ...

Аварийный пароль «NUKE» в Linux Mint

M

malinovyi_zvon

New member
09.03.2019
1
0
Всем привет. Необходимо реализовать NUKE на «Linux Mint 18.3 Sylvia». Воспользовался данным гайдом: , но что-то пошло не так. Привожу порядок команд:
# sudo apt-get update
# sudo apt-get install libgcrypt11-dev libdevmapper-dev libpopt-dev uuid-dev libtool automake autopoint debhelper xsltproc docbook-xsl dpkg-dev
# sudo apt-get source cryptsetup
# git clone
# cd cryptsetup-1.6.6
# patch -p1 < ../cryptsetup-nuke-keys/cryptsetup_1.6.1+nuke_keys.diff
# dpkg-buildpackage -b -uc |Тут появляется ошибка:
" dpkg-checkbuilddeps: ошибка: Unmet build dependencies: build-essential:native dpkg-buildpackage: предупреждение: неудовлетворительные зависимости/конфликты при сборке; прерываемся dpkg-buildpackage: предупреждение: (Используйте параметр -d, чтобы продолжить сборку.) "
# dpkg-buildpackage -b -uc -d |Делаю как было предложено, и снова ошибка:
" rm: невозможно удалить 'autom4te.cache': Это каталог debian/rules:196: ошибка выполнения рецепта для цели «clean» make: *** [clean] Ошибка 1 dpkg-buildpackage: ошибка: debian/rules clean возвратил код ошибки 2 "
Думается мне что дело в несовместимости патча (на гитхаб лежит cryptsetup 2:1.6.1 , а у меня установлен cryptsetup 2:1.6.6). Где может быть ошибка?
 
Мы в соцсетях:  ТелеграмВконтактеДзенФейсбукТвиттерЮтуб