• Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Проблема Автозагрузка sshd

fakecop

Green Team
23.12.2016
105
26
BIT
1
Помогите пожалуйста отключить демона
Я все перелопатил но все равно не что не получается

1531856135676.png


Проблема в том что sshd зачем то запускается при старте, но вот что его запускает не совсем понятно и как из авто запуска его убрать??((
 

+Maxon4ik

Green Team
06.03.2018
23
48
BIT
0
1. Service - - status-all посмотреть какие службы сейчас запущены, а какие нет!
2. Systemctl is-enabled tor, посмотреть включён ли сервис тор на автозагрузку, в твоём случае ssh вместо tor.
3. Sуstemctl enable tor включить сервис тор в автозагрузку
4. Systemctl disable tor соответсвенно выключить из автозагрузки.....
Если не помогло, возможно создан некий скрипт с запуском сервиса и добавлен в cron.... набери crontab -e и посмотри строки начинающиеся с “@reboot”
 
  • Нравится
Реакции: mz111 и Vertigo

fakecop

Green Team
23.12.2016
105
26
BIT
1
1. Service - - status-all посмотреть какие службы сейчас запущены, а какие нет!
2. Systemctl is-enabled tor, посмотреть включён ли сервис тор на автозагрузку, в твоём случае ssh вместо tor.
3. Sуstemctl enable tor включить сервис тор в автозагрузку
4. Systemctl disable tor соответсвенно выключить из автозагрузки.....
Если не помогло, возможно создан некий скрипт с запуском сервиса и добавлен в cron.... набери crontab -e и посмотри строки начинающиеся с “@reboot”
Тор я не устанавливал и сервиса тоже нету, крон установил и по вводу команды кронтаб везде пусто
П.С. у меня арч
 

Vertigo

Lex mea est Vulgate Linux
Gold Team
15.02.2017
1 318
3 999
BIT
1
Пример выше отключения правильный по сути.
В Arch systemd рулит. Система Вам и в терминале указывает на демона и службу .
Пробуйте
Код:
# systemctl disable sshd.service -убрать из автозагрузки
# systemctl stop sshd.service - остановить
 
  • Нравится
Реакции: itsecstig и Глюк

fakecop

Green Team
23.12.2016
105
26
BIT
1
Пример выше отключения правильный по сути.
В Arch systemd рулит. Система Вам и в терминале указывает на демона и службу .
Пробуйте
Код:
# systemctl disable sshd.service -убрать из автозагрузки
# systemctl stop sshd.service - остановить
Да это я знаю, об этом и пишут везде, но у меня проблема другая
Даже когда отключаю автозапуск systemctl disable sshd он все равно запускается
Можно конечно же каждый раз при запуске писать systemctl stop sshd , но ведь это не решение проблемы
 

Vertigo

Lex mea est Vulgate Linux
Gold Team
15.02.2017
1 318
3 999
BIT
1
Даже когда отключаю автозапуск systemctl disable sshd он все равно запускается
Значит что-то перемудрили либо с правами,либо с установкой.
Может у Вас ещё и sshd.socket добавлен в автозагрузку?
Попробуйте и его отключить таким же способом.
Файл затем можно проверить /etc/ssh/sshd.config и посмотреть что там за настройки такие .
 
  • Нравится
Реакции: Глюк

fakecop

Green Team
23.12.2016
105
26
BIT
1
Значит что-то перемудрили либо с правами,либо с установкой.
Может у Вас ещё и sshd.socket добавлен в автозагрузку?
Попробуйте и его отключить таким же способом.
Файл затем можно проверить /etc/ssh/sshd.config и посмотреть что там за настройки такие .
Решил замаскировать демона, что бы не загружался при старте
Это помогло, но не думаю что это то самое решение
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!