• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

не могу установить метасплоит в termux

28.08.2020
5
0
BIT
0
во время уcтановки метасплоита выдаёт ошибку. Устанавливал метасплоит через github сначала он потребовал уcтановить что то ещё.... я установил..... опять попросил установить..... после ввода этих комvанд выдаёт ошибку якобы не может уcтановить nokogiri 1.10.10 после решил попробовать другой репозиторий ( sparklemotion/nokogiri ) выдаёт ошибку 21 или конкретнее metasploit.sh: 21: metasploit.sh: Syntax error: "(" unexpected. Я уже не понимаю что делать поэтому пишу на этот форум. Спасибо всем кто ответил)
 

Pernat1y

Red Team
05.04.2018
1 443
135
BIT
0
Пробуй так:
Код:
pkg install unstable-repo
pkg install metasploit
PS. Ещё недавно пакет был сломан но сейчас уже пофиксили.
 
28.08.2020
5
0
BIT
0
не работает
1.jpeg
 

rwxrwxrwx

Green Team
25.11.2020
114
46
BIT
0
Хм,при установке нестабильных репозиториев не должна вылезать проблема "Unable to locate package unstable-repo"
Попробуй в termux'e написать cd $PREFIX/etc/apt потом cd sources.list.d и если в этой папке есть "unstable.list" то написать nano unstable.list и проверить,написано ли там это deb https://dl.bintray.com/xeffyr/unstable-packages unstable main должно быть написано только это,и ничего больше
Если же unstable.list не существует,то нужно создать его touch unstable.list и проделать все тоже самое выше (с открытием листа и вписывании деба)
 
28.08.2020
5
0
BIT
0
спасибо всем кто мне помогал. Установил на другом телефон всё просто шикарно. Значит проблема в моём телефоне. Сейчас попробую сделать как сказал

rwxrwxrwx. всем спасибо кто мне помогал)​

 
Последнее редактирование:
28.08.2020
5
0
BIT
0
не сработало. будем считать что мой телефон не поддерживает метасплоит. Но всё равно спасибо всем кто помогал. Ну то есть он начал какую-ту загрузку и потом выдал ту же ошибку. Когда решил сращу установить метасплоит он выдал ошибку что нужна версия руби больше 2.7 как установить руби определённую версию я не знаю.
 
Последнее редактирование:

Pernat1y

Red Team
05.04.2018
1 443
135
BIT
0
не сработало. будем считать что мой телефон не поддерживает метасплоит. Но всё равно спасибо всем кто помогал. Ну то есть он начал какую-ту загрузку и потом выдал ту же ошибку. Когда решил сращу установить метасплоит он выдал ошибку что нужна версия руби больше 2.7 как установить руби определённую версию я не знаю.
Попробуй остановить Termux и почистить data/cache через управлялку приложениями в андроиде.
 

gu3st

Green Team
11.02.2018
11
3
BIT
0
Здравствуйте, Уважаемые!)
По всей видимости, с репы термукс удалили метасплоит, гидру и склмап...
Ладно с двумя последними, скажите на радость как метасплоит установить)
Заранее благодарю)
С ув. Мистер Икс)
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!