• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Не могу запустить в kali linux gvm-setup

girocoptyr

Member
02.12.2023
6
0
BIT
2
Ввожу команду gvm-setup, пишет:
[>] Starting PostgreSQL service
[-] ERROR: The default PostgreSQL version (15) is not 16 that is required by libgvmd
[-] ERROR: libgvmd needs PostgreSQL 16 to use the port 5432
[-] ERROR: Use pg_upgradecluster to update your PostgreSQL cluster
Обновляю postgresql, пишет что 16 версия уже установлена, обновляю кластер postgresql, пишет что тоже установлено, помогите добрые люди :(
 

Exited3n

Red Team
10.05.2022
686
243
BIT
510
Ввожу команду gvm-setup, пишет:
[>] Starting PostgreSQL service
[-] ERROR: The default PostgreSQL version (15) is not 16 that is required by libgvmd
[-] ERROR: libgvmd needs PostgreSQL 16 to use the port 5432
[-] ERROR: Use pg_upgradecluster to update your PostgreSQL cluster
Обновляю postgresql, пишет что 16 версия уже установлена, обновляю кластер postgresql, пишет что тоже установлено, помогите добрые люди :(
Bash:
sudo nano /etc/postgresql/15/main/postgresql.conf
# port меняешь на 5433

sudo nano /etc/postgresql/16/main/postgresql.conf
# port меняешь на 5432

sudo reboot
sudo gvm-setup
 

girocoptyr

Member
02.12.2023
6
0
BIT
2
Bash:
sudo nano /etc/postgresql/15/main/postgresql.conf
# port меняешь на 5433

sudo nano /etc/postgresql/16/main/postgresql.conf
# port меняешь на 5432

sudo reboot
sudo gvm-setup
спасибо конечно, но после данной процедуры, вылезла другая ошикбка :/
[-] ERROR: No PostgreSQL version uses the port 5432/TCP
[-] ERROR: libgvmd needs PostgreSQL 16 to use the port 5432
[-] ERROR: Use pg_upgradecluster to update your PostgreSQL cluster
 

Exited3n

Red Team
10.05.2022
686
243
BIT
510
спасибо конечно, но после данной процедуры, вылезла другая ошикбка :/
[-] ERROR: No PostgreSQL version uses the port 5432/TCP
[-] ERROR: libgvmd needs PostgreSQL 16 to use the port 5432
[-] ERROR: Use pg_upgradecluster to update your PostgreSQL cluster
Вывод покажи - sudo netstat -tulnp
Это тоже - pg_lsclusters
 

girocoptyr

Member
02.12.2023
6
0
BIT
2
Bash:
sudo nano /etc/postgresql/15/main/postgresql.conf
# port меняешь на 5433

sudo nano /etc/postgresql/16/main/postgresql.conf
# port меняешь на 5432

sudo reboot
sudo gvm-setup
УРААА ЗАПУСТИЛОСЬ!!!

УРААА ЗАПУСТИЛОСЬ!!!
Вывод покажи - sudo netstat -tulnp
Это тоже - pg_lsclusters
у меня почему-то было 2 версии postgresql, я одну удалил 15 версию, прописал в конфиге 16-ой версии то что ты сказал, и заработало! СПУСТЯ 3 ДНЯ, ураааа, я теперь могу продолжить обучение,
СПАСИБО ТЕБЕ БОЛЬШОЕ
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!