• Открыта запись на вторую часть курса по анонимности и безопасности в сети интернет "Paranoid II" от команды codeby. Анонимные роутеры, Подъём, настройка и администрирование Tor-ноды, Работа с железом ПК, Удаление аппаратных закладок, Минимизация рисков, Авторские разработки и многое другое. Подробнее ...

Статья NECTOR Pentest Framework

Vander

Vander

CodebyTeam
Gold Team
16.01.2016
1 453
4 289
Всем привет! В этой статье речь пойдет о фреймворке под названием NECTOR - Целью NECTOR является повышение осведомленности в области безопасности, к примеру, учреждений путем демонстрации потенциальных уязвимостей в системе.

NECTOR Pentest Framework


NECTOR - это мощная и расширяемая структура, используемая для сбора, анализа и использования информации при разведке.

NECTOR Pentest Framework


NECTOR - использует функциональность и стабильность структуры Django и включает в себя бэкэнд базы данных SQLite с минималистичным интерфейсом. Проект разрабатывается без использования JavaScript.

Интуитивно понятный веб-интерфейс NECTOR позволяет легко анализировать данные, настраивать параметры сканирования, отчеты об инцидентах и многое другое.

Приложения:

· Хосты (подсети)

· Обнаружение

· Osint

· События

· Отчеты

Установка и запуск (Kali Linux 2017.2):

> git clone

> cd /nector

NECTOR Pentest Framework


> pip3 install virtualenv

NECTOR Pentest Framework


> source venv-nector/bin/activate

> pip install –r requirements.txt

NECTOR Pentest Framework


Запуск фреймворка:

> python manage.py migrate

NECTOR Pentest Framework


> python manage.py runserver

NECTOR Pentest Framework


В браузере обращаемся к NECTOR по адресу 127.0.0.1:8000, в случае успеха, попадаем в административную панель управления фреймворком:

NECTOR Pentest Framework


На этом все, спасибо за внимание.
 
Tihon49

Tihon49

Премиум
06.01.2018
203
107
Понтяно что это джанго, не понятно что не так с SECRET_KEY. Я вставил туда код от своего проекта, но чё-то матюкается....
К слову, на винде всё это запускать пытаюсь пока.
Лень перезагружать ноут xD

Так же просит :
error: Microsoft Visual C++ 14.0 is required. Get it with "Microsoft Visual C++ Build Tools":

Если не получится, попробую, как и положено на кали запустить. )))))
 
Мы в соцсетях:  ТелеграмВконтактеДзенФейсбукТвиттерЮтуб