Проблема Обновления для kali linux

KogNik

KogNik

Member
12.11.2019
8
0
IMG_20191112_055155.jpg
Kali linux, что можно сделать, в интернете при поиске данных файлов, нахожу только старые версии. Новичок, так что прошу не ругать)
 
KogNik

KogNik

Member
12.11.2019
8
0
Может быть попробовать заморозить эти пакеты? Ну отключить для них поиск обновлений или что-то подобное. Если это может подействовать, то как это сделать?
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 554
3 394
а может попробовать обновиться через консоль? apt-get update && apt-get dist-upgrade
и после можно пробовать ставить нужные Вам пакеты, если нужда осталась. Потому что, скорее всего, Вы уже что то ставили через синаптик, где то насильно, что то не соблюдалось, часть ставили руками, в итоге зависимости все поплыли. Вообщем начните с консольного обновления через команды выше.
 
KogNik

KogNik

Member
12.11.2019
8
0
а может попробовать обновиться через консоль? apt-get update && apt-get dist-upgrade
и после можно пробовать ставить нужные Вам пакеты, если нужда осталась. Потому что, скорее всего, Вы уже что то ставили через синаптик, где то насильно, что то не соблюдалось, часть ставили руками, в итоге зависимости все поплыли. Вообщем начните с консольного обновления через команды выше.
Не помогло
IMG_20191112_104755.jpg

--fix-missing добавлял следом за этой попыткой
 
KogNik

KogNik

Member
12.11.2019
8
0
apt-get update --fix-missing
Пробовал, тот же результат, по ссылке нет этой версии которую он ищет и вообще нет версии в интернете xterm и libbrotli1 которую он пытается установить

apt-get update --fix-missing
Не считая этих двух все остальное прекрасно обновляется и устанавливается
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 554
3 394
Эти пакеты просит
Не считая этих двух все остальное прекрасно обновляется и устанавливается
Тогда и переживать не стоит =) Последние пакеты вижу как 344, думаю Вы их так же там могли видеть (

Можно пойти не совсем хорошим путем, обновить полностью систему, без учета зависимостей, а просто догнать до последних версий:
apt update
apt list --upgradable
apt upgrade -y

Но есть шанс что то упадет ) И тогда будет не такая мелочь, а более серьезный масштаб
 
f22

f22

Red Team
05.05.2019
1 399
107
Попробуй удалить и установить заново пакеты
apt-get purge -y xterm libbrotli1; apt-get install -y xterm libbrotli1
 
KogNik

KogNik

Member
12.11.2019
8
0
Да, как раз там и видел
Так я не могу установить ничего
 
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 554
3 394
Да, как раз там и видел
Так я не могу установить ничего
Видели где? Не совсем понятно. Вы можете пока не делать акцент на этих пакетах - роли особой в системе они не играют, рано или поздно производитель решит этот вопрос.
 
Последнее редактирование:
KogNik

KogNik

Member
12.11.2019
8
0
Как в обход выполнить команду apt-get install " " чтобы не пытался обновить эти два пакета и не выдавал эту ошибку 404
 
H

hamerik

Active member
26.06.2019
35
3
Может быть попробовать заморозить эти пакеты? Ну отключить для них поиск обновлений или что-то подобное. Если это может подействовать, то как это сделать?
Вот так можно заморозить нужные пакеты.

1: sudo apt-mark hold xterm libbrotli1
 
П

Петручо

Well-known member
27.11.2016
98
8
сначала надо обновить репы , по ходу где то есть косяк . у меня такое было , уже не помню как исправил , но там выводило на ошибку с неверным ключем какого то репозитория, хотя сурслист был чистым и там был только репозиторий кали. поиск по этому ключу показал как исправить , после этого dist upgrade заработал нормально.
 
NEKO4ANXD

NEKO4ANXD

New member
09.02.2020
3
0
Попробуй удалить и установить заново пакеты
apt-get purge -y xterm libbrotli1; apt-get install -y xterm libbrotli1
у меня пишет
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
 
f22

f22

Red Team
05.05.2019
1 399
107
у меня пишет
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
E: Could not open lock file /var/lib/dpkg/lock-frontend - open (13: Permission denied)
E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), are you root?
Запускай команды через sudo
sudo apt-get update && sudo apt-get upgrade -y
 
Мы в соцсетях: