• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Проблема при запуске net-creds

Niko20

Member
22.10.2020
9
0
BIT
0
При попытке запустить net-creds вылетает вот такое:
user123@kali:~/net-creds$ sudo python net-creds.py
Traceback (most recent call last):
File "net-creds.py", line 7, in <module>
from scapy.all import *
ImportError: No module named scapy.all
сам еще не очень в этой теме, только начинаю изучать.
 

Niko20

Member
22.10.2020
9
0
BIT
0
Гуглить ошибку пробовал?
да

У тебя видимо отсутствует модуль, установи sudo pip install scapy
при установке получил вот такую вещь:

sudo pip install scapy
Requirement already satisfied: scapy in /usr/lib/python3/dist-packages (2.4.4)
как понял из объяснений в инете он у меня вроде как стоит, но почему тогда его не видит net-cat ? не та версия? как тогда установить мою? или отчего эта ошибка может быть еще?
 

Pernat1y

Well-known member
05.04.2018
1 443
135
BIT
0
ошибка вышла, у меня в параллель еще и 3.8.6 стоит, где ошибся?
почему же тогда net-creds не ставится?
python2 и python3 вполне себе могут стоят параллельно. Пакеты у них ставятся отдельно, поэтому проверь, что под второй ты тоже scapy поставил.
 

Niko20

Member
22.10.2020
9
0
BIT
0
python2 и python3 вполне себе могут стоят параллельно. Пакеты у них ставятся отдельно, поэтому проверь, что под второй ты тоже scapy поставил.
есть еще какие либо способы установки не через pip2? пишет, что нельзя так сделать
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!