• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Проблема с pkgProblemResolver::Resolve

Sptpower

Member
15.05.2020
5
0
BIT
0
Всем привет, не обновляется система через apt upgrade. Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами. При выполнении команды "apt --fix-broken install" также ошибка.
Снимок экрана_2020-07-01_22-30-12.png
 

Sptpower

Member
15.05.2020
5
0
BIT
0
Побывали ?
#Нет
apt upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Вы можете запустить «apt --fix-broken install» для исправления этих ошибок.
Следующие пакеты имеют неудовлетворённые зависимости:
libexpat1-dev : Зависит: libc6-dev но он не может быть установлен или
libc-dev но он не может быть установлен
libstdc++-8-dev : Зависит: libc6-dev (>= 2.13-5) но он не может быть установлен
E: Неудовлетворённые зависимости. Попытайтесь выполнить «apt --fix-broken install», не указывая имени пакета (или указав решение).
 

mav48

New member
07.07.2020
2
0
BIT
1
Не могу установить ни одну программу.


Код:
root@kali:~# sudo apt-get install tor
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Некоторые пакеты не могут быть установлены. Возможно, то, что вы просите,
неосуществимо, или же вы используете нестабильную версию дистрибутива, где
запрошенные вами пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, вам поможет:

Следующие пакеты имеют неудовлетворённые зависимости:
gsettings-desktop-schemas : Ломает: mutter (< 3.31.4) но 3.30.2-8 должен быть установлен
E: Ошибка: pkgProblemResolver::Resolve привёл к появлению сломанных пакетов. Это может быть вызвано зафиксированными пакетами.
root@kali:~#
Код:
root@kali:~#  sudo apt-get update
Сущ:1 http://mirror-1.truenetwork.ru/kali kali-rolling InRelease
Чтение списков пакетов… Готово           
root@kali:~# sudo apt-get upgrade
Чтение списков пакетов… Готово
Построение дерева зависимостей       
Чтение информации о состоянии… Готово
Расчёт обновлений… Готово
Следующие пакеты будут оставлены в неизменном виде:
  accountsservice apache2 apache2-bin apache2-data apache2-utils appstream
  aspell build-essential chromium chromium-common chromium-driver
  chromium-sandbox clang clang-6.0 colord cpp crunch cutycapt desktop-base
  dnsrecon eog espeak-ng-data evince evince-common evolution-data-server
  exim4-base exim4-config exim4-daemon-light exiv2 fern-wifi-cracker
  firefox-esr folks-common freerdp2-x11 fwupd fwupd-amd64-signed g++ gawk gcc
  gcc-9-base gdisk gedit gedit-common gir1.2-accountsservice-1.0
  gir1.2-evince-3.0 gir1.2-freedesktop gir1.2-glib-2.0 gir1.2-gnomedesktop-3.0
  gir1.2-gst-plugins-base-1.0 gir1.2-gweather-3.0 gir1.2-javascriptcoregtk-4.0
  gir1.2-peas-1.0 gir1.2-rsvg-2.0 gir1.2-soup-2.4 gir1.2-totem-1.0
  gir1.2-vte-2.91 gir1.2-webkit2-4.0 gjs glib-networking
  glib-networking-services gnome-contacts gnome-control-center
  gnome-control-center-data gnome-desktop3-data gnome-font-viewer
  gnome-session gnome-session-bin gnome-session-common gnome-settings-daemon
  gnome-settings-daemon-common gnome-shell gnome-shell-common
  gnome-shell-extension-dashtodock gnome-shell-extension-desktop-icons
  gnome-shell-extension-workspaces-to-dock gnome-shell-extensions
  gnome-software gnome-software-common gnome-system-monitor gnome-terminal
  gnome-terminal-data gnome-theme-kali grilo-plugins-0.3 groff-base
  gsettings-desktop-schemas gstreamer1.0-gl gstreamer1.0-libav
  gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good
  gstreamer1.0-plugins-ugly gstreamer1.0-pulseaudio gstreamer1.0-x
  gtk2-engines-murrine guile-2.2-libs guymager gvfs gvfs-backends gvfs-common
  gvfs-daemons gvfs-fuse gvfs-libs hashcat hwloc i965-va-driver
  impacket-scripts inetsim intel-media-va-driver iproute2 iptables
  kali-defaults kali-desktop-core kali-desktop-gnome kali-linux-default
  kali-menu king-phisher kismet-capture-linux-wifi kismet-core lib32stdc++6
  libaccountsservice0 libalgorithm-diff-xs-perl libaom0 libapache2-mod-php
  libappstream4 libasan5 libasound2 libasound2-data libasound2-plugins
  libaspell15 libavcodec58 libavfilter7 libavformat58 libavresample4
  libavutil56 libblockdev-part2 libbrotli1 libc-bin libc-dev-bin libc6
  libc6-dev libc6-i386 libcairo-gobject-perl libcairo-perl libcamel-1.2-62
  libchromaprint1 libclang-common-6.0-dev libclang1-6.0 libclutter-1.0-0
  libcolord2 libcrypt-ssleay-perl libcupsfilters1 libdbd-mysql-perl
  libdbi-perl libdc1394-22 libde265-0 libdjvulibre21 libdrm-amdgpu1 libdrm2
  libebackend-1.2-10 libedataserverui-1.2-2 libegl-mesa0 libenchant1c2a
  libespeak-ng1 libevdocument3-4 libevview3-3 libexempi8 libexif12 libfaad2
  libfcgi-perl libfile-fcntllock-perl libflite1 libfolks-eds25 libfolks25
  libfreerdp-client2-2 libfreerdp2-2 libgail-common libgail18 libgbm1
  libgcab-1.0-0 libgd3 libgeos-c1v5 libgexiv2-2 libgfortran5
  libgirepository-1.0-1 libgjs0g libgl1-mesa-dri libglapi-mesa
  libglib-object-introspection-perl libglib-perl libglib2.0-0 libglib2.0-bin
  libglibmm-2.4-1v5 libglx-mesa0 libgme0 libgnome-bluetooth13 libgphoto2-6
  libgs9 libgs9-common libgstreamer-gl1.0-0 libgstreamer-plugins-bad1.0-0
  libgstreamer-plugins-base1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin
  libgtk2.0-0 libgtk2.0-bin libguytools2 libharfbuzz-icu0 libhtml-parser-perl
  libhttp-message-perl libical3 libicu63 libinput10 libip4tc2 libip6tc2
  libiptc0 libiw30 libjavascriptcoregtk-4.0-18 liblapack3 liblcms2-2
  liblilv-0-0 libllvm6.0 libllvm8 liblocale-gettext-perl
  libmath-random-isaac-xs-perl libmongoc-1.0-0 libmp3lame0 libmpcdec6
  libnautilus-extension1a libnet-dbus-perl libnet-dns-sec-perl
  libnet-libidn-perl libnet-ssleay-perl libnginx-mod-http-auth-pam
  libnginx-mod-http-dav-ext libnginx-mod-http-echo libnginx-mod-http-geoip
  libnginx-mod-http-image-filter libnginx-mod-http-subs-filter
  libnginx-mod-http-upstream-fair libnginx-mod-http-xslt-filter
  libnginx-mod-mail libnginx-mod-stream libnss-myhostname libnss-systemd
  libofa0 libomp-dev libopenjp2-7 libopenmpt0 libpam-systemd libpeas-1.0-0
  libphonenumber7 libpng16-16 libpocl2 libpocl2-common libpoppler-glib8
  libpoppler82 libpostproc55 libpulse-mainloop-glib0 libpulse0 libpulsedsp
  libpython-dev libpython-stdlib libpython2-dev libpython2-stdlib libpython2.7
  libpython2.7-dev libpython2.7-minimal libpython2.7-stdlib libpython3-dev
  libpython3-stdlib libqt5charts5 libqt5concurrent5 libqt5core5a libqt5dbus5
  libqt5designer5 libqt5gui5 libqt5help5 libqt5multimedia5
  libqt5multimedia5-plugins libqt5multimediagsttools5 libqt5multimediawidgets5
  libqt5network5 libqt5opengl5 libqt5positioning5 libqt5printsupport5
  libqt5qml5 libqt5quick5 libqt5sensors5 libqt5sql5 libqt5sql5-sqlite
  libqt5svg5 libqt5test5 libqt5webchannel5 libqt5webkit5 libqt5widgets5
  libqt5xml5 libradare2-dev librados2 librsvg2-2 librsvg2-common
  librubberband2 libsane libselinux1 libsemanage-common libsemanage1
  libsensors5 libserd-0-0 libslang2 libsmbclient libsndfile1 libsocket6-perl
  libsoup2.4-1 libsoxr0 libspeex1 libspeexdsp1 libsqlite3-0 libsratom-0-0
  libswresample3 libswscale5 libsystemd0 libtag1v5 libtag1v5-vanilla libtcl8.6
  libtdb1 libterm-readkey-perl libtext-charwidth-perl libtext-iconv-perl
  libtiff5 libtk8.6 libtotem0 libtracker-control-2.0-0 libtracker-miner-2.0-0
  libtracker-sparql-2.0-0 libtwolame0 libudev1 libvisual-0.4-0 libvpx6
  libvte-2.91-0 libvulkan1 libwbclient0 libwebkit2gtk-4.0-37 libwinpr2-2
  libxatracker2 libxml-parser-perl libxml2 libxslt1.1 libxtables12
  libxvidcore4 libyara3 libzvbi-common libzvbi0 linux-headers-amd64 llvm-6.0
  llvm-6.0-dev llvm-6.0-runtime locales login mailutils mailutils-common
  mariadb-client-10.3 mariadb-client-core-10.3 mariadb-server-10.3
  mariadb-server-core-10.3 mawk mesa-va-drivers mesa-vdpau-drivers
  metasploit-framework mitmproxy mutter nautilus nautilus-data
  nautilus-extension-gnome-terminal ndiff netsniff-ng nginx nginx-common
  nginx-full nmap nmap-common openjdk-11-jre openjdk-11-jre-headless
  openssh-client openssh-server openssh-sftp-server ophcrack ophcrack-cli
  passwd perl perl-base php php-common plymouth plymouth-label pocl-opencl-icd
  polenum poppler-utils postgresql pulseaudio pulseaudio-module-bluetooth
  pulseaudio-utils python python-babel-localedata python-cffi-backend
  python-dev python-enchant python-faraday python-gi python-gobject
  python-minimal python-numpy python-pastedeploy-tpl python2 python2-dev
  python2-minimal python2.7 python2.7-dev python2.7-minimal python3
  python3-apt python3-brlapi python3-brotli python3-cairo python3-cffi-backend
  python3-cups python3-dbus python3-dev python3-distutils python3-gi
  python3-gi-cairo python3-jsonschema python3-kiwisolver python3-lib2to3
  python3-lxml python3-mako python3-markupsafe python3-matplotlib
  python3-maxminddb python3-minimal python3-mpltoolkits.basemap
  python3-msgpack python3-mysqldb python3-numpy python3-protobuf
  python3-psycopg2 python3-pycryptodome python3-pycurl python3-pyproj
  python3-pyqtgraph python3-ruamel.yaml python3-scipy python3-simplejson
  python3-sip python3-smbc python3-sqlalchemy python3-sqlalchemy-ext
  python3-tk python3-tornado python3-urwid python3-yaml qt5-gtk-platformtheme
  radare2 reaver ruby ruby-atomic ruby-dev ruby-ffi ruby-json ruby-nokogiri
  ruby-yajl rubygems-integration samba samba-common samba-common-bin
  samba-dsdb-modules samba-libs samba-vfs-modules sane-utils screen set
  smbclient smbmap snmp snmpd sqlite3 sqlitebrowser systemd theharvester totem
  totem-plugins tracker tracker-extract tracker-miner-fs tshark udev
  unattended-upgrades util-linux vim vim-common vim-runtime vim-tiny whois
  winexe wireshark wireshark-common wireshark-qt wpasupplicant x11-apps
  xbrlapi xserver-xephyr xserver-xorg-core xserver-xorg-video-intel xwayland
  zsh zsh-common
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 514 пакетов не обновлено.
root@kali:~#
 

Вложения

  • Снимок экрана от 2020-07-07 18-43-13.png
    Снимок экрана от 2020-07-07 18-43-13.png
    158,9 КБ · Просмотры: 733
Последнее редактирование:
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!