• B правой части каждого сообщения есть стрелки и . Не стесняйтесь оценивать ответы. Чтобы автору вопроса закрыть свой тикет, надо выбрать лучший ответ. Просто нажмите значок в правой части сообщения.

  • Курсы Академии Кодебай, стартующие в мае - июне, от команды The Codeby

    1. Цифровая криминалистика и реагирование на инциденты
    2. ОС Linux (DFIR) Старт: 16 мая
    3. Анализ фишинговых атак Старт: 16 мая Устройства для тестирования на проникновение Старт: 16 мая

    Скидки до 10%

    Полный список ближайших курсов ...

Python

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15
Всем привет, подскажите как исправить

@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# python simple_IMSI-catcher.py --sniff
Traceback (most recent call last):
File "simple_IMSI-catcher.py", line 536, in <module>
from scapy.all import sniff, UDP
ImportError: No module named scapy.all
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15
apt-upgrade выполнил тоже

pip install scapy
попробуй

теперь получаю следующее

/usr/lib/python2.7/dist-packages/matplotlib/font_manager.py:273: UserWarning: Matplotlib is building the font cache using fc-list. This may take a moment.
warnings.warn('Matplotlib is building the font cache using fc-list. This may take a moment.')
Nb IMSI ; TMSI-1 ; TMSI-2 ; IMSI ; country ; brand ; operator ; MCC ; MNC ; LAC ; CellId ; Timestamp

так понимаю нужно подождать
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15


python3 simple_IMSI-catcher.py --sniff


space:/home/enceladus/Рабочий стол/IMSI-catcher-master# python3 simple_IMSI-catcher.py --sniff
Traceback (most recent call last):
File "simple_IMSI-catcher.py", line 536, in <module>
from scapy.all import sniff, UDP
ImportError: No module named 'scapy'

так же и
@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# add-apt-repository -y ppa:ptrkrysik/gr-gsm
Cannot add PPA: 'ppa:~ptrkrysik/ubuntu/gr-gsm'.
The user named '~ptrkrysik' has no PPA named 'ubuntu/gr-gsm'
Please choose from the following available PPAs:


и
@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# apt install python3-numpy python3-scipy python3-scapyЧтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Невозможно найти пакет python3-scapy

Благодарю что отозвался
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15
Подключен HackRF One, станции ищет,

@space:~/kalibrate-hackrf# kal -s GSM900
kal: Scanning for GSM-900 base stations.
GSM-900:
chan: 4 (935.8MHz + 34.886kHz) power: 686834.07
chan: 5 (936.0MHz + 16.656kHz) power: 742341.43
chan: 6 (936.2MHz + 11.197kHz) power: 814920.14
chan: 7 (936.4MHz - 30.773kHz) power: 882496.87
chan: 11 (937.2MHz - 5.954kHz) power: 879519.99
chan: 16 (938.2MHz + 30.381kHz) power: 831308.27
chan: 17 (938.4MHz + 5.967kHz) power: 778855.21
chan: 18 (938.6MHz - 7.251kHz) power: 701668.12
chan: 19 (938.8MHz - 38.253kHz) power: 783627.75
chan: 26 (940.2MHz + 31.712kHz) power: 2066368.45
chan: 27 (940.4MHz + 7.214kHz) power: 2089487.87
chan: 28 (940.6MHz + 19.311kHz) power: 2181443.56
chan: 29 (940.8MHz - 18.337kHz) power: 2241655.85
chan: 30 (941.0MHz - 30.807kHz) power: 2239956.42
chan: 58 (946.6MHz + 19.292kHz) power: 396961.08
chan: 59 (946.8MHz - 5.695kHz) power: 435373.14
chan: 60 (947.0MHz - 30.681kHz) power: 446653.54
chan: 87 (952.4MHz + 32.208kHz) power: 466970.81
chan: 88 (952.6MHz + 7.275kHz) power: 574137.69
chan: 89 (952.8MHz - 5.775kHz) power: 380797.91


пытаюсь по инструкции

снимок_6.png
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15
Пробую, получаю ответы что выше отправил(


может ты лучше по этой инструкции попробуй)
Код:
@space:~# python3.5 --version
Python 3.5.2

@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# python3 simple_IMSI-catcher.py --sniff
Traceback (most recent call last):
  File "simple_IMSI-catcher.py", line 536, in <module>
    from scapy.all import sniff, UDP
ImportError: No module named 'scapy'

@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# pip install scapy
WARNING: pip is being invoked by an old script wrapper. This will fail in a future version of pip.
Please see ImportError in system pip wrappers after an upgrade · Issue #5599 · pypa/pip for advice on fixing the underlying issue.
To avoid this problem you can invoke Python with '-m pip' instead of running pip directly.
/usr/local/lib/python2.7/dist-packages/pip/_vendor/requests/__init__.py:83: RequestsDependencyWarning: Old version of cryptography ([1, 2, 3]) may cause slowdown.
  warnings.warn(warning, RequestsDependencyWarning)
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at Release process — pip 20.1.dev0 documentation
Requirement already satisfied: scapy in /usr/local/lib/python2.7/dist-packages (2.4.3)
Не понимаю, говорит что версия не поддерживается, хотя пишет что 3.5 установлен
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15

может ты лучше по этой инструкции попробуй)

если я правильно понял то это оно?)
Код:
@space:/home/enceladus/Рабочий стол/IMSI-catcher-master# python2 simple_IMSI-catcher.py --sniff
Nb IMSI ; TMSI-1     ; TMSI-2     ; IMSI              ; country      ; brand      ; operator              ; MCC  ; MNC   ; LAC    ; CellId ; Timestamp
1       ;            ;            ; 250 01 8542774194 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 1     ; 12     ;        ; 2020-02-25T22:36:50.378667
2       ;            ;            ; 250 01 8855782435 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:01.271495
3       ;            ;            ; 250 01 8853034426 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:04.182325
4       ;            ;            ; 250 01 8505115580 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:13.006371
5       ;            ;            ; 250 01 8854093320 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:25.336710
6       ;            ;            ; 250 01 8852762028 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:25.769692
7       ;            ;            ; 250 01 8854032070 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:26.089500
8       ; 0x26bbb484 ;            ; 250 01 8855500258 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:37:44.174372
9       ;            ;            ; 250 01 8542868230 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:38:02.980263
10      ;            ;            ; 250 01 8854820024 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:38:16.729939
11      ;            ;            ; 250 01 8855377631 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:38:55.268199
12      ;            ;            ; 250 01 8854588119 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:39:40.350604
13      ;            ;            ; 250 01 8854605613 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:39:45.114984
14      ; 0x17c57beb ;            ; 250 01 8542366648 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:39:59.199917
15      ;            ;            ; 250 01 8850866257 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:41:50.078308
16      ;            ;            ; 250 01 8855160404 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:42:01.629250
17      ;            ;            ; 250 01 8855351163 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:42:12.408598
18      ; 0x13c05e4c ;            ; 250 01 8542296610 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:42:18.100967
19      ;            ;            ; 250 01 8856588141 ; Russian Federation ; MTS        ; Mobile TeleSystems    ; 250  ; 01    ; 12     ; 72     ; 2020-02-25T22:42:52.562013



@space:/home/enceladus# apt install python3-scapy
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Невозможно найти пакет python3-scapy
 

f22

Codeby Academy
Gold Team
05.05.2019
1 841
225
BIT
1 042
Не понимаю, говорит что версия не поддерживается, хотя пишет что 3.5 установлен
Как раз наоборот, говорит, что python2 устарел
pip3 install scapy

И выполни
echo 'alias pip="pip3"' >> ~/.bashrc
У тебя pip используется для версии 2.7, а тебе нужна 3.

Можешь такой же алиас добавить для вызова python
echo 'alias python="python3"' >> ~/.bashrc
 

zxv_zz

Well-known member
26.12.2019
97
0
BIT
15
Как раз наоборот, говорит, что python2 устарел
pip3 install scapy

И выполни
echo 'alias pip="pip3"' >> ~/.bashrc
У тебя pip используется для версии 2.7, а тебе нужна 3.

Можешь такой же алиас добавить для вызова python
echo 'alias python="python3"' >> ~/.bashrc

Благодарю! Отпишу по результату!

Как раз наоборот, говорит, что python2 устарел
pip3 install scapy

И выполни
echo 'alias pip="pip3"' >> ~/.bashrc
У тебя pip используется для версии 2.7, а тебе нужна 3.

Можешь такой же алиас добавить для вызова python
echo 'alias python="python3"' >> ~/.bashrc


Все заработало, спасибо!

Как раз наоборот, говорит, что python2 устарел
pip3 install scapy

И выполни
echo 'alias pip="pip3"' >> ~/.bashrc
У тебя pip используется для версии 2.7, а тебе нужна 3.

Можешь такой же алиас добавить для вызова python
echo 'alias python="python3"' >> ~/.bashrc

Теперь другие коники выкидывает........

root@space:/home/enceladus# grgsm_scanner
linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown


ARFCN: 1016, Freq: 933.4M, CID: 0, LAC: 17, MCC: 250, MNC: 1, Pwr: -40
ARFCN: 2, Freq: 935.4M, CID: 6513, LAC: 17, MCC: 250, MNC: 1, Pwr: -20
ARFCN: 27, Freq: 940.4M, CID: 0, LAC: 0, MCC: 0, MNC: 0, Pwr: -30
ARFCN: 32, Freq: 941.4M, CID: 41217, LAC: 61345, MCC: 250, MNC: 99, Pwr: -23
ARFCN: 37, Freq: 942.4M, CID: 61847, LAC: 61345, MCC: 250, MNC: 99, Pwr: -37
ARFCN: 44, Freq: 943.8M, CID: 0, LAC: 61345, MCC: 250, MNC: 99, Pwr: -42
ARFCN: 56, Freq: 946.2M, CID: 0, LAC: 0, MCC: 0, MNC: 0, Pwr: -20
ARFCN: 69, Freq: 948.8M, CID: 932, LAC: 6122, MCC: 250, MNC: 2, Pwr: -30
ARFCN: 71, Freq: 949.2M, CID: 27401, LAC: 6122, MCC: 250, MNC: 2, Pwr: -26
ARFCN: 113, Freq: 957.6M, CID: 7951, LAC: 6122, MCC: 250, MNC: 2, Pwr: -29
root@space:/home/enceladus# grgsm_livemon -f 949.2M
linux; GNU C++ version 5.3.1 20151219; Boost_105800; UHD_003.009.002-0-unknown


(process:12635): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(python2:12635): GConf-WARNING **: Client failed to connect to the D-BUS daemon:
Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_register_object: assertion 'G_IS_DBUS_CONNECTION (connection)' failed

(python2:12635): GLib-GIO-CRITICAL **: g_dbus_connection_get_unique_name: assertion 'G_IS_DBUS_CONNECTION (connection)' failed
Qt: Session management error: None of the authentication protocols specified are supported
gr-osmosdr 0.1.4 (0.1.4) gnuradio 3.7.9
built-in source types: file osmosdr fcd rtl rtl_tcp uhd miri hackrf bladerf rfspace airspy redpitaya
Number of USB devices: 12
USB device 1d50:6089: 0000000000000000c83868dc2c4a89a3 match
Using HackRF One with firmware 2018.01.1
Using Volk machine: sse4_1_32_orc
Traceback (most recent call last):
File "/usr/local/bin/grgsm_livemon", line 355, in <module>
main()
File "/usr/local/bin/grgsm_livemon", line 343, in main
tb = top_block_cls(args=options.args, collector=options.collector, collectorport=options.collectorport, fc=options.fc, gain=options.gain, osr=options.osr, ppm=options.ppm, samp_rate=options.samp_rate, serverport=options.serverport, shiftoff=options.shiftoff)
File "/usr/local/bin/grgsm_livemon", line 172, in __init__
self.blocks_socket_pdu_0_0 = blocks.socket_pdu("UDP_SERVER", "127.0.0.1", serverport, 10000, False)
File "/usr/lib/python2.7/dist-packages/gnuradio/blocks/blocks_swig5.py", line 1042, in make
return _blocks_swig5.socket_pdu_make(type, addr, port, MTU, tcp_no_delay)
RuntimeError: bind: Адрес уже используется
 
Мы в соцсетях:

Обучение наступательной кибербезопасности в игровой форме. Начать игру!