• Профессиональным авторам. Срочный заказ!

    Необходимо сделать развернутое описание каждой из наших услуг. Ограничений на объем текста нет. ЦА - руководство компаний (сухой технический текст). При отсутствии исполнителей среди участников форума, работа будет передана фрилансерам 10 февраля.

    Подробнее о заказе ...

Решено С чего начать изучать Linux?

  • Автор темы Harmful_Fox
  • Дата начала
  • Теги
    linux
Harmful_Fox

Harmful_Fox

Member
09.02.2018
22
2
Здравствуйте, хочу изучить Linux. Посоветуйте дистрибутив максимально дружелюбный для новичка и по которому много информации в сети, а также с чего именно начать.
Как я понял тут два варианта Mint и Ubuntu, но на каком лучше остановится не понятно.
Приколов аля начни с Кали не нужно, я не настолько туп чтобы вестись на это!
 
  • Нравится
Реакции: sklk
ghostphisher

ghostphisher

гарант codeby
Gold Team
07.12.2016
2 531
3 367
Администрирование - вот с чего стоит начинать. Упор делаем на создание сервера для работы с почтой, файлами, веб ( играем в хостинг провайдера ), ставим серверные приложения, заставляем работать.
 
  • Нравится
Реакции: sklk, Vertigo и n01n02h
Х

Хлебушек

Well-known member
19.11.2018
53
52
Как я понял тут два варианта Mint и Ubuntu, но на каком лучше остановится не понятно.
Вариантов на самом деле много. Если выбирать из этих двух, то можете брать любой, который больше нравится внешне. Грубо говоря Mint - это и есть Ubuntu c другим DE (desktop environment).

А так все зависит от того, как собираетесь использовать, от целей. Просто серфить интернет и смотреть фильмаки, то можно вообще ничего не изучать, эти системы уже максимально приближены к винде.
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
Здравствуйте уважаемые форумчане,столкнулся с проблемой установки acestream плеера в linuxmint 19.1 tessa,прошу помощи.
После загрузки и распаковки файла по ссылке (
Ubuntu 18:beta version, amd64 - tar.gz дальше распаковки дело не идет,если использовать snap то происходит другая ошибка -
The command could not be found because ‘/ snap / bin’ is not included in the PATH environment variable.
acestreamplayer.engine: command not found ,
вообщем так я и оказался здесь,хочу добавить я нуб,только начал знакомиться с семейством ubuntu,искал информацию по сети,везде все устарело,в менеджере приложений данный плеер отсутствует,написал разрабам,ответ пока не получил.
Если у кого есть время прошу уделить внимание и помочь в этом вопросе,пошагово.
Спасибо за понимание.
 
V

Valkiria

Вечер, делать нечего.
Мой процесс компилирования OpenWRT для Dlink DIR-320 заканчивается ошибками.
Не собирается прошивка на новом ядре.
Давай хоть с твоим плеером разберёмся )
Если у кого есть время прошу уделить внимание и помочь в этом вопросе,пошагово.
Сразу вопрос.
А че это за плеер и почему твой выбор остановился на нём ?
В нём имеется что-то особенное ?

Ты просматривал наличие готовых пакетов в репозитариях Убунты ?
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
А че это за плеер и почему твой выбор остановился на нём ?
В нём имеется что-то особенное ?
Плеер для просмотра потокового тв на компьютере с различными os/
Плеер лучше транслирует тв программы прямого эфира,лучше чем на сайтах с аналогичными услугами только веб.
Ты просматривал наличие готовых пакетов в репозитариях Убунты ?
Да много где просматривал,пару раз пришлось систему переустанавливать,после проб)) .В Линукс Минт в менеджере приложений и на оф.сайте ace stream,добавить ссылку на репозитарий в систему тоже не получилось,там какая то проблема с ключем,матюкается
 
V

Valkiria

Давай по-порядку.
Ты хочешь установить в Минт или в Убунту ?
А то я уже запуталась в твоих ОС.
Мне надо знать, имеется ли возможность установить из репозитория или придётся собирать программу.
Для просмотра ТВ у тебя должно быть соответствующее оборудование - тв приёмник, USB или PCI. Оно имеется у тебя ?
Или ты желаешь смотреть ТВ не эфирное, а интернет ТВ ?
Старайся быть точным.
Старайся писать грамотно, от этого зависит скорейшее решение твоих проблем.

О менеджере приложений забудь, мы будем пользоваться консольными командами.
 
  • Нравится
Реакции: Fijee и sklk
sklk

sklk

Active member
26.01.2019
40
7
Ты хочешь установить в Минт или в Убунту ?
LinuxMint 19.1 Tessa
Мне надо знать, имеется ли возможность установить из репозитория или придётся собирать программу.
в репозитарии старая версия плеера,но сам deb пакет с этим acestream необходимо еще добавить в репозитарий LinuxMint 19.1 Tessa,а там сразу проблема с ключем.
Для просмотра ТВ у тебя должно быть соответствующее оборудование - тв приёмник, USB или PCI. Оно имеется у тебя ?
Или ты желаешь смотреть ТВ не эфирное, а интернет ТВ ?
Да интернет тв.
О менеджере приложений забудь, мы будем пользоваться консольными командами.
хорошо,я буду стараться.
 
  • Нравится
Реакции: Valkiria
awareness

awareness

New member
13.11.2018
3
4
Здравствуйте уважаемые форумчане,столкнулся с проблемой установки acestream плеера в linuxmint 19.1 tessa,прошу помощи.
После загрузки и распаковки файла по ссылке (
Ubuntu 18:beta version, amd64 - tar.gz дальше распаковки дело не идет,если использовать snap то происходит другая ошибка -
The command could not be found because ‘/ snap / bin’ is not included in the PATH environment variable.
acestreamplayer.engine: command not found ,
вообщем так я и оказался здесь,хочу добавить я нуб,только начал знакомиться с семейством ubuntu,искал информацию по сети,везде все устарело,в менеджере приложений данный плеер отсутствует,написал разрабам,ответ пока не получил.
Если у кого есть время прошу уделить внимание и помочь в этом вопросе,пошагово.
Спасибо за понимание.
Я устанавливал себе на Linux Mint 19, пользуясь этой статьей:

У меня тогда получилось без проблем.
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
Я устанавливал себе на Linux Mint 19, пользуясь этой статьей:

У меня тогда получилось без проблем.
Да пробовал и этот вариант,матюкается на шаге запуска ,
Команда не найдена, поскольку / snap / bin не включена в переменную среды PATH.
acestreamplayer.engine: команда не найдена,искал как исправить,но что то не получилось.
 
V

Valkiria

А ты не пробовал скачать deb пакеты и установить их с помощью установщика gdebi ?

Давай попробует установить эту программулину из deb пакетов.
Но прежде чем что-то скачивать, проверим такую возможность.
Попробуй для начала установить установщик gdebi:
Код:
sudo apt install gdebi
Напиши, что получилось ))

Если проблем нет, то скачай пакеты вот по этой ссылке, но выбери свою разрядность.

Когда файлы будут загружены, перейдите в папку с ними:
cd ~/Загрузки/
И попробуй по очереди установить.
Код:
$ gdebi acestream-engine_3.0.5.1-0.2_amd64.deb
$ gdebi acestream-player-compat_3.0.2-1-1_amd64.deb
$ gdebi acestream-player-data_3.0.2-1.1_amd64.deb
$ gdebi acestream-player_3.0.2-1.1_amd64.deb
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
Напиши, что получилось ))
E: Не удалось получить файл блокировки /var/lib/dpkg/lock-frontend - open (11: Ресурс временно недоступен)
E: Невозможно получить блокировку внешнего интерфейса dpkg (/var/lib/dpkg/lock-frontend); она уже используется другим процессом?
 
V

Valkiria

Убей этот процесс.
Комaнда
Код:
ps -A

Выделение_001.png


Затем найди номер процесса .
Убей командой
Код:
kill 1458-это номер процесса

Или вот такой командой
Код:
sudo fuser -vki /var/lib/dpkg/lock
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
А ты не пробовал скачать deb пакеты и установить их с помощью установщика gdebi ?
yus@yus-Lenovo-ideapad-110-15ACL:~/Загрузки$ gdebi acestream-engine_3.0.5.1-0.2_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Требует установки следующих пакетов: libjs-jquery libjs-sphinxdoc libjs-underscore python-appindicator python-apsw python-gobject python-m2crypto python-typing

Ace Stream HD
Ace Stream (formerly TorrentStream) is an innovative multimedia platform of a
new generation, which includes different products and solutions for ordinary
Internet users as well as for professional members of the multimedia market.
Ace Stream uses in its core, P2P technology, BitTorrent protocol, which is
acknowledged as the most effective protocol to transfer/deliver "heavy content"
Для установки пакетов необходимо быть суперпользователем
yus@yus-Lenovo-ideapad-110-15ACL:~/Загрузки$ gdebi acestream-player-compat_3.0.2-1-1_amd64.deb
gdebi error, file not found: acestream-player-compat_3.0.2-1-1_amd64.deb
yus@yus-Lenovo-ideapad-110-15ACL:~/Загрузки$ gdebi acestream-player-data_3.0.2-1.1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Этот пакет невозможно установить
Dependency is not satisfiable: libass5

yus@yus-Lenovo-ideapad-110-15ACL:~/Загрузки$ gdebi acestream-player_3.0.2-1.1_amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
Этот пакет невозможно установить
Dependency is not satisfiable: acestream-player-data (>= 3.0.2)
-------------------------------------------------------------------------------------------------------
вот что получилось после того как сработала первая команда sudo apt install gdebi
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет gdebi самой новой версии (0.9.5.7xmint8).
Следующие пакеты устанавливались автоматически и больше не требуются:
libxnvctrl0 psensor-common
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 0 пакетов не обновлено.
 
sklk

sklk

Active member
26.01.2019
40
7
перед этим загрузил четыре файла amd64.deb по очереди ( )
 
V

Valkiria

Понятно.
Куча неудовлетворённых зависимостей.
Это Линукс ))

Прежде чем продолжить удовлетворять капризы линукса, давай всё-таки попробуем более простой способ - подключим репозиторий и попытаемся из хранилища установить ))
Потому что удовлетворять все эти зависимости - долго и неграмотно.

Кстати, для порядка запусти команду для очистки системы от ненужного хлама.
Код:
sudo apt autoremove
Но это к делу не относится.

Попробуй подключить репозиторий.
Выполни команду
Код:
echo 'deb http://repo.acestream.org/ubuntu/ trusty main' | sudo tee /etc/apt/sources.list.d/acestream.list
Этой командой ты внесёшь изменения в список репозиториев.
А далее нужно ключ скачать и установить, без ключа репозиторий не подключится.

Код:
sudo wget -O - http://repo.acestream.org/keys/acestream.public.key | sudo apt-key add -
И устанавливай
Код:
sudo apt-get update
sudo apt-get install acestream-full
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
:~$ sudo apt-get update
Сущ:1 bionic InRelease
Сущ:2 bionic InRelease
Пол:3 trusty InRelease [2.181 B]
Пол:4 bionic-updates InRelease [88,7 kB]
Пол:5 bionic-security InRelease [88,7 kB]
Игн:6 tessa InRelease
Сущ:7 tessa Release
Пол:8 bionic-backports InRelease [74,6 kB]
Ошб:3 trusty InRelease
Следующие подписи неверны: E1254F21D636B7EFDE41D2AF50E2BCF0E3805CD8
Пол:9 bionic-updates/main i386 Packages [438 kB]
Пол:11 bionic-updates/main amd64 Packages [504 kB]
Пол:12 bionic-updates/main Translation-en [189 kB]
Пол:13 bionic-updates/main amd64 DEP-11 Metadata [278 kB]
Пол:14 bionic-updates/universe i386 Packages [708 kB]
Пол:15 bionic-updates/universe amd64 Packages [717 kB]
Пол:16 bionic-updates/universe amd64 DEP-11 Metadata [202 kB]
Пол:17 bionic-security/main amd64 DEP-11 Metadata [204 B]
Пол:18 bionic-updates/multiverse amd64 DEP-11 Metadata [2.468 B]
Пол:19 bionic-backports/universe amd64 DEP-11 Metadata [7.344 B]
Пол:20 bionic-security/universe amd64 DEP-11 Metadata [20,8 kB]
Пол:21 bionic-security/multiverse amd64 DEP-11 Metadata [2.464 B]
Чтение списков пакетов… Готово
W: Ошибка GPG: trusty InRelease: Следующие подписи неверны: E1254F21D636B7EFDE41D2AF50E2BCF0E3805CD8
E: Репозиторий « trusty InRelease» не подписан.
N: Обновление из этого репозитория нельзя выполнить безопасным способом, поэтому по умолчанию он отключён.
N: Информацию о создании репозитория и настройке пользователя смотрите в справочной странице apt-secure(8).
yus@yus-Lenovo-ideapad-110-15ACL:~$ sudo apt-get install acestream-full
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
E: Невозможно найти пакет acestream-full
-------------------------------------------------------------------------------------
матюкается
 
V

Valkiria

Это потому что ключ не подходит ))
Надо искать репозиторий и ключ.
Так будет правильно.
Предлагаю вместе погуглить и поискать правильный ключ от этого репозитория для Linux MINT или другой репозиторий с ключом.
Это будет самый правильный и простой способ.


Можно ещё удовлетворить все зависимости и установить способом, выше. Из скачанных пакетов DEB и утилиты dpkg.
Но это не совсем верное решение, хотя иногда оно бывает единственно верным. Когда очень хочется, но не можется )
С моих советов люди смеяться будут ))


Но можно собрать из исходников - это будет хорошо.
 
  • Нравится
Реакции: sklk
sklk

sklk

Active member
26.01.2019
40
7
а как убить это
Ошибка GPG: trusty InRelease: Следующие подписи неверны: E1254F21D636B7EFDE41D2AF50E2BCF0E3805CD8Репозиторий « trusty InRelease» не подписан.
в synaptic
 
Мы в соцсетях: