Проблема Запуск fern wifi cracker используя python3

D

Dog1709

Member
13.05.2019
6
0
После обновления fern wifi cracker, при попытке запустить его, execute.py выдает ошибку, что я пытаюсь запустить программу используя python2.7 а нужно 3. Python 3 в Kali ставил, но вот как заставить запускаться программу используя python3 не знаю. Подскажите решение.
 
explorer

explorer

Red Team
05.08.2018
789
1 697
Элементарно Ватсон )

cd /usr/share/fern-wifi-cracker/
/usr/share/fern-wifi-cracker# python3 execute.py
 
D

Dog1709

Member
13.05.2019
6
0
Элементарно Ватсон )

cd /usr/share/fern-wifi-cracker/
/usr/share/fern-wifi-cracker# python3 execute.py
Ваша подсказка дала положительный результат в решении моего вопроса)) Все шло более менее хорошо. Я установил python3-pip который запрашивала программа. Далее, появилась проблема, касательно отсутствия scapys (являясь полным ламером не понимаю о чем идет речь в 90% случаях). Пытался решить вопрос установкой scapys (sudo apt-get install python-scapy). Впадаю в отчаяние и прихожу на форум, только когда гугл перестает выдавать дельные советы. (скин экрана прилагаю). Надеюсь у вас есть мысли, которые помогут мне в данном вопросе XD
 

Вложения

explorer

explorer

Red Team
05.08.2018
789
1 697
Попробуйте так:
pip3 install scapy-python3
 
D

Dog1709

Member
13.05.2019
6
0
Попробуйте так:
pip3 install scapy-python3
Финальный отчет, проблему пофиксить удалось) Ваш совет продвинул решение дальше. После возникла проблема (скрин забыл вовремя сделать) связанная с всплывающей ошибкой о том, что scapy был переименован в kamene и дословно ( You should use either pip package kamene for scapy3k). Далее брал информацию с форумов github'а. Использовал данную ссылку git clone github.com/secdev/scapy и следующие команды $ cd scapy, $ sudo python3 setup.py install. Fern заработал)
 
W

WhiteHacK

Active member
18.08.2019
39
7
Заранее извиняюсь что может быть не в ту тему, но все же, кто нибудь уже крякнул новую версию ту которая платная (не опенсорс) ?
 
Мы в соцсетях: