Проблема Изменить имя внешнего сетевого интерфейса

loadreb

loadreb

Member
17.12.2019
7
2
Произошел казус с внешним сетевым интерфейсом,по не известным мне причинам он изменил имя с WLAN1 на wlx00c0caa7459f , как его заставить преобрести обычное свое имя WLAN1 ?
 
f22

f22

Red Team
05.05.2019
1 095
91
Произошел казус с внешним сетевым интерфейсом,по не известным мне причинам он изменил имя с WLAN1 на wlx00c0caa7459f , как его заставить преобрести обычное свое имя WLAN1 ?
Временное решение
ip link set wlx00c0caa7459f name wlan1

Либо для в файле /etc/default/grub
Замени строку
GRUB_CMDLINE_LINUX=""
на
GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"

И сгенерируй новый grub командой
sudo grub-mkconfig -o /boot/grub/grub.cfg
 
loadreb

loadreb

Member
17.12.2019
7
2
Временное решение
ip link set wlx00c0caa7459f name wlan1

RTNETLINK answers: Device or resource busy

Либо для в файле /etc/default/grub
Замени строку
GRUB_CMDLINE_LINUX=""
на
GRUB_CMDLINE_LINUX="net.ifnames=0 biosdevname=0"
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
# info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz"

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

Нет такой строки но есть похожие,к сожелению я не так селен.Спасибо.
 
f22

f22

Red Team
05.05.2019
1 095
91
Через пробел добавь
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz net.ifnames=0 biosdevname=0"
 
loadreb

loadreb

Member
17.12.2019
7
2
Через пробел добавь
Код:
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz net.ifnames=0 biosdevname=0"
Попробовал,нет ни чего не происходит,все по старому,имя не изменилось на wlan1,я делал так
Код:
GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz"
через пробел от нижней строчки добавил
Код:
GRUB_CMDLINE_LINUX="initrd=/install/initrd.gz net.ifnames=0 biosdevname=0"
потом попробовал удалив 4 строчку и написал вместо нее эту строку.
И все это через
Код:
sudo grub-mkconfig -o /boot/grub/grub.cfg
и перезагрузку.
Не помогает.
 
loadreb

loadreb

Member
17.12.2019
7
2
Спасибо.Нашел следующее решение этой проблемы

Код:
GRUB_CMDLINE_LINUX_DEFAULT="net.ifnames=0"
вместо третьей строчки

Код:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
 
Мы в соцсетях: